aboutsummaryrefslogtreecommitdiff
path: root/textproc/yq/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/yq/Makefile')
-rw-r--r--textproc/yq/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/textproc/yq/Makefile b/textproc/yq/Makefile
index 2ad2df3e7348..ffe33d01ca00 100644
--- a/textproc/yq/Makefile
+++ b/textproc/yq/Makefile
@@ -1,5 +1,5 @@
PORTNAME= yq
-DISTVERSION= 3.4.1
+DISTVERSION= 3.4.2
CATEGORIES= textproc python
MASTER_SITES= PYPI
@@ -10,7 +10,9 @@ WWW= https://kislyuk.github.io/yq/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=3.4.3:devel/py-setuptools-scm@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=7:devel/py-setuptools-scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= jq:textproc/jq \
${PYTHON_PKGNAMEPREFIX}argcomplete>=1.8.1:devel/py-argcomplete@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyaml>=5.3.1:textproc/py-pyaml@${PY_FLAVOR} \
@@ -23,7 +25,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}build>0:devel/py-build@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
USES= python shebangfix
-USE_PYTHON= distutils noflavors autoplist
+USE_PYTHON= pep517 noflavors autoplist
SHEBANG_FILES= test/test.py