aboutsummaryrefslogtreecommitdiff
path: root/www/hotcrp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/hotcrp/Makefile')
-rw-r--r--www/hotcrp/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/www/hotcrp/Makefile b/www/hotcrp/Makefile
index 625638719171..2c68fa2bdafc 100644
--- a/www/hotcrp/Makefile
+++ b/www/hotcrp/Makefile
@@ -1,27 +1,24 @@
PORTNAME= hotcrp
-PORTVERSION= 2.102
-PORTREVISION= 18
+PORTVERSION= 3.0.0
CATEGORIES= www
-MASTER_SITES= http://www.read.seas.harvard.edu/~kohler/hotcrp/
+MASTER_SITES= ${WWW}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Web based conference management software
+COMMENT= Web-based conference management software
WWW= https://www.read.seas.harvard.edu/~kohler/hotcrp/
-RUN_DEPENDS= pdftohtml:graphics/poppler-utils \
- zip:archivers/zip
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= pdftohtml:graphics/poppler-utils
USES= php mysql:server
-USE_PHP= mysqli gd session ctype
+USE_PHP= ctype gd mysqli session zlib
NO_BUILD= yes
SUB_FILES= pkg-message
-LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
do-install:
- ${MKDIR} ${STAGEDIR}${WWWDIR}
- @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
.include <bsd.port.mk>