aboutsummaryrefslogtreecommitdiff
path: root/www/py-django-simple-history/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-django-simple-history/Makefile')
-rw-r--r--www/py-django-simple-history/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/www/py-django-simple-history/Makefile b/www/py-django-simple-history/Makefile
index 12147e225148..8978fd32c6f6 100644
--- a/www/py-django-simple-history/Makefile
+++ b/www/py-django-simple-history/Makefile
@@ -1,5 +1,6 @@
PORTNAME= django-simple-history
PORTVERSION= 3.5.0
+PORTREVISION= 2
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,12 +12,14 @@ WWW= https://github.com/jazzband/django-simple-history
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=0:devel/py-setuptools-scm@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=0:devel/py-setuptools-scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asgiref>=3.6:www/py-asgiref@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}django32>=0:www/py-django32@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}django42>=0:www/py-django42@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes