aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/hyprland/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/hyprland/Makefile')
-rw-r--r--x11-wm/hyprland/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/x11-wm/hyprland/Makefile b/x11-wm/hyprland/Makefile
index a8860721b9ae..27895402b023 100644
--- a/x11-wm/hyprland/Makefile
+++ b/x11-wm/hyprland/Makefile
@@ -1,11 +1,11 @@
PORTNAME= hyprland
DISTVERSIONPREFIX= v
-DISTVERSION= 0.39.1
+DISTVERSION= 0.40.0
PORTREVISION= 1
CATEGORIES= x11-wm wayland
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES+= 1016faea53fd.patch:-p1 # https://github.com/hyprwm/Hyprland/pull/5653
+PATCHFILES+= ec092bd601d9.patch:-p1 # hyprwayland-scanner 0.3.5
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Dynamic tiling Wayland compositor that doesn't sacrifice on its looks #'
@@ -15,11 +15,13 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
- wayland-protocols>=1.25:graphics/wayland-protocols
+ hyprwayland-scanner>=0.3.5:devel/hyprwayland-scanner \
+ wayland-protocols>=1.35:graphics/wayland-protocols
LIB_DEPENDS= libhyprlang.so:devel/hyprlang \
libtomlplusplus.so:devel/tomlplusplus \
libdrm.so:graphics/libdrm \
libwayland-server.so:graphics/wayland \
+ libuuid.so:misc/e2fsprogs-libuuid \
libwlroots.so:x11-toolkits/wlroots \
libhyprcursor.so:x11/hyprcursor \
libinput.so:x11/libinput \
@@ -37,7 +39,7 @@ GH_TUPLE= hyprwm:hyprland-protocols:v0.2-4-g0c2ce70:hyprland_protocols/subprojec
MESON_ARGS= -Dsystemd=disabled
# Generated by "make update-hash" for commit_pins in hyprpm.toml
-GH_HASH= fe7b748eb668136dd0558b7c8279bfcd7ab4d759
+GH_HASH= cba1ade848feac44b2eda677503900639581c3f4
# XXX Drop after FreeBSD 14.0 EOL around 2025-03-01
.if exists(/usr/lib/libc++.so) && !exists(/usr/include/c++/v1/__format/write_escaped.h)
@@ -71,7 +73,10 @@ post-patch:
-e '/^TAG/s/=.*/=${DISTVERSIONFULL}/' \
-e '/^COMMITS/s/=.*/="?"/' \
${WRKSRC}/scripts/generateVersion.sh
-
+# Respect consolekit2 as XDG_RUNTIME_DIR fallback
+ @${REINPLACE_CMD} 's,/run/user,/var&,' \
+ ${WRKSRC}/hyprctl/main.cpp \
+ ${WRKSRC}/src/Compositor.cpp
# Respect PREFIX for wallpapers
@${REINPLACE_CMD} 's,/usr/share,${DATADIR:H},' \
${WRKSRC}/src/render/OpenGL.cpp