aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-09-06 09:26:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-09-06 09:26:51 +0000
commit0b48d9e7b41602b07bf406fe0d6a658cb33db5a9 (patch)
treecc86a87a56d13222db41b1a55a068967f993b4cf
parent698499d2ec0f0b363835ed8b59be7ef054977c2e (diff)
downloadports-release/10.4.0.tar.gz
ports-release/10.4.0.zip
MFH: r449332release/10.4.0
Fix not starting after crash. When nrpe quits ungracefully, for example, if the box was rebooted, it often does not start because the pid file is still there, and the pid in it exists and the pid in it is in use by some other process. The dubious code is in src/nrpe.c in write_pid_file() around line 1756 that could be axed. But I think the easiest way to fix this is with the attached patch. precmd is run just before starting the daemon and after checking that it is not already running. With this, it starts just fine, and still refuses to start if it is really already running, but starts fine if the pid file contains a pid that exists but is not nrpe. PR: 221740 Submitted by: mat Approved by: maintainer timeout, ports-secteam blanket Sponsored by: Absolight
-rw-r--r--net-mgmt/nrpe/Makefile2
-rw-r--r--net-mgmt/nrpe/files/nrpe2.in1
2 files changed, 2 insertions, 1 deletions
diff --git a/net-mgmt/nrpe/Makefile b/net-mgmt/nrpe/Makefile
index 17e365219d64..f556ce0bb623 100644
--- a/net-mgmt/nrpe/Makefile
+++ b/net-mgmt/nrpe/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nrpe
DISTVERSION= 2.15
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net-mgmt
MASTER_SITES= SF/nagios/${PORTNAME}-2.x/${PORTNAME}-${PORTVERSION}
diff --git a/net-mgmt/nrpe/files/nrpe2.in b/net-mgmt/nrpe/files/nrpe2.in
index 59f94fa5847b..18ce7a07d303 100644
--- a/net-mgmt/nrpe/files/nrpe2.in
+++ b/net-mgmt/nrpe/files/nrpe2.in
@@ -48,6 +48,7 @@ nrpe2_prestart()
{
find_pidfile
install -d -o ${nrpe_user:-nagios} ${pidfile%/*}
+ rm -f ${pidfile}
}
run_rc_command "$1"