aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-06-18 16:51:31 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-06-18 16:51:31 +0000
commit007b1b0d7327750a8768f41ced431bf13ae381df (patch)
tree7e665ad0ea6334f95f831775ed9d361acb502d40
parent7407838e0661d881957172d9afd75528670902fc (diff)
downloadports-007b1b0d7327750a8768f41ced431bf13ae381df.tar.gz
ports-007b1b0d7327750a8768f41ced431bf13ae381df.zip
Notes
-rw-r--r--net/minidlna/Makefile3
-rw-r--r--net/minidlna/distinfo4
-rw-r--r--net/minidlna/files/extra-patch-kqueue100
-rw-r--r--net/minidlna/files/patch-clang-inline137
-rw-r--r--net/minidlna/files/patch-minidlna.conf18
5 files changed, 18 insertions, 244 deletions
diff --git a/net/minidlna/Makefile b/net/minidlna/Makefile
index 2e5d3f5dabfc..35aa6bd9296b 100644
--- a/net/minidlna/Makefile
+++ b/net/minidlna/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= minidlna
-PORTVERSION= 1.1.2
-PORTREVISION= 1
+PORTVERSION= 1.1.3
PORTEPOCH= 1
CATEGORIES= net multimedia www
MASTER_SITES= SF
diff --git a/net/minidlna/distinfo b/net/minidlna/distinfo
index b3ffdb1d733a..10ad84971967 100644
--- a/net/minidlna/distinfo
+++ b/net/minidlna/distinfo
@@ -1,2 +1,2 @@
-SHA256 (minidlna-1.1.2.tar.gz) = 97e2e9141c1190d76ad97f0da083874bccf9f9590841be9eb7668bcf695b7204
-SIZE (minidlna-1.1.2.tar.gz) = 671295
+SHA256 (minidlna-1.1.3.tar.gz) = ed42d5cadf9488a95a0107341918879ef8ce4c650e19337688c46cdcd484bc4e
+SIZE (minidlna-1.1.3.tar.gz) = 481789
diff --git a/net/minidlna/files/extra-patch-kqueue b/net/minidlna/files/extra-patch-kqueue
index 8f049c0bc0d8..20001a26acfa 100644
--- a/net/minidlna/files/extra-patch-kqueue
+++ b/net/minidlna/files/extra-patch-kqueue
@@ -270,22 +270,6 @@
if( id )
{
if( !depth )
-@@ -421,13 +466,13 @@
-
- if( !depth )
- {
-- //DEBUG DPRINTF(E_DEBUG, L_INOTIFY, "Inserting %s\n", name);
-+ DPRINTF(E_DEBUG, L_INOTIFY, "Inserting %s\n", name);
- insert_file(name, path, id+2, get_next_available_id("OBJECTS", id));
- sqlite3_free(id);
- if( (is_audio(path) || is_playlist(path)) && next_pl_fill != 1 )
- {
- next_pl_fill = time(NULL) + 120; // Schedule a playlist scan for 2 minutes from now.
-- //DEBUG DPRINTF(E_WARN, L_INOTIFY, "Playlist scan scheduled for %s", ctime(&next_pl_fill));
-+ //DEBUG DPRINTF(E_WARN, L_INOTIFY, "Playlist scan scheduled for %s", ctime(&next_pl_fill));
- }
- }
- return depth;
@@ -446,6 +491,8 @@
struct media_dir_s* media_path;
struct stat st;
@@ -304,20 +288,6 @@
if( !id )
id = sqlite3_mprintf("%s", BROWSEDIR_ID);
insert_directory(name, path, BROWSEDIR_ID, id+2, get_next_available_id("OBJECTS", id));
-@@ -538,9 +585,12 @@
- int64_t detailID;
- int rows, playlist;
-
-+ DPRINTF(E_DEBUG, L_INOTIFY, "inotify_remove_file: %s\n", path);
-+
- if( ends_with(path, ".srt") )
- {
-- return sql_exec(db, "DELETE from CAPTIONS where PATH = '%q'", path);
-+ rows = sql_exec(db, "DELETE from CAPTIONS where PATH = '%q'", path);
-+ return rows;
- }
- /* Invalidate the scanner cache so we don't insert files into non-existent containers */
- valid_cache = 0;
@@ -554,27 +604,25 @@
{
sql_exec(db, "DELETE from PLAYLISTS where ID = %lld", detailID);
@@ -419,25 +389,6 @@
if( !length )
{
if( next_pl_fill && (time(NULL) >= next_pl_fill) )
-@@ -682,14 +737,14 @@
- }
- else if( length < 0 )
- {
-- if( (errno == EINTR) || (errno == EAGAIN) )
-- continue;
-- else
-+ if( (errno == EINTR) || (errno == EAGAIN) )
-+ continue;
-+ else
- DPRINTF(E_ERROR, L_INOTIFY, "read failed!\n");
- }
- else
- {
-- length = read(pollfds[0].fd, buffer, BUF_LEN);
-+ length = read(pollfds[0].fd, buffer, BUF_LEN);
- }
-
- i = 0;
@@ -707,12 +762,12 @@
sprintf(path_buf, "%s/%s", get_path_from_wd(event->wd), event->name);
if ( event->mask & IN_ISDIR && (event->mask & (IN_CREATE|IN_MOVED_TO)) )
@@ -587,7 +538,7 @@
+ if ( !found_flag )
+ {
+ char * esc_name = NULL;
-+ esc_name = modifyString(strdup(entry->d_name), "&", "&amp;amp;");
++ esc_name = modifyString(strdup(entry->d_name), "&", "&amp;amp;", 0);
+ inotify_insert_directory(global_kqueue_handle, esc_name, tmp_path);
+ free(esc_name);
+ }
@@ -672,7 +623,7 @@
+ continue;
+ }
+
-+ esc_name = modifyString(strdup(entry->d_name), "&", "&amp;amp;");
++ esc_name = modifyString(strdup(entry->d_name), "&", "&amp;amp;", 0);
+ if ( S_ISDIR(st.st_mode) )
+ inotify_insert_directory(global_kqueue_handle, esc_name, tmp_path);
+ else
@@ -721,33 +672,6 @@
" (ID, PATH) "
"VALUES"
" (%lld, %Q)", detailID, file);
-@@ -492,7 +492,7 @@
- m.dlna_pn, song.mime?song.mime:m.mime, album_art);
- if( ret != SQLITE_OK )
- {
-- fprintf(stderr, "Error inserting details for '%s'!\n", path);
-+ DPRINTF(E_ERROR, L_DB_SQL, "Error inserting details for '%s'!\n", path);
- ret = 0;
- }
- else
-@@ -675,7 +675,7 @@
- m.rotation, thumb, m.creator, m.dlna_pn, m.mime);
- if( ret != SQLITE_OK )
- {
-- fprintf(stderr, "Error inserting details for '%s'!\n", path);
-+ DPRINTF(E_ERROR, L_DB_SQL, "Error inserting details for '%s'!\n", path);
- ret = 0;
- }
- else
-@@ -1587,7 +1587,7 @@
- m.mime, album_art);
- if( ret != SQLITE_OK )
- {
-- fprintf(stderr, "Error inserting details for '%s'!\n", path);
-+ DPRINTF(E_ERROR, L_DB_SQL, "Error inserting details for '%s'!\n", path);
- ret = 0;
- }
- else
--- ./minidlna.c.orig 2013-11-02 05:06:41.000000000 +0400
+++ ./minidlna.c 2013-11-13 17:25:27.000000000 +0400
@@ -46,6 +46,7 @@
@@ -790,17 +714,6 @@
#endif
smonitor = OpenAndConfMonitorSocket();
---- ./scanner.c.orig 2013-11-02 05:06:41.000000000 +0400
-+++ ./scanner.c 2013-11-13 17:25:27.000000000 +0400
-@@ -590,7 +590,7 @@
-
- sql_failed:
- if( ret != SQLITE_OK )
-- fprintf(stderr, "Error creating SQLite3 database!\n");
-+ DPRINTF(E_ERROR, L_DB_SQL, "Error creating SQLite3 database!\n");
- return (ret != SQLITE_OK);
- }
-
--- upnpevents.c.orig 2013-11-02 02:06:41.000000000 +0100
+++ upnpevents.c 2013-12-24 12:22:41.533935174 +0100
@@ -416,6 +416,10 @@
@@ -841,12 +754,3 @@
ts = sql_get_int_field(db, "SELECT TIMESTAMP from DETAILS where PATH = '%q'", path);
if( !ts && is_playlist(path) && (sql_get_int_field(db, "SELECT ID from PLAYLISTS where PATH = '%q'", path) > 0) )
{
-@@ -472,7 +483,7 @@
- if( (is_audio(path) || is_playlist(path)) && next_pl_fill != 1 )
- {
- next_pl_fill = time(NULL) + 120; // Schedule a playlist scan for 2 minutes from now.
-- //DEBUG DPRINTF(E_WARN, L_INOTIFY, "Playlist scan scheduled for %s", ctime(&next_pl_fill));
-+ DPRINTF(E_WARN, L_INOTIFY, "Playlist scan scheduled for %s", ctime(&next_pl_fill));
- }
- }
- return depth;
diff --git a/net/minidlna/files/patch-clang-inline b/net/minidlna/files/patch-clang-inline
deleted file mode 100644
index f68c6119f6af..000000000000
--- a/net/minidlna/files/patch-clang-inline
+++ /dev/null
@@ -1,137 +0,0 @@
-diff --git tagutils/misc.c tagutils/misc.c
-index 98ad543..5dc94e5 100644
---- tagutils/misc.c
-+++ tagutils/misc.c
-@@ -30,7 +30,7 @@
-
- #include "misc.h"
-
--inline __u16
-+__u16
- le16_to_cpu(__u16 le16)
- {
- #if __BYTE_ORDER == __LITTLE_ENDIAN
-@@ -41,7 +41,7 @@ le16_to_cpu(__u16 le16)
- #endif
- }
-
--inline __u32
-+__u32
- le32_to_cpu(__u32 le32)
- {
- #if __BYTE_ORDER == __LITTLE_ENDIAN
-@@ -56,7 +56,7 @@ le32_to_cpu(__u32 le32)
- #endif
- }
-
--inline __u64
-+__u64
- le64_to_cpu(__u64 le64)
- {
- #if __BYTE_ORDER == __LITTLE_ENDIAN
-@@ -77,7 +77,7 @@ le64_to_cpu(__u64 le64)
- #endif
- }
-
--inline __u8
-+__u8
- fget_byte(FILE *fp)
- {
- __u8 d;
-@@ -87,7 +87,7 @@ fget_byte(FILE *fp)
- return d;
- }
-
--inline __u16
-+__u16
- fget_le16(FILE *fp)
- {
- __u16 d;
-@@ -98,7 +98,7 @@ fget_le16(FILE *fp)
- return d;
- }
-
--inline __u32
-+__u32
- fget_le32(FILE *fp)
- {
- __u32 d;
-@@ -109,7 +109,7 @@ fget_le32(FILE *fp)
- return d;
- }
-
--inline __u32
-+__u32
- cpu_to_be32(__u32 cpu32)
- {
- #if __BYTE_ORDER == __LITTLE_ENDIAN
-diff --git tagutils/misc.h tagutils/misc.h
-index c7642fe..fc488a1 100644
---- tagutils/misc.h
-+++ tagutils/misc.h
-@@ -37,14 +37,14 @@ typedef signed long long __s64;
- #endif
-
-
--inline __u16 le16_to_cpu(__u16 le16);
--inline __u32 le32_to_cpu(__u32 le32);
--inline __u64 le64_to_cpu(__u64 le64);
--inline __u8 fget_byte(FILE *fp);
--inline __u16 fget_le16(FILE *fp);
--inline __u32 fget_le32(FILE *fp);
--
--inline __u32 cpu_to_be32(__u32 cpu32);
-+__u16 le16_to_cpu(__u16 le16);
-+__u32 le32_to_cpu(__u32 le32);
-+__u64 le64_to_cpu(__u64 le64);
-+__u8 fget_byte(FILE *fp);
-+__u16 fget_le16(FILE *fp);
-+__u32 fget_le32(FILE *fp);
-+
-+__u32 cpu_to_be32(__u32 cpu32);
-
- extern char * sha1_hex(char *key);
-
-diff --git utils.c utils.c
-index 57ae5a4..d46f2f0 100644
---- utils.c
-+++ utils.c
-@@ -33,7 +33,7 @@
- #include "upnpglobalvars.h"
- #include "log.h"
-
--inline int
-+int
- strcatf(struct string_s *str, const char *fmt, ...)
- {
- int ret;
-@@ -52,14 +52,14 @@ strcatf(struct string_s *str, const char *fmt, ...)
- return ret;
- }
-
--inline void
-+void
- strncpyt(char *dst, const char *src, size_t len)
- {
- strncpy(dst, src, len);
- dst[len-1] = '\0';
- }
-
--inline int
-+int
- xasprintf(char **strp, char *fmt, ...)
- {
- va_list args;
-diff --git utils.h utils.h
-index d9d49a4..fbff582 100644
---- utils.h
-+++ utils.h
-@@ -29,7 +29,7 @@
- /* String functions */
- int strcatf(struct string_s *str, char *fmt, ...);
- void strncpyt(char *dst, const char *src, size_t len);
--inline int xasprintf(char **strp, char *fmt, ...);
-+int xasprintf(char **strp, char *fmt, ...);
- int ends_with(const char * haystack, const char * needle);
- char *trim(char *str);
- char *strstrc(const char *s, const char *p, const char t);
diff --git a/net/minidlna/files/patch-minidlna.conf b/net/minidlna/files/patch-minidlna.conf
index e2131d7e99ff..c8122ab8d0f3 100644
--- a/net/minidlna/files/patch-minidlna.conf
+++ b/net/minidlna/files/patch-minidlna.conf
@@ -1,8 +1,6 @@
-diff --git minidlna.conf minidlna.conf
-index bfb71d5..b579912 100644
---- minidlna.conf
-+++ minidlna.conf
-@@ -21,7 +21,7 @@ media_dir=/opt
+--- minidlna.conf.orig 2014-06-06 00:14:30.000000000 +0200
++++ minidlna.conf 2014-06-16 10:05:28.456790810 +0200
+@@ -25,7 +25,7 @@
#friendly_name=My DLNA Server
# set this if you would like to specify the directory where you want MiniDLNA to store its database and album art cache
@@ -11,3 +9,13 @@ index bfb71d5..b579912 100644
# set this if you would like to specify the directory where you want MiniDLNA to store its log file
#log_dir=/var/log
+@@ -61,6 +61,9 @@
+ serial=12345678
+ model_number=1
+
++# Override the uuid to run multiple instances
++# uuid=550e8400-e29b-41d4-a716-446655440000
++
+ # specify the path to the MiniSSDPd socket
+ #minissdpdsocket=/var/run/minissdpd.sock
+