aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-21 19:05:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-21 19:05:17 +0000
commit00a5e04aa6d17d5e44c476d2605143eb288cd288 (patch)
treebcd8f4be15fc71d3df9b9303f678046f2b55d291
parent4e801d79e363bee21034d166d85232e8e070cc5e (diff)
downloadports-00a5e04aa6d17d5e44c476d2605143eb288cd288.tar.gz
ports-00a5e04aa6d17d5e44c476d2605143eb288cd288.zip
Notes
-rw-r--r--audio/libjackasyn/Makefile8
-rw-r--r--deskutils/snotes/Makefile4
-rw-r--r--games/lianliankan/Makefile8
-rw-r--r--math/R/Makefile1
-rw-r--r--x11-themes/ubuntulooks/Makefile8
5 files changed, 26 insertions, 3 deletions
diff --git a/audio/libjackasyn/Makefile b/audio/libjackasyn/Makefile
index 68f56cbadc7c..49302d031fe3 100644
--- a/audio/libjackasyn/Makefile
+++ b/audio/libjackasyn/Makefile
@@ -34,6 +34,12 @@ MAKE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CXXFLAGS}"
SUB_FILES= pkg-message
MAN1= jacklaunch.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PTHREAD%%|${PTHREAD_LIBS}|g' ${WRKSRC}/${CONFIGURE_SCRIPT}
@@ -49,4 +55,4 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1/
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/deskutils/snotes/Makefile b/deskutils/snotes/Makefile
index 51806752c23c..1b1bbab46b23 100644
--- a/deskutils/snotes/Makefile
+++ b/deskutils/snotes/Makefile
@@ -26,6 +26,10 @@ PLIST_FILES= bin/${PORTNAME}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= does not compile
+.endif
+
do-configure:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake -project
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake -nocache
diff --git a/games/lianliankan/Makefile b/games/lianliankan/Makefile
index 54eb149bcf76..d08932e2e2a2 100644
--- a/games/lianliankan/Makefile
+++ b/games/lianliankan/Makefile
@@ -23,8 +23,14 @@ USE_X_PREFIX= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile
+.endif
+
post-install:
${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${FILESDIR}/lianliankan.desktop ${PREFIX}/share/applications
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/R/Makefile b/math/R/Makefile
index af2df8ad5cb0..3a415308e99e 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -148,6 +148,7 @@ CONFIGURE_ENV+= R_PAPERSIZE=letter
.if ${OSVERSION} < 500000
CONFIGURE_ARGS+= --disable-mbcs
+BROKEN= does not compile
.endif
.if ${OSVERSION} < 600000
diff --git a/x11-themes/ubuntulooks/Makefile b/x11-themes/ubuntulooks/Makefile
index b2f072fb8a07..bed8d5faad72 100644
--- a/x11-themes/ubuntulooks/Makefile
+++ b/x11-themes/ubuntulooks/Makefile
@@ -23,4 +23,10 @@ USE_GNOME= gtk20
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile
+.endif
+
+.include <bsd.port.post.mk>