aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-03-26 21:35:04 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-03-26 21:35:04 +0000
commit0180080a9e7a36afccd35f76e4944ba57d38073b (patch)
tree9dbc29ff5d987109e001644e0916d91291c298b4
parent1c9d2c8a35154fba58dad0c23378514155c714c8 (diff)
downloadports-0180080a9e7a36afccd35f76e4944ba57d38073b.tar.gz
ports-0180080a9e7a36afccd35f76e4944ba57d38073b.zip
Notes
-rw-r--r--audio/libsamplerate/Makefile2
-rw-r--r--audio/nas/Makefile2
-rw-r--r--devel/libopendaap/Makefile2
-rw-r--r--multimedia/libdvbpsi/Makefile2
-rw-r--r--multimedia/libfame/Makefile2
-rw-r--r--multimedia/mp4v2/Makefile2
-rw-r--r--multimedia/mpeg4ip-libmp4v2/Makefile2
-rw-r--r--multimedia/vcdimager/Makefile2
8 files changed, 8 insertions, 8 deletions
diff --git a/audio/libsamplerate/Makefile b/audio/libsamplerate/Makefile
index 81274673a6c4..604eb84dae6a 100644
--- a/audio/libsamplerate/Makefile
+++ b/audio/libsamplerate/Makefile
@@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-gcc-pipe
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-install:
.if !defined(NOPORTDOCS)
diff --git a/audio/nas/Makefile b/audio/nas/Makefile
index 40583a703f64..b9df4dc21b66 100644
--- a/audio/nas/Makefile
+++ b/audio/nas/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= multimedia@FreeBSD.org
COMMENT= Network Audio System
USE_IMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAKE_ENV+= COMPRESS_CMD="${COMPRESS_CMD:S/c//}"
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
diff --git a/devel/libopendaap/Makefile b/devel/libopendaap/Makefile
index bd30813375be..0abddf9ec736 100644
--- a/devel/libopendaap/Makefile
+++ b/devel/libopendaap/Makefile
@@ -18,7 +18,7 @@ USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GNOME= gnomehack gnometarget pkgconfig
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN3= libopendaap.3
diff --git a/multimedia/libdvbpsi/Makefile b/multimedia/libdvbpsi/Makefile
index 358231b90f07..59cd83a92185 100644
--- a/multimedia/libdvbpsi/Makefile
+++ b/multimedia/libdvbpsi/Makefile
@@ -21,7 +21,7 @@ USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-release
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e 's|-Wall|$${CFLAGS}|g ; \
diff --git a/multimedia/libfame/Makefile b/multimedia/libfame/Makefile
index 962525361994..3507d4396006 100644
--- a/multimedia/libfame/Makefile
+++ b/multimedia/libfame/Makefile
@@ -18,7 +18,7 @@ COMMENT= A video encoding library
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/multimedia/mp4v2/Makefile b/multimedia/mp4v2/Makefile
index 3037721d35d5..5810abd44029 100644
--- a/multimedia/mp4v2/Makefile
+++ b/multimedia/mp4v2/Makefile
@@ -21,7 +21,7 @@ USE_GNOME= gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
diff --git a/multimedia/mpeg4ip-libmp4v2/Makefile b/multimedia/mpeg4ip-libmp4v2/Makefile
index 3037721d35d5..5810abd44029 100644
--- a/multimedia/mpeg4ip-libmp4v2/Makefile
+++ b/multimedia/mpeg4ip-libmp4v2/Makefile
@@ -21,7 +21,7 @@ USE_GNOME= gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
diff --git a/multimedia/vcdimager/Makefile b/multimedia/vcdimager/Makefile
index 4668214c6844..09fc451c7c4a 100644
--- a/multimedia/vcdimager/Makefile
+++ b/multimedia/vcdimager/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_GMAKE= yes
USE_GNOME= gnometarget gnomehack pkgconfig lthack
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \