aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-25 15:51:09 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-25 15:51:09 +0000
commit01a258883dfd6644a6c902ea503f2dd11418243f (patch)
tree0bfd18ca605d355e4c7bde149bcf88ecc8c5061c
parenta31254472dece08e5eab4ac1e05b773e4282b432 (diff)
downloadports-01a258883dfd6644a6c902ea503f2dd11418243f.tar.gz
ports-01a258883dfd6644a6c902ea503f2dd11418243f.zip
Notes
-rw-r--r--textproc/info2html/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/textproc/info2html/Makefile b/textproc/info2html/Makefile
index ac1451989507..e475ccad49de 100644
--- a/textproc/info2html/Makefile
+++ b/textproc/info2html/Makefile
@@ -10,13 +10,16 @@ EXTRACT_SUFX= .tar
MAINTAINER= wenheping@gmail.com
COMMENT= Translate GNU info files into HTML pages
+USES= shebangfix
NO_BUILD= yes
+
PLIST_FILES= bin/info2html bin/infocat bin/info2html.css bin/info2html.conf
+SHEBANG_FILES= info2html infocat
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/info2html ${LOCALBASE}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/infocat ${LOCALBASE}/bin
- ${INSTALL_DATA} ${WRKSRC}/info2html.conf ${LOCALBASE}/bin
- ${INSTALL_DATA} ${WRKSRC}/info2html.css ${LOCALBASE}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/info2html ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/infocat ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/info2html.conf ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/info2html.css ${STAGEDIR}${PREFIX}/bin
+
.include <bsd.port.mk>