aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2009-01-13 09:42:06 +0000
committerAndrej Zverev <az@FreeBSD.org>2009-01-13 09:42:06 +0000
commit025f77656aaa5178bb0fb8217dbb41c368a26b14 (patch)
treeaf1dad659ff960adeb7889dc6566cd13f461d9b8
parente56455dd940cd197b19213bb0fff83d8a3647557 (diff)
downloadports-025f77656aaa5178bb0fb8217dbb41c368a26b14.tar.gz
ports-025f77656aaa5178bb0fb8217dbb41c368a26b14.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-OpenSSH/Makefile22
-rw-r--r--net/p5-Net-OpenSSH/distinfo3
-rw-r--r--net/p5-Net-OpenSSH/pkg-descr4
-rw-r--r--net/p5-Net-OpenSSH/pkg-plist8
5 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 3e825d399931..4e3f2661716a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -533,6 +533,7 @@
SUBDIR += p5-Net-OAuth
SUBDIR += p5-Net-OpenDHT
SUBDIR += p5-Net-OpenID-Consumer
+ SUBDIR += p5-Net-OpenSSH
SUBDIR += p5-Net-Packet
SUBDIR += p5-Net-Packet-Target
SUBDIR += p5-Net-ParseWhois
diff --git a/net/p5-Net-OpenSSH/Makefile b/net/p5-Net-OpenSSH/Makefile
new file mode 100644
index 000000000000..5c6e0046a4fd
--- /dev/null
+++ b/net/p5-Net-OpenSSH/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Net-OpenSSH
+# Date created: 2009-01-13
+# Whom: Andrej Zverev <az@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-OpenSSH
+PORTVERSION= 0.16
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= az@FreeBSD.org
+COMMENT= Perl SSH client package implemented on top of OpenSSH
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::OpenSSH::Constants.3 \
+ Net::OpenSSH.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-OpenSSH/distinfo b/net/p5-Net-OpenSSH/distinfo
new file mode 100644
index 000000000000..4b1d5e3129a7
--- /dev/null
+++ b/net/p5-Net-OpenSSH/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-OpenSSH-0.16.tar.gz) = 1b460c3be599e9c3d374d9ac5de16789
+SHA256 (Net-OpenSSH-0.16.tar.gz) = 3778646b333621955c6c0758f21e198e43e131c2577369d5d3c967828da50f22
+SIZE (Net-OpenSSH-0.16.tar.gz) = 21908
diff --git a/net/p5-Net-OpenSSH/pkg-descr b/net/p5-Net-OpenSSH/pkg-descr
new file mode 100644
index 000000000000..a791d411e090
--- /dev/null
+++ b/net/p5-Net-OpenSSH/pkg-descr
@@ -0,0 +1,4 @@
+Net::OpenSSH is a secure shell client package implemented on top of
+OpenSSH binary client (ssh).
+
+WWW: http://search.cpan.org/~salva/Net-OpenSSH/
diff --git a/net/p5-Net-OpenSSH/pkg-plist b/net/p5-Net-OpenSSH/pkg-plist
new file mode 100644
index 000000000000..20158a539eb0
--- /dev/null
+++ b/net/p5-Net-OpenSSH/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Net/OpenSSH/Constants.pm
+%%SITE_PERL%%/Net/OpenSSH.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenSSH/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenSSH
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/OpenSSH
+@dirrmtry %%SITE_PERL%%/Net