aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-10 12:27:36 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-08-10 12:27:36 +0000
commit032065463d8fc9b622fc2f0e1da9922f8bab8c8a (patch)
treea97755c61f5c24076ce2a2d60aff4204526cc5e1
parentb515624c9f4781e7698f812b6fcfba2d5ae2cc6b (diff)
downloadports-032065463d8fc9b622fc2f0e1da9922f8bab8c8a.tar.gz
ports-032065463d8fc9b622fc2f0e1da9922f8bab8c8a.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Tie-Function/Makefile21
-rw-r--r--devel/p5-Tie-Function/distinfo2
-rw-r--r--devel/p5-Tie-Function/pkg-descr4
-rw-r--r--devel/p5-Tie-Function/pkg-plist5
5 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b9a4a647eedc..4a6bd1e3c42e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2434,6 +2434,7 @@
SUBDIR += p5-Tie-File
SUBDIR += p5-Tie-File-AsHash
SUBDIR += p5-Tie-FileLRUCache
+ SUBDIR += p5-Tie-Function
SUBDIR += p5-Tie-Hash-Indexed
SUBDIR += p5-Tie-Hash-MultiValue
SUBDIR += p5-Tie-Hash-Regex
diff --git a/devel/p5-Tie-Function/Makefile b/devel/p5-Tie-Function/Makefile
new file mode 100644
index 000000000000..64b54f38cbfc
--- /dev/null
+++ b/devel/p5-Tie-Function/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Tie-Function
+# Date created: 2011-08-04
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tie-Function
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Wrap functions in tied hash sugar
+
+PERL_CONFIGURE= yes
+
+MAN3= Tie::Function.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Tie-Function/distinfo b/devel/p5-Tie-Function/distinfo
new file mode 100644
index 000000000000..7f42bfdf1e07
--- /dev/null
+++ b/devel/p5-Tie-Function/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Tie-Function-0.02.tar.gz) = 0b1617af218dfab911ba0fbd72210529a246efe140332da77fe3e03d11000117
+SIZE (Tie-Function-0.02.tar.gz) = 2173
diff --git a/devel/p5-Tie-Function/pkg-descr b/devel/p5-Tie-Function/pkg-descr
new file mode 100644
index 000000000000..998eec741535
--- /dev/null
+++ b/devel/p5-Tie-Function/pkg-descr
@@ -0,0 +1,4 @@
+Tie::Function simplifies wrapping functions in tied hash syntax so they can be
+interpolated in double-quoted literals without messy intermediate variables.
+
+WWW: http://search.cpan.org/dist/Tie-Function/
diff --git a/devel/p5-Tie-Function/pkg-plist b/devel/p5-Tie-Function/pkg-plist
new file mode 100644
index 000000000000..46ae5d0eddd5
--- /dev/null
+++ b/devel/p5-Tie-Function/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Tie/Function.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/Function/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/Function
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie
+@dirrmtry %%SITE_PERL%%/Tie