aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-17 17:48:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-17 17:48:20 +0000
commit0351ceac7a5e5ce04fc3132cb766ef70d05fd1e0 (patch)
tree265433ebc387523b2f7ae214f1aa34c26ec573d8
parent2a92043ffae53b767d8005bc3c74ce949124eb0e (diff)
downloadports-0351ceac7a5e5ce04fc3132cb766ef70d05fd1e0.tar.gz
ports-0351ceac7a5e5ce04fc3132cb766ef70d05fd1e0.zip
Notes
-rw-r--r--textproc/xmlada-gps/Makefile24
-rw-r--r--textproc/xmlada-gps/files/patch-Makefile.in80
2 files changed, 94 insertions, 10 deletions
diff --git a/textproc/xmlada-gps/Makefile b/textproc/xmlada-gps/Makefile
index cb5163d616ac..e8e9a5bba42d 100644
--- a/textproc/xmlada-gps/Makefile
+++ b/textproc/xmlada-gps/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xmlada-gps
PORTVERSION= 3.1.3
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://libre.adacore.com/
EXTRACT_SUFX= -src.tgz
@@ -20,17 +21,20 @@ CONFLICTS= xmlada-[0-9]*
GNU_CONFIGURE= yes
USE_GMAKE= yes
+XMLADA_SRC= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+
+.include <bsd.port.pre.mk>
# Check for GNAT sources.
-.if !exists(${DISTDIR}/${DISTFILE}) && !defined(PACKAGE_BUILDING)
-ECHO_MSG= ${PRINTF}
-IGNORE=Because of licensing and registration restrictions, you must fetch\n \
- the source distribution manually. Please access\n \
- http://libre.adacore.com/\ with a web browser, register\n \
- (It's free!) and log in. Download the source files:\n\n \
- \t${DISTFILE}\n\n \
- and place them in ${DISTDIR}\n
- ${ECHO_MSG} ${IGNORE}
+.if !exists(${DISTDIR}/${XMLADA_SRC}) && !defined(PACKAGE_BUILDING)
+ECHO_MSG=/usr/bin/printf
+IGNORE=:\n\
+Because of licensing and registration restrictions, you must fetch the\n\
+source distribution manually. Please access http://libre.adacore.com/\n\
+with a web browser, register (it's free), and log in. Download the source\n\
+files:\n\
+\t${XMLADA_SRC}\n\
+and place them in ${DISTDIR}.\n
.endif
WRKSRC= ${WRKDIR}/xmlada-2.1
@@ -51,4 +55,4 @@ do-install:
${DOCSDIR}/dir
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/xmlada-gps/files/patch-Makefile.in b/textproc/xmlada-gps/files/patch-Makefile.in
new file mode 100644
index 000000000000..4b89efae087c
--- /dev/null
+++ b/textproc/xmlada-gps/files/patch-Makefile.in
@@ -0,0 +1,80 @@
+--- Makefile.in.orig Wed Jan 18 06:38:29 2006
++++ Makefile.in Sun Jan 14 18:14:09 2007
+@@ -2,8 +2,8 @@
+ PREFIX=@EXEC_PREFIX@
+
+ ## The type of library we want to build
+-LIBRARY_TYPE=relocatable
+-# LIBRARY_TYPE=static
++# LIBRARY_TYPE=relocatable
++LIBRARY_TYPE=static
+
+ GNATMAKE=gnatmake
+ CC=gcc
+@@ -11,9 +11,10 @@
+ # Compiler mode: one of "distrib", "debug", "optimize", "profile"
+ MODE=distrib
+
+-CHMOD=chmod
+-CP=cp -p -f
+-MKDIR=mkdir -p
++CHMOD=/bin/chmod
++CP_DATA=${INSTALL_DATA}
++CP_SCRIPT=${INSTALL_SCRIPT}
++MKDIR=/bin/mkdir -p
+
+ ifeq (${OS}, Windows_NT)
+ LN=cp -f -p
+@@ -52,36 +53,37 @@
+
+ # Rule for installing the modules
+ %_inst: force
+- ${CP} $*/*.ad[bs] ${PREFIX}/include/xmlada
+- -${CP} $*/lib/*.ali ${PREFIX}/lib/xmlada/
+- -${CP} $*/lib/*xmlada_* ${PREFIX}/lib/xmlada/
++ ${CP_DATA} $*/*.ad[bs] ${PREFIX}/include/xmlada
++ -${CP_DATA} $*/lib/*.ali ${PREFIX}/lib/xmlada
++ -${CP_DATA} $*/lib/*xmlada_* ${PREFIX}/lib/xmlada
+ ${RM} ${PREFIX}/lib/*xmlada_$**
+ cd ${PREFIX}/lib; ${foreach lib, ${notdir ${wildcard $*/lib/*xmlada_*}}, \
+ ${RM} ${PREFIX}/lib/${lib}; \
+ ${LN} xmlada/${lib} ${PREFIX}/lib/${lib};}
+- cd ${PREFIX}/lib/xmlada; ${CHMOD} ugo-w *.ali
+ cd $*; ls *.ad[bs] > ${PREFIX}/lib/gnat/xmlada/xmlada_$*.lgpr
+
+ install_dirs: force
+ @${MKDIR} ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/lib
+ @${MKDIR} ${PREFIX}/lib/xmlada
+- @${MKDIR} ${PREFIX}/share/doc/xmlada
+ @${MKDIR} ${PREFIX}/include/xmlada
+ @${MKDIR} ${PREFIX}/lib/gnat
+ @${MKDIR} ${PREFIX}/lib/gnat/xmlada
+- @${MKDIR} ${PREFIX}/share/gps/plug-ins/
++ @${MKDIR} ${PREFIX}/share/gps/plug-ins
+
+ install: obj install_dirs ${MODULE_INSTALL}
+- ${CP} distrib/${LIBRARY_TYPE}/*.gpr ${PREFIX}/lib/gnat
+- ${CP} xmlada-config ${PREFIX}/bin
+- -${CP} docs/xml.ps ${PREFIX}/share/doc/xmlada 2>/dev/null
+- -${CP} docs/xml.pdf ${PREFIX}/share/doc/xmlada
+- -${CP} docs/xml.html ${PREFIX}/share/doc/xmlada
+- -${CP} docs/xml.info ${PREFIX}/share/doc/xmlada
+- ${CHMOD} +x ${PREFIX}/bin/xmlada-config
+- ${CP} distrib/xmlada.gpr ${PREFIX}/lib/gnat/xmlada.gpr
+- ${CP} distrib/xmlada_gps.py ${PREFIX}/share/gps/plug-ins/
++ ${CP_SCRIPT} xmlada-config ${PREFIX}/bin/xmlada-config
++ ${CP_SCRIPT} distrib/xmlada_gps.py \
++ ${PREFIX}/share/gps/plug-ins/xmlada_gps.py
++ ${CP_DATA} distrib/${LIBRARY_TYPE}/*.gpr ${PREFIX}/lib/gnat
++ ${CP_DATA} distrib/xmlada.gpr ${PREFIX}/lib/gnat/xmlada.gpr
++
++install_docs:
++ @${MKDIR} ${PREFIX}/share/doc/xmlada
++ -${CP_DATA} docs/xml.ps ${PREFIX}/share/doc/xmlada 2>/dev/null
++ -${CP_DATA} docs/xml.pdf ${PREFIX}/share/doc/xmlada
++ -${CP_DATA} docs/xml.html ${PREFIX}/share/doc/xmlada
++ -${CP_DATA} docs/xml.info ${PREFIX}/share/doc/xmlada
+
+ clean: force
+ gnat clean -q -r -Punicode/unicode.gpr