aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-12-19 10:49:00 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-12-19 10:49:00 +0000
commit0406d5b04f614dc6385035dd3005abd3fd269228 (patch)
treed1c6a110737ea4dde2a53b41b74670aeccf172ab
parent837e3284ec8132921b409d9d3fbbdae4590828f1 (diff)
Notes
-rw-r--r--Keywords/fc.yaml9
-rw-r--r--Keywords/fcfontsdir.yaml19
-rw-r--r--Keywords/fontsdir.yaml17
-rw-r--r--Mk/bsd.xorg.mk14
-rw-r--r--x11-fonts/encodings/Makefile1
-rw-r--r--x11-fonts/font-adobe-100dpi/Makefile1
-rw-r--r--x11-fonts/font-adobe-75dpi/Makefile1
-rw-r--r--x11-fonts/font-adobe-utopia-100dpi/Makefile1
-rw-r--r--x11-fonts/font-adobe-utopia-75dpi/Makefile1
-rw-r--r--x11-fonts/font-adobe-utopia-type1/Makefile1
-rw-r--r--x11-fonts/font-alias/Makefile1
-rw-r--r--x11-fonts/font-arabic-misc/Makefile1
-rw-r--r--x11-fonts/font-bh-100dpi/Makefile1
-rw-r--r--x11-fonts/font-bh-75dpi/Makefile1
-rw-r--r--x11-fonts/font-bh-lucidatypewriter-100dpi/Makefile1
-rw-r--r--x11-fonts/font-bh-lucidatypewriter-75dpi/Makefile1
-rw-r--r--x11-fonts/font-bh-ttf/Makefile1
-rw-r--r--x11-fonts/font-bh-type1/Makefile1
-rw-r--r--x11-fonts/font-bitstream-100dpi/Makefile1
-rw-r--r--x11-fonts/font-bitstream-75dpi/Makefile1
-rw-r--r--x11-fonts/font-bitstream-speedo/Makefile1
-rw-r--r--x11-fonts/font-bitstream-type1/Makefile1
-rw-r--r--x11-fonts/font-cronyx-cyrillic/Makefile1
-rw-r--r--x11-fonts/font-cursor-misc/Makefile1
-rw-r--r--x11-fonts/font-daewoo-misc/Makefile1
-rw-r--r--x11-fonts/font-dec-misc/Makefile1
-rw-r--r--x11-fonts/font-ibm-type1/Makefile1
-rw-r--r--x11-fonts/font-isas-misc/Makefile1
-rw-r--r--x11-fonts/font-jis-misc/Makefile1
-rw-r--r--x11-fonts/font-micro-misc/Makefile1
-rw-r--r--x11-fonts/font-misc-cyrillic/Makefile1
-rw-r--r--x11-fonts/font-misc-ethiopic/Makefile1
-rw-r--r--x11-fonts/font-misc-meltho/Makefile1
-rw-r--r--x11-fonts/font-misc-misc/Makefile1
-rw-r--r--x11-fonts/font-mutt-misc/Makefile1
-rw-r--r--x11-fonts/font-schumacher-misc/Makefile1
-rw-r--r--x11-fonts/font-screen-cyrillic/Makefile1
-rw-r--r--x11-fonts/font-sony-misc/Makefile1
-rw-r--r--x11-fonts/font-sun-misc/Makefile1
-rw-r--r--x11-fonts/font-util/Makefile1
-rw-r--r--x11-fonts/font-winitzki-cyrillic/Makefile1
-rw-r--r--x11-fonts/font-xfree86-type1/Makefile1
42 files changed, 97 insertions, 0 deletions
diff --git a/Keywords/fc.yaml b/Keywords/fc.yaml
new file mode 100644
index 000000000000..239bb4519572
--- /dev/null
+++ b/Keywords/fc.yaml
@@ -0,0 +1,9 @@
+# $FreeBSD$
+#
+# MAINTAINER: x11@FreeBSD.org
+
+actions: [dirrmtry]
+post-install: |
+ fc-cache -s %D/%@ 2>/dev/null || true
+post-deinstall: |
+ fc-cache -s %D/%@ 2>/dev/null || true
diff --git a/Keywords/fcfontsdir.yaml b/Keywords/fcfontsdir.yaml
new file mode 100644
index 000000000000..fdb00a8bf5f4
--- /dev/null
+++ b/Keywords/fcfontsdir.yaml
@@ -0,0 +1,19 @@
+# $FreeBSD$
+#
+# MAINTAINER: x11@FreeBSD.org
+
+actions: [dirrmtry]
+post-install: |
+ fc-cache -s %D/%@ 2>/dev/null || true
+ mkfontscale %D/%@ 2>/dev/null || true
+ mkfontdir %D/%@ 2>/dev/null || true
+post-deinstall: |
+ fc-cache -s %D/%@ 2>/dev/null || true
+ mkfontscale %D/%@ 2>/dev/null || true
+ if [ -e %D/%@/fonts.scale -a "`stat -f '%%z' %D/%@/fonts.scale 2>/dev/null`" = '2' ]; then
+ rm %D/%@/fonts.scale
+ fi
+ mkfontdir %D/%@ 2>/dev/null || true
+ if [ -e %D/%@/fonts.dir -a "`stat -f '%%z' %D/%@/fonts.dir 2>/dev/null`" = '2' ]; then
+ rm %D/%@/fonts.dir
+ fi
diff --git a/Keywords/fontsdir.yaml b/Keywords/fontsdir.yaml
new file mode 100644
index 000000000000..2f1fdea3504c
--- /dev/null
+++ b/Keywords/fontsdir.yaml
@@ -0,0 +1,17 @@
+# $FreeBSD$
+#
+# MAINTAINER: x11@FreeBSD.org
+
+actions: [dirrmtry]
+post-install: |
+ mkfontscale %D/%@ 2>/dev/null || true
+ mkfontsdir %D/%@ 2>/dev/null || true
+post-deinstall: |
+ mkfontscale %@ 2>/dev/null || true
+ if [ -e %D/%@/fonts.scale -a "`stat -f '%%z' %D/%@/fonts.scale 2>/dev/null`" = '2' ]; then
+ rm %D/%@/fonts.scale
+ fi
+ mkfontdir %@ 2>/dev/null || true
+ if [ -e %D/%@/fonts.dir -a "`stat -f '%%z' %D/%@§fonts.dir 2>/dev/null`" = '2' ]; then
+ rm %D/%@/fonts.dir
+ fi
diff --git a/Mk/bsd.xorg.mk b/Mk/bsd.xorg.mk
index 7d585780987d..a2ba2517b294 100644
--- a/Mk/bsd.xorg.mk
+++ b/Mk/bsd.xorg.mk
@@ -104,6 +104,19 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
. endif
post-install:
+.if defined(WITH_PKGNG)
+. for _fontdir in ${FONTDIR}
+. if ${INSTALLS_TTF} == yes && ${NEED_MKFONTFOO} == yes
+ @${ECHO_CMD} "@fcfontsdir lib/X11/fonts/${_fontdir}" >> ${TMPPLIST}
+. elif ${INSTALLS_TTF} == yes && ${NEED_MKFONTFOO} == no
+ @${ECHO_CMD} "@fc lib/X11/fonts/${_fontdir}" >> ${TMPPLIST}
+. elif ${NEED_MKFONTFOO} == yes
+ @${ECHO_CMD} "@fontsdir lib/X11/fonts/${_fontdir}" >> ${TMPPLIST}
+. else
+ @${ECHO_CMD} "@dirrmtry lib/X11/fonts/${_fontdir}" >> ${TMPPLIST}
+. endif
+. endfor
+.else
. if ${INSTALLS_TTF} == "yes"
. for _fontdir in ${FONTDIR}
@${ECHO_CMD} "@exec fc-cache -s %D/lib/X11/fonts/${_fontdir} 2>/dev/null || true" >> ${TMPPLIST}
@@ -123,6 +136,7 @@ post-install:
@${ECHO_CMD} "@unexec rmdir %D/lib/X11/fonts/${_fontdir} 2>/dev/null || true" >> ${TMPPLIST}
. endfor
. endif
+.endif
. if ${XORG_CAT} == "lib"
USES+= pathfix
diff --git a/x11-fonts/encodings/Makefile b/x11-fonts/encodings/Makefile
index 4840274f3c38..6ef6fc172825 100644
--- a/x11-fonts/encodings/Makefile
+++ b/x11-fonts/encodings/Makefile
@@ -2,6 +2,7 @@
PORTNAME= encodings
PORTVERSION= 1.0.4
+PORTREVISION=
PORTEPOCH= 1
CATEGORIES= x11-fonts
diff --git a/x11-fonts/font-adobe-100dpi/Makefile b/x11-fonts/font-adobe-100dpi/Makefile
index 0f634fac98ad..59cdb52ed499 100644
--- a/x11-fonts/font-adobe-100dpi/Makefile
+++ b/x11-fonts/font-adobe-100dpi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-adobe-100dpi
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-adobe-75dpi/Makefile b/x11-fonts/font-adobe-75dpi/Makefile
index ecdd02c74118..63c41f57c972 100644
--- a/x11-fonts/font-adobe-75dpi/Makefile
+++ b/x11-fonts/font-adobe-75dpi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-adobe-75dpi
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-adobe-utopia-100dpi/Makefile b/x11-fonts/font-adobe-utopia-100dpi/Makefile
index 9abf4ae020a1..4ad846942bdc 100644
--- a/x11-fonts/font-adobe-utopia-100dpi/Makefile
+++ b/x11-fonts/font-adobe-utopia-100dpi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-adobe-utopia-100dpi
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-adobe-utopia-75dpi/Makefile b/x11-fonts/font-adobe-utopia-75dpi/Makefile
index 6fcafcc10485..e20690f7e000 100644
--- a/x11-fonts/font-adobe-utopia-75dpi/Makefile
+++ b/x11-fonts/font-adobe-utopia-75dpi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-adobe-utopia-75dpi
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-adobe-utopia-type1/Makefile b/x11-fonts/font-adobe-utopia-type1/Makefile
index a19133eee9c9..31e8fc41b9ba 100644
--- a/x11-fonts/font-adobe-utopia-type1/Makefile
+++ b/x11-fonts/font-adobe-utopia-type1/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-adobe-utopia-type1
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-alias/Makefile b/x11-fonts/font-alias/Makefile
index e745bae96ee0..ed6aa51e0819 100644
--- a/x11-fonts/font-alias/Makefile
+++ b/x11-fonts/font-alias/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-alias
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-arabic-misc/Makefile b/x11-fonts/font-arabic-misc/Makefile
index 3c3987487db5..334a6a019716 100644
--- a/x11-fonts/font-arabic-misc/Makefile
+++ b/x11-fonts/font-arabic-misc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-arabic-misc
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-bh-100dpi/Makefile b/x11-fonts/font-bh-100dpi/Makefile
index 2411a3755b50..de413085a685 100644
--- a/x11-fonts/font-bh-100dpi/Makefile
+++ b/x11-fonts/font-bh-100dpi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-bh-100dpi
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-bh-75dpi/Makefile b/x11-fonts/font-bh-75dpi/Makefile
index 921a01d55dea..9c6f73271d7f 100644
--- a/x11-fonts/font-bh-75dpi/Makefile
+++ b/x11-fonts/font-bh-75dpi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-bh-75dpi
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-bh-lucidatypewriter-100dpi/Makefile b/x11-fonts/font-bh-lucidatypewriter-100dpi/Makefile
index a23ca06f6f95..10325d1bef44 100644
--- a/x11-fonts/font-bh-lucidatypewriter-100dpi/Makefile
+++ b/x11-fonts/font-bh-lucidatypewriter-100dpi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-bh-lucidatypewriter-100dpi
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-bh-lucidatypewriter-75dpi/Makefile b/x11-fonts/font-bh-lucidatypewriter-75dpi/Makefile
index 335df69d056d..296cbb122fa7 100644
--- a/x11-fonts/font-bh-lucidatypewriter-75dpi/Makefile
+++ b/x11-fonts/font-bh-lucidatypewriter-75dpi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-bh-lucidatypewriter-75dpi
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-bh-ttf/Makefile b/x11-fonts/font-bh-ttf/Makefile
index ae81fe96ad78..b48d9417cedf 100644
--- a/x11-fonts/font-bh-ttf/Makefile
+++ b/x11-fonts/font-bh-ttf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-bh-ttf
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-bh-type1/Makefile b/x11-fonts/font-bh-type1/Makefile
index 65d892853606..747936c0257e 100644
--- a/x11-fonts/font-bh-type1/Makefile
+++ b/x11-fonts/font-bh-type1/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-bh-type1
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-bitstream-100dpi/Makefile b/x11-fonts/font-bitstream-100dpi/Makefile
index a38a56e46efd..e681a8d9bafe 100644
--- a/x11-fonts/font-bitstream-100dpi/Makefile
+++ b/x11-fonts/font-bitstream-100dpi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-bitstream-100dpi
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-bitstream-75dpi/Makefile b/x11-fonts/font-bitstream-75dpi/Makefile
index 4ef122e674da..81f44256ccc0 100644
--- a/x11-fonts/font-bitstream-75dpi/Makefile
+++ b/x11-fonts/font-bitstream-75dpi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-bitstream-75dpi
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-bitstream-speedo/Makefile b/x11-fonts/font-bitstream-speedo/Makefile
index d2a81599f3e6..c9b7dabb59ea 100644
--- a/x11-fonts/font-bitstream-speedo/Makefile
+++ b/x11-fonts/font-bitstream-speedo/Makefile
@@ -2,6 +2,7 @@
PORTNAME= font-bitstream-speedo
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-bitstream-type1/Makefile b/x11-fonts/font-bitstream-type1/Makefile
index 00a6e5f6ea59..01f3a2c00c78 100644
--- a/x11-fonts/font-bitstream-type1/Makefile
+++ b/x11-fonts/font-bitstream-type1/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-bitstream-type1
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-cronyx-cyrillic/Makefile b/x11-fonts/font-cronyx-cyrillic/Makefile
index 3bca6ecb3393..75dcb84080c7 100644
--- a/x11-fonts/font-cronyx-cyrillic/Makefile
+++ b/x11-fonts/font-cronyx-cyrillic/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-cronyx-cyrillic
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-cursor-misc/Makefile b/x11-fonts/font-cursor-misc/Makefile
index 09920f54db8d..989a37d312c7 100644
--- a/x11-fonts/font-cursor-misc/Makefile
+++ b/x11-fonts/font-cursor-misc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-cursor-misc
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-daewoo-misc/Makefile b/x11-fonts/font-daewoo-misc/Makefile
index 952dd3368ec4..7c86b547155d 100644
--- a/x11-fonts/font-daewoo-misc/Makefile
+++ b/x11-fonts/font-daewoo-misc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-daewoo-misc
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-dec-misc/Makefile b/x11-fonts/font-dec-misc/Makefile
index a6bf1edc1613..8f2926107bc4 100644
--- a/x11-fonts/font-dec-misc/Makefile
+++ b/x11-fonts/font-dec-misc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-dec-misc
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-ibm-type1/Makefile b/x11-fonts/font-ibm-type1/Makefile
index ae4dd6e902ad..42fa7c5acbdc 100644
--- a/x11-fonts/font-ibm-type1/Makefile
+++ b/x11-fonts/font-ibm-type1/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-ibm-type1
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-isas-misc/Makefile b/x11-fonts/font-isas-misc/Makefile
index 0e038369fad8..da7dfa753791 100644
--- a/x11-fonts/font-isas-misc/Makefile
+++ b/x11-fonts/font-isas-misc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-isas-misc
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-jis-misc/Makefile b/x11-fonts/font-jis-misc/Makefile
index 43968fb8cf68..ae8f580b081a 100644
--- a/x11-fonts/font-jis-misc/Makefile
+++ b/x11-fonts/font-jis-misc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-jis-misc
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-micro-misc/Makefile b/x11-fonts/font-micro-misc/Makefile
index b443a44ad6ba..253e3c7d62e2 100644
--- a/x11-fonts/font-micro-misc/Makefile
+++ b/x11-fonts/font-micro-misc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-micro-misc
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-misc-cyrillic/Makefile b/x11-fonts/font-misc-cyrillic/Makefile
index d06da8356f8f..9669dd77f9ab 100644
--- a/x11-fonts/font-misc-cyrillic/Makefile
+++ b/x11-fonts/font-misc-cyrillic/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-misc-cyrillic
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-misc-ethiopic/Makefile b/x11-fonts/font-misc-ethiopic/Makefile
index 81cdcf829b0b..96a10897fad6 100644
--- a/x11-fonts/font-misc-ethiopic/Makefile
+++ b/x11-fonts/font-misc-ethiopic/Makefile
@@ -2,6 +2,7 @@
PORTNAME= font-misc-ethiopic
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-misc-meltho/Makefile b/x11-fonts/font-misc-meltho/Makefile
index 00116af8ef12..1eb225d0b7c1 100644
--- a/x11-fonts/font-misc-meltho/Makefile
+++ b/x11-fonts/font-misc-meltho/Makefile
@@ -2,6 +2,7 @@
PORTNAME= font-misc-meltho
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-misc-misc/Makefile b/x11-fonts/font-misc-misc/Makefile
index 99e9eb502854..892e937da7f0 100644
--- a/x11-fonts/font-misc-misc/Makefile
+++ b/x11-fonts/font-misc-misc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-misc-misc
PORTVERSION= 1.1.2
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-mutt-misc/Makefile b/x11-fonts/font-mutt-misc/Makefile
index 28ff192bad5f..0f7a9c0cd1f4 100644
--- a/x11-fonts/font-mutt-misc/Makefile
+++ b/x11-fonts/font-mutt-misc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-mutt-misc
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-schumacher-misc/Makefile b/x11-fonts/font-schumacher-misc/Makefile
index 06b1f426bf94..387c96d846dd 100644
--- a/x11-fonts/font-schumacher-misc/Makefile
+++ b/x11-fonts/font-schumacher-misc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-schumacher-misc
PORTVERSION= 1.1.2
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-screen-cyrillic/Makefile b/x11-fonts/font-screen-cyrillic/Makefile
index bd2a49c0efa7..977ef07bc2d5 100644
--- a/x11-fonts/font-screen-cyrillic/Makefile
+++ b/x11-fonts/font-screen-cyrillic/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-screen-cyrillic
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-sony-misc/Makefile b/x11-fonts/font-sony-misc/Makefile
index 0ffd90e41426..ac761738d57c 100644
--- a/x11-fonts/font-sony-misc/Makefile
+++ b/x11-fonts/font-sony-misc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-sony-misc
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-sun-misc/Makefile b/x11-fonts/font-sun-misc/Makefile
index 0eeee719e87f..1a77118ab30e 100644
--- a/x11-fonts/font-sun-misc/Makefile
+++ b/x11-fonts/font-sun-misc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-sun-misc
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-util/Makefile b/x11-fonts/font-util/Makefile
index 9807bb091dc1..fab4f6c45625 100644
--- a/x11-fonts/font-util/Makefile
+++ b/x11-fonts/font-util/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-util
PORTVERSION= 1.3.0
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-winitzki-cyrillic/Makefile b/x11-fonts/font-winitzki-cyrillic/Makefile
index 9b8b09b01f6b..be9ce1de4990 100644
--- a/x11-fonts/font-winitzki-cyrillic/Makefile
+++ b/x11-fonts/font-winitzki-cyrillic/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-winitzki-cyrillic
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-fonts/font-xfree86-type1/Makefile b/x11-fonts/font-xfree86-type1/Makefile
index 3095a1df874d..e6361136d679 100644
--- a/x11-fonts/font-xfree86-type1/Makefile
+++ b/x11-fonts/font-xfree86-type1/Makefile
@@ -3,6 +3,7 @@
PORTNAME= font-xfree86-type1
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= x11-fonts
MAINTAINER= x11@FreeBSD.org