aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-04 09:01:28 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-04 09:01:28 +0000
commit0492c912a267f29c738399fa23de7ffdf1e71f5a (patch)
tree7a32d56326fbd2a42cd33d9a67d61effc563fb80
parentbf1170638df958f203d69f8f7f973120b3c8eaac (diff)
downloadports-0492c912a267f29c738399fa23de7ffdf1e71f5a.tar.gz
ports-0492c912a267f29c738399fa23de7ffdf1e71f5a.zip
Notes
-rw-r--r--net/pxe/Makefile19
-rw-r--r--net/pxe/files/patch-pxe.cc14
2 files changed, 19 insertions, 14 deletions
diff --git a/net/pxe/Makefile b/net/pxe/Makefile
index fcef500e31a8..7479b30b64ea 100644
--- a/net/pxe/Makefile
+++ b/net/pxe/Makefile
@@ -11,27 +11,32 @@ MASTER_SITES= http://www.kano.org.uk/projects/pxe/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= PXE daemon, set up a boot menu for netbooting PXE enabled clients
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
USE_RC_SUBR= pxe
SUB_FILES= pkg-message
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-config=${PREFIX}/etc/pxe.conf \
- --with-log=/var/log/pxe.log \
- --with-setuid=nobody
+CONFIGURE_ARGS= --with-config=${PREFIX}/etc/pxe.conf \
+ --with-log=/var/log/pxe.log \
+ --with-setuid=nobody
-PORTDOCS= Changes INSTALL LICENCE README THANKS
-PLIST_FILES= sbin/pxe etc/pxe.conf.sample
+PORTDOCS= Changes INSTALL README THANKS
+PLIST_FILES= etc/pxe.conf.sample sbin/pxe
OPTIONS_DEFINE= DOCS
post-patch:
- ${REINPLACE_CMD} -e 's|/tmp/pxe.pid|/var/run/pxe.pid|' \
+ @${REINPLACE_CMD} -e 's|/tmp/pxe.pid|/var/run/pxe.pid|' \
${WRKSRC}/autoconf.h.in
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pxe ${STAGEDIR}${PREFIX}/sbin
${INSTALL_DATA} ${WRKSRC}/pxe.conf \
${STAGEDIR}${PREFIX}/etc/pxe.conf.sample
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
diff --git a/net/pxe/files/patch-pxe.cc b/net/pxe/files/patch-pxe.cc
index 95ad40fb542c..58332071f742 100644
--- a/net/pxe/files/patch-pxe.cc
+++ b/net/pxe/files/patch-pxe.cc
@@ -1,6 +1,6 @@
---- pxe.cc.orig Sun Feb 2 13:39:26 2003
-+++ pxe.cc Sun Jun 3 21:34:25 2007
-@@ -208,6 +208,31 @@
+--- pxe.cc.orig 2003-02-02 12:39:26 UTC
++++ pxe.cc
+@@ -208,6 +208,31 @@ int StartPxeService(const char *configfi
return(retval);
}
@@ -32,7 +32,7 @@
/******************************************************************************
* main - kick things off and do cool things *
-@@ -247,6 +272,15 @@
+@@ -247,6 +272,15 @@ int main(int argc, char **argv)
}
debug.close();
@@ -48,7 +48,7 @@
// redirect the file descriptors
if (0 == _debug) {
debug.open("/dev/null", std::ios::out);
-@@ -258,34 +292,6 @@
+@@ -258,34 +292,6 @@ int main(int argc, char **argv)
debug.close();
}
@@ -83,7 +83,7 @@
// if not in debug mode, fork and go
if (0 == _debug) {
signal(SIGCHLD, SIG_IGN);
-@@ -320,6 +326,7 @@
+@@ -320,6 +326,7 @@ int main(int argc, char **argv)
}
close(chk);
@@ -91,7 +91,7 @@
StartPxeService(configfile);
exit(0);
-@@ -328,6 +335,7 @@
+@@ -328,6 +335,7 @@ int main(int argc, char **argv)
}
} else { // debug