aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-08-15 15:19:39 +0000
committerChris Rees <crees@FreeBSD.org>2011-08-15 15:19:39 +0000
commit04d5606303699fe6a1fff5184515d1566c2cbf99 (patch)
tree2a7cd6de49603674f326475909261f478432d10f
parentdc5b5c47b1013e0f458534ad5ed67d8783c78958 (diff)
Notes
-rw-r--r--textproc/urlview/Makefile32
-rw-r--r--textproc/urlview/files/gecko.sh.in5
-rw-r--r--textproc/urlview/files/patch-sample.urlview25
-rw-r--r--textproc/urlview/files/patch-url_handler.sh35
-rw-r--r--textproc/urlview/pkg-plist4
5 files changed, 34 insertions, 67 deletions
diff --git a/textproc/urlview/Makefile b/textproc/urlview/Makefile
index f48283c798e0..8bb7c587f849 100644
--- a/textproc/urlview/Makefile
+++ b/textproc/urlview/Makefile
@@ -8,41 +8,27 @@
PORTNAME= urlview
PORTVERSION= 0.9
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= textproc www
MASTER_SITES= ftp://ftp.mutt.org/mutt/contrib/ \
ftp://ftp.sunsite.auc.dk/pub/mail/mutt/contrib/ \
ftp://ftp.cs.tu-berlin.de/pub/net/mail/mutt/contrib/
-#PATCH_SITES= http://feeding.frenzy.com/~rainking/
-#PATCHFILES= urlview.diff
-
MAINTAINER= mexas@bristol.ac.uk
COMMENT= URL extractor/launcher
GNU_CONFIGURE= yes
MAN1= urlview.1
-SUB_FILES= gecko.sh
-SUB_LIST= GECKO=${GECKO}
-
-.if defined(WITH_FIREFOX)
-USE_FIREFOX= 36
-GECKO= firefox3
-.elif defined(WITH_SEAMONKEY)
-USE_SEAMONKEY= 20
-GECKO= seamonkey
-.endif
-
-.include <bsd.port.pre.mk>
+PLIST_FILES= bin/urlview \
+ etc/urlview.conf.sample
post-patch:
- @${REINPLACE_CMD} -e "s,!!PREFIX!!,${PREFIX},g" \
- -e "s,/usr/X11R6,${X11BASE},g" ${WRKSRC}/url_handler.sh
- @${REINPLACE_CMD} -e \
- "s,/etc/urlview.conf,${PREFIX}/etc/urlview.conf,g" ${WRKSRC}/*
+ @${REINPLACE_CMD} -e 's,/etc,${PREFIX}&,' \
+ -e 's/url_handler.sh/firefox/' \
+ ${WRKSRC}/*
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/url_handler.sh ${WRKDIR}/gecko.sh \
- ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/sample.urlview \
+ ${PREFIX}/etc/urlview.conf.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/urlview/files/gecko.sh.in b/textproc/urlview/files/gecko.sh.in
deleted file mode 100644
index 5c0d5ba4f1ad..000000000000
--- a/textproc/urlview/files/gecko.sh.in
+++ /dev/null
@@ -1,5 +0,0 @@
-#! /bin/sh
-# $FreeBSD$
-# Launch %%GECKO%% for urlview
-URL=$@
-%%GECKO%% -remote "openurl($URL, new-tab)" || %%GECKO%% $URL
diff --git a/textproc/urlview/files/patch-sample.urlview b/textproc/urlview/files/patch-sample.urlview
new file mode 100644
index 000000000000..faf6a6a036f0
--- /dev/null
+++ b/textproc/urlview/files/patch-sample.urlview
@@ -0,0 +1,25 @@
+--- sample.urlview~
++++ sample.urlview
+@@ -3,7 +3,6 @@
+ # man urlview <Man page>
+ #
+ # Put this file in: $HOME/.urlview
+-# Put url_handler.sh in: /usr/bin
+ #
+ # You can call 'urlview' while in 'mutt' by pressing the Ctrl b keys.
+ # Put these macros in your $HOME/.muttrc file.
+@@ -19,10 +18,8 @@
+ #REGEXP (((http|https|ftp|gopher)|mailto):(//)?[^ >"\t]*|www\.[-a-z0-9.]+)[^ .,;\t>">\):]
+ REGEXP (((http|https|ftp|gopher)|mailto)[.:][^ >"\t]*|www\.[-a-z0-9.]+)[^ .,;\t>">\):]
+
+-# Command to invoke for selected URL. Use lynx, netscape, or url_handler.sh
+-# shell script.
+-
+-#COMMAND lynx %s
+-#COMMAND netscape -remote 'openURL(%s)'
+-COMMAND url_handler.sh
++# Command to invoke for selected URL.
+
++#COMMAND lynx %s # :VT
++#COMMAND u=%s; xterm -e lynx $u || lynx $u # :XT
++#COMMAND firefox %s 2>/dev/null & # :XW
diff --git a/textproc/urlview/files/patch-url_handler.sh b/textproc/urlview/files/patch-url_handler.sh
deleted file mode 100644
index 1f8c42ffab3a..000000000000
--- a/textproc/urlview/files/patch-url_handler.sh
+++ /dev/null
@@ -1,35 +0,0 @@
-$FreeBSD$
---- url_handler.sh.orig Tue Jul 4 03:14:30 2000
-+++ url_handler.sh Wed Aug 22 10:42:49 2001
-@@ -1,4 +1,4 @@
--#! /bin/bash
-+#! /bin/sh
-
- # Copyright (c) 1998 Martin Schulze <joey@debian.org>
- # Slightly modified by Luis Francisco Gonzalez <luisgh@debian.org>
-@@ -28,11 +28,11 @@
- # VT: Launch in the same terminal
-
- # The lists of programs to be executed are
--https_prgs="/usr/X11R6/bin/netscape:XW /usr/bin/lynx:XT"
--http_prgs="/usr/bin/lynx:XT /usr/X11R6/bin/netscape:XW"
--mailto_prgs="/usr/bin/mutt:VT /usr/bin/elm:VT /usr/bin/pine:VT /usr/bin/mail:VT"
--gopher_prgs="/usr/bin/lynx:XT /usr/bin/gopher:XT"
--ftp_prgs="/usr/bin/lynx:XT /usr/bin/ncftp:XT"
-+https_prgs="!!PREFIX!!/bin/gecko.sh:XW !!PREFIX!!/bin/lynx:XT !!PREFIX!!/bin/w3m:XT"
-+http_prgs="!!PREFIX!!/bin/gecko.sh:XW !!PREFIX!!/bin/lynx:XT !!PREFIX!!/bin/w3m:XT !!PREFIX!!/bin/links:XT"
-+mailto_prgs="!!PREFIX!!/bin/mutt:VT !!PREFIX!!/bin/elm:VT !!PREFIX!!/bin/pine:VT /usr/bin/mail:VT"
-+gopher_prgs="!!PREFIX!!/bin/lynx:XT !!PREFIX!!/bin/gopher:XT"
-+ftp_prgs="!!PREFIX!!/bin/lynx:XT !!PREFIX!!/bin/ncftp2:XT !!PREFIX!!/bin/ncftp3:XT !!PREFIX!!/bin/ncftp:XT"
-
- # Program used as an xterm (if it doesn't support -T you'll need to change
- # the command line in getprg)
-@@ -42,7 +42,7 @@
- ###########################################################################
- # Change bellow this at your own risk
- ###########################################################################
--function getprg()
-+getprg()
- {
- local ele tag prog
-
diff --git a/textproc/urlview/pkg-plist b/textproc/urlview/pkg-plist
deleted file mode 100644
index 586625222171..000000000000
--- a/textproc/urlview/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-@comment $FreeBSD$
-bin/gecko.sh
-bin/url_handler.sh
-bin/urlview