aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-06-21 19:12:43 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-06-21 19:12:43 +0000
commit06f65b4c7f8aed0bfea34c97833fcebb5c5004fe (patch)
tree434100f1a0d8aacb87f4c368c1076468a52a051e
parent92fa392f6b80fd1ed44ebfd73432dc2411e81ebf (diff)
downloadports-06f65b4c7f8aed0bfea34c97833fcebb5c5004fe.tar.gz
ports-06f65b4c7f8aed0bfea34c97833fcebb5c5004fe.zip
Notes
-rw-r--r--games/allacrost/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/games/allacrost/Makefile b/games/allacrost/Makefile
index d6aeee84e570..925f081a1afe 100644
--- a/games/allacrost/Makefile
+++ b/games/allacrost/Makefile
@@ -20,15 +20,15 @@ LIB_DEPENDS= libpng.so:graphics/png \
libboost_thread.so:devel/boost-libs
GNU_CONFIGURE= yes
-USES= compiler:c++11-lang gettext gmake iconv jpeg lua:51 openal:al
+USES= gettext gmake iconv jpeg localbase lua:51 openal:al
USE_SDL= sdl ttf net
USE_GL= gl glu
USE_XORG= x11
+USE_CXXSTD= c++98
CONFIGURE_ARGS= --datadir=${DATADIR} --enable-editor=no
-CPPFLAGS+= -I${LOCALBASE}/include -I${LUA_INCDIR}
-LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
-CXXFLAGS+= -Wno-c++11-narrowing
+CPPFLAGS+= -isystem${LUA_INCDIR}
+LDFLAGS+= -L${LUA_LIBDIR}
LLD_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}