aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2004-06-03 12:39:56 +0000
committerAnders Nordby <anders@FreeBSD.org>2004-06-03 12:39:56 +0000
commit072b0fc121907de78e2c66b51442c551614d1d01 (patch)
treea6cc1409d07696f5c58f5081ed72aee30d801ef9
parent72b1f5a129d46996df886967c2f198c486a0f7e1 (diff)
downloadports-072b0fc121907de78e2c66b51442c551614d1d01.tar.gz
ports-072b0fc121907de78e2c66b51442c551614d1d01.zip
Notes
-rw-r--r--www/mod_sqlinclude/Makefile15
-rw-r--r--www/mod_sqlinclude/distinfo4
-rw-r--r--www/mod_sqlinclude/files/patch-mod_sqlinclude.c11
-rw-r--r--www/mod_sqlinclude/pkg-plist8
4 files changed, 16 insertions, 22 deletions
diff --git a/www/mod_sqlinclude/Makefile b/www/mod_sqlinclude/Makefile
index 6aa242a7051a..aa53b148755c 100644
--- a/www/mod_sqlinclude/Makefile
+++ b/www/mod_sqlinclude/Makefile
@@ -5,20 +5,25 @@
# $FreeBSD$
PORTNAME= mod_sqlinclude
-PORTVERSION= 1.2
+PORTVERSION= 1.4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
-DISTNAME= ${PORTNAME}_${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= anders@FreeBSD.org
COMMENT= An Apache module implementing config inclusion from MySQL databases
-LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+USE_MYSQL= yes
+DOCS= CHANGES.txt README.txt test.sql
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_APACHE2) || exists(${LOCALBASE}/include/apache2/apr.h)
+IGNORE= Sorry, mod_sqlinclude only works with Apache 1.x
+.else
USE_APACHE= yes
-DOCS= CHANGES.txt README.txt TODO.txt
+.endif
do-build:
(cd ${WRKSRC} && ${APXS} -c -I${LOCALBASE}/include \
@@ -33,4 +38,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/mod_sqlinclude/distinfo b/www/mod_sqlinclude/distinfo
index 80b7e51ae412..11fea817ebab 100644
--- a/www/mod_sqlinclude/distinfo
+++ b/www/mod_sqlinclude/distinfo
@@ -1,2 +1,2 @@
-MD5 (mod_sqlinclude_1.2.tgz) = 4db84fa282416ca098d937d18cd262d6
-SIZE (mod_sqlinclude_1.2.tgz) = 8832
+MD5 (mod_sqlinclude-1.4.tgz) = ecb1fd5d5a89c55e7dda4a9a456b0c13
+SIZE (mod_sqlinclude-1.4.tgz) = 10275
diff --git a/www/mod_sqlinclude/files/patch-mod_sqlinclude.c b/www/mod_sqlinclude/files/patch-mod_sqlinclude.c
deleted file mode 100644
index f48b0f8e09ad..000000000000
--- a/www/mod_sqlinclude/files/patch-mod_sqlinclude.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- mod_sqlinclude.c.orig Thu Oct 25 17:09:46 2001
-+++ mod_sqlinclude.c Thu Oct 25 17:10:00 2001
-@@ -376,7 +376,7 @@
- { "SQL_SQLPassword", cmd_sqli_sqlpassword, NULL, RSRC_CONF, TAKE1,
- "the MySQL password for SQLI_User. No default" },
- { "SQL_SQLDB", cmd_sqli_sqldb, NULL, RSRC_CONF, TAKE1,
-- "the MySQL database the module shall use. Default 'sqlinclude' },
-+ "the MySQL database the module shall use. Default 'sqlinclude'" },
-
- { "SQL_Include", cmd_sqli_include, NULL, RSRC_CONF, TAKE1,
- "valid SQL query. Data returned in 1st column will be passed to Apache" },
diff --git a/www/mod_sqlinclude/pkg-plist b/www/mod_sqlinclude/pkg-plist
index 8bcd0ce0e6ab..953b6df5b3bc 100644
--- a/www/mod_sqlinclude/pkg-plist
+++ b/www/mod_sqlinclude/pkg-plist
@@ -1,7 +1,7 @@
libexec/apache/mod_sqlinclude.so
@exec %D/sbin/apxs -e -A -n sqlinclude %f
@unexec %D/sbin/apxs -e -A -n sqlinclude %f
-%%PORTDOCS%%share/doc/mod_sqlinclude/CHANGES.txt
-%%PORTDOCS%%share/doc/mod_sqlinclude/README.txt
-%%PORTDOCS%%share/doc/mod_sqlinclude/TODO.txt
-%%PORTDOCS%%@dirrm share/doc/mod_sqlinclude
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/test.sql
+%%PORTDOCS%%@dirrm %%DOCSDIR%%