aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Robey <chuckr@FreeBSD.org>1997-06-09 20:21:38 +0000
committerChuck Robey <chuckr@FreeBSD.org>1997-06-09 20:21:38 +0000
commit07a0947d9687c4c6b81364b67e6da620d8bf3070 (patch)
treeef35318aaaf8abd1beeda483c2e3f8bd86bc2cb5
parent8631ac1f09a454b9e0c3ae024873c8c13100c61c (diff)
downloadports-07a0947d9687c4c6b81364b67e6da620d8bf3070.tar.gz
ports-07a0947d9687c4c6b81364b67e6da620d8bf3070.zip
Notes
-rw-r--r--emulators/xgs/Makefile59
-rw-r--r--emulators/xgs/distinfo4
-rw-r--r--emulators/xgs/pkg-comment2
-rw-r--r--emulators/xgs/pkg-descr48
-rw-r--r--emulators/xgs/pkg-plist33
5 files changed, 86 insertions, 60 deletions
diff --git a/emulators/xgs/Makefile b/emulators/xgs/Makefile
index 1515150e9638..ff3ef2e8bb83 100644
--- a/emulators/xgs/Makefile
+++ b/emulators/xgs/Makefile
@@ -1,40 +1,55 @@
-# New ports collection makefile for: xgs-0.40
-# Version required: 0.40
-# Date created: 17th January 1996
-# Whom: Joel Sutton <suttonj@interconnect.com.au>
+# New ports collection makefile for: xgs-0.50
+# Version required: 0.50
+# Date created: 2nd May, 1997
+# Whom: Joel Sutton <sutton@aardvark.apana.org.au>
+# FreeBSD Version: 2.1.5-RELEASE
#
-# $Id: Makefile,v 1.1.1.1 1997/02/24 13:50:06 tg Exp $
+# $Id$
#
-
-DISTNAME= xgs-0.40
+
+# This is the stable release of the xgs emulator. Sound support is
+# currently broken.
+
+# Distfile collection and extraction stuff
+#
+DISTNAME= xgs-0.50-src
+PKGNAME= xgs-0.50
+EXTRACT_SUFX= .tar.gz
CATEGORIES= emulators
-MASTER_SITES= http://www.optera.com/~invid/emulators/XGS/ \
+MASTER_SITES= ftp://ftp.optera.com/pub/xgs/ \
ftp://ftp.apple.asimov.net/pub/apple_II/emulators/rom_images/
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${ROMFILE}
-MAINTAINER= suttonj@interconnect.com.au
+MAINTAINER= sutton@aardvark.apana.org.au
+DIST_SUBDIR= xgs
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} xgs.rom
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-NO_PACKAGE= ${RESTRICTED}
RESTRICTED= "xgs.rom copyright is owned by Apple and cannot be distributed"
+NO_PACKAGE= ${RESTRICTED}
+
+# Source building
+#
WRKSRC= ${WRKDIR}/xgs
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-oss-sound
+CONFIGURE_ARGS= --with-x --datadir="${PREFIX}/lib"
-#INSTALL_DATA?= install -c -o bin -g bin
-ROMFILE= xgs.rom
-XGS= /share/xgs
-
-post-patch:
- cp ${DISTDIR}/${ROMFILE} ${WRKSRC}
+# Directories etc...
+#
+XGS_DOC= ${PREFIX}/share/doc/xgs
+XGS_LIB= ${PREFIX}/lib/xgs
+DOC_FILES= CHANGES.TXT COMPAT.TXT INSTALL.TXT TODO.TXT \
+ IWM-DOC.TXT XGS-FAQ.TXT
post-install:
.if !defined(NOPORTDOCS)
- ${INSTALL_DATA} -m 644 ${WRKSRC}/CHANGES ${WRKSRC}/COMPATIBILITY \
- ${WRKSRC}/README ${WRKSRC}/TO-DO ${PREFIX}${XGS}/
- ${INSTALL_DATA} -m 644 ${PKGDIR}/DESCR ${PREFIX}${XGS}/README.FreeBSD
+ -${MKDIR} ${XGS_DOC}
+ for file in ${DOC_FILES} ; do \
+ ${INSTALL_DATA} ${WRKSRC}/docs/$$file ${XGS_DOC}/ ;\
+ done
+ ${INSTALL_DATA} ${PKGDIR}/DESCR ${XGS_DOC}/README.FreeBSD
.endif
- ${INSTALL_DATA} -m 666 /dev/null ${PREFIX}${XGS}/xgs.ram
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/xgs.rom ${XGS_LIB}/
+ ${INSTALL_DATA} -m 666 /dev/null ${XGS_LIB}/xgs.ram
.include <bsd.port.mk>
diff --git a/emulators/xgs/distinfo b/emulators/xgs/distinfo
index 78e8a0b8ab84..b896572ca974 100644
--- a/emulators/xgs/distinfo
+++ b/emulators/xgs/distinfo
@@ -1,2 +1,2 @@
-MD5 (xgs-0.40.tar.gz) = fdd04ddfe2f188c301be7fd11be61ae8
-MD5 (xgs.rom) = 20a0334c447cb069a040ae5be1d938df
+MD5 (xgs/xgs-0.50-src.tar.gz) = a22f2974fd87253ba39c21a32451a4fb
+MD5 (xgs/xgs.rom) = 20a0334c447cb069a040ae5be1d938df
diff --git a/emulators/xgs/pkg-comment b/emulators/xgs/pkg-comment
index daa52ec76029..b08fa7cac0e2 100644
--- a/emulators/xgs/pkg-comment
+++ b/emulators/xgs/pkg-comment
@@ -1,2 +1,2 @@
-An Apple IIGS emulator.
+Apple IIGS emulator stable release 0.50
diff --git a/emulators/xgs/pkg-descr b/emulators/xgs/pkg-descr
index 53fd15c98e08..ca97d557afd0 100644
--- a/emulators/xgs/pkg-descr
+++ b/emulators/xgs/pkg-descr
@@ -1,26 +1,43 @@
-This emulator does a good job of emulating an Apple IIGS. Various IIGS
-hardware devices are also emulated (see README file) but this version
-is still an alpha so you might find a few things missing.
+General Notes
+=============
+
+This emulator does a great job of emulating an Apple IIGS. Various
+IIGS hardware devices are also emulated but this version is still an
+alpha quality release so you might find a few things missing.
XGS requires a copy of the IIGS ROM to boot up and this port should
attempt to FTP a copy of it from the Asimov archives (if it is still
available). If you have to obtain a copy of it manually then all you
-should need to do is drop it in the distfiles directory to allow the
-port to build. The md5 checksum file is specifically for the version 1
-ROM so you may have to alter it should you decide to use a version 3
-ROM. Also, this ROM cannot be distributed due to copyright reasons.
+should need to do is drop it in the xgs subdirectory of the distfiles
+directory to allow the port to build. This ROM cannot be distributed
+due to copyright reasons.
+
+Version Specific Notes
+======================
+
+Disk emulation has improved considerably. Many images available on the
+net will now load.
-Please check out the README file in either the working directory or
-/usr/local/share/xgs/ (or equivalent on your system). As this package
-has no man pages you will need to pick up the basics from there. All
-author credits can be found in these files also.
+A new disk image format has been adopted and further support for other
+image types have been added. Also most of the utilities have been
+consolidated into one program. Be sure to check the docs on this one.
-When loading disk images be sure to use the full path of the
-file you're loading.
+Sound emulation is currently broken and I'm looking for help in this
+area as I lack experience with sound programming. If you are able to
+assist, or even better, have some patches you can send me please
+contact me on the email address below.
+
+Finally
+=======
+
+Please check out the files in /usr/local/share/doc/xgs (or equivalent
+on your system). As this package has no man pages you will need to
+pick up the basics from there. All author credits can be found in
+these files also.
Check out the following for all sorts of Apple II goodies:
- http://www.asimov.net/
+ ftp://ftp.apple.asimov.net/pub/apple_II/
http://www.optera.com/~invid/emulators/XGS/
comp.emulators.apple2
@@ -28,4 +45,5 @@ Share and enjoy,
Joel...
:->
-suttonj@interconnect.com.au \ No newline at end of file
+sutton@aardvark.apana.org.au
+
diff --git a/emulators/xgs/pkg-plist b/emulators/xgs/pkg-plist
index ddec4d669f81..dd110cfed411 100644
--- a/emulators/xgs/pkg-plist
+++ b/emulators/xgs/pkg-plist
@@ -1,21 +1,14 @@
bin/xgs
-bin/build40
-bin/build80
-bin/dc2img
-bin/dsk2img
-bin/imginfo
-bin/lockimg
-bin/newimg
-bin/raw2img
-bin/show40
-bin/show80
-bin/unlockimg
-share/xgs/xgs40.fnt
-share/xgs/xgs80.fnt
-share/xgs/xgs.rom
-share/xgs/xgs.ram
-share/xgs/CHANGES
-share/xgs/COMPATIBILITY
-share/xgs/README
-share/xgs/TO-DO
-share/xgs/README.FreeBSD
+bin/imgutil
+share/doc/xgs/CHANGES.TXT
+share/doc/xgs/COMPAT.TXT
+share/doc/xgs/INSTALL.TXT
+share/doc/xgs/TODO.TXT
+share/doc/xgs/IWM-DOC.TXT
+share/doc/xgs/XGS-FAQ.TXT
+share/doc/xgs/README.FreeBSD
+lib/xgs/xgs40.fnt
+lib/xgs/xgs80.fnt
+lib/xgs/xgs.rom
+lib/xgs/xgs.ram
+