aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNik Clayton <nik@FreeBSD.org>1999-01-16 00:25:55 +0000
committerNik Clayton <nik@FreeBSD.org>1999-01-16 00:25:55 +0000
commit08addbfd375c03ba2af4b55eeb451652d33a94c3 (patch)
tree6cdc8469d816dd4a974009c6a5d410619d5d87ea
parent14d4b937c91e68bad90f77cfcf664d807ba9cfc9 (diff)
downloadports-08addbfd375c03ba2af4b55eeb451652d33a94c3.tar.gz
ports-08addbfd375c03ba2af4b55eeb451652d33a94c3.zip
Notes
-rw-r--r--www/sitecopy/Makefile36
-rw-r--r--www/sitecopy/distinfo2
-rw-r--r--www/sitecopy/pkg-comment1
-rw-r--r--www/sitecopy/pkg-descr16
-rw-r--r--www/sitecopy/pkg-plist1
5 files changed, 56 insertions, 0 deletions
diff --git a/www/sitecopy/Makefile b/www/sitecopy/Makefile
new file mode 100644
index 000000000000..05255e855093
--- /dev/null
+++ b/www/sitecopy/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: sitecopy
+# Version required: 0.3.2
+# Date created: 15 January 1999
+# Whom: nik
+#
+# $Id$
+#
+
+DISTNAME= sitecopy-0.3.2
+CATEGORIES= www
+DISTFILES= sitecopy-0.3.0.tar.gz
+
+MASTER_SITES= http://www.lyra.org/sitecopy/
+
+MAINTAINER= nik@FreeBSD.ORG
+
+DIST_SUBDIR= sitecopy
+
+PATCHFILES= sitecopy-0.3.0-0.3.2.patch.gz
+PATCH_SITES= http://www.lyra.org/sitecopy/
+
+USE_GMAKE= yes
+
+WRKSRC= ${WRKDIR}/sitecopy-0.3.0
+PATCH_DIST_STRIP=
+
+FETCH_BEFORE_ARGS= -b
+
+MAN1= sitecopy.1
+MANCOMPRESSED= no
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sitecopy ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/sitecopy.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/www/sitecopy/distinfo b/www/sitecopy/distinfo
new file mode 100644
index 000000000000..f7d7d4984f5c
--- /dev/null
+++ b/www/sitecopy/distinfo
@@ -0,0 +1,2 @@
+MD5 (sitecopy/sitecopy-0.3.0.tar.gz) = d210bcc50de61efede49c8b5010ad465
+MD5 (sitecopy/sitecopy-0.3.0-0.3.2.patch.gz) = 7cc807134aa27fec98df66c5c327c6b6
diff --git a/www/sitecopy/pkg-comment b/www/sitecopy/pkg-comment
new file mode 100644
index 000000000000..e73ccaac71cd
--- /dev/null
+++ b/www/sitecopy/pkg-comment
@@ -0,0 +1 @@
+Maintains remote websites, uses FTP to sync up with local copy
diff --git a/www/sitecopy/pkg-descr b/www/sitecopy/pkg-descr
new file mode 100644
index 000000000000..e6e6983124dc
--- /dev/null
+++ b/www/sitecopy/pkg-descr
@@ -0,0 +1,16 @@
+sitecopy is for copying locally stored websites to remote web servers.
+The program will upload files to the server which have changed locally,
+and delete files from the server which have been removed locally, to keep
+the remote site synchronized with the local site, with a single command.
+The aim is to remove the hassle of uploading and deleting individual files
+using an FTP client. sitecopy will also optionally try to spot files you move
+locally, and move them remotely.
+
+sitecopy is designed to not care about what is actually on the remote
+server - it simply keeps a record of what it THINKS is in on the remote
+server, and works from that.
+
+http://www.orton.demon.co.uk/
+
+- Nik
+nik@FreeBSD.ORG
diff --git a/www/sitecopy/pkg-plist b/www/sitecopy/pkg-plist
new file mode 100644
index 000000000000..0e26b93f24e5
--- /dev/null
+++ b/www/sitecopy/pkg-plist
@@ -0,0 +1 @@
+bin/sitecopy