aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2018-07-02 02:59:12 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2018-07-02 02:59:12 +0000
commit08b32a0f4b1fe3ae1b3c7e536cf4c9be26bd772d (patch)
tree020bac8aa2508bda1ee5df486bab3120c2f1c937
parent3ad060a5ba0dd40acf73000bac93a49187349383 (diff)
downloadports-08b32a0f4b1fe3ae1b3c7e536cf4c9be26bd772d.tar.gz
ports-08b32a0f4b1fe3ae1b3c7e536cf4c9be26bd772d.zip
Notes
-rw-r--r--graphics/opendx/Makefile10
-rw-r--r--graphics/opendx/files/patch-src_uipp_dxuilib_EditorWindow.C11
2 files changed, 19 insertions, 2 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index a3716df06fd3..61ef053b317c 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -16,8 +16,6 @@ LICENSE_NAME= IBM PUBLIC LICENSE - Open Visualization Data Explorer VERSION 1.0
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BROKEN_FreeBSD_12_amd64= fails to build: gmake[1]: *** No rule to make target 'Makefile'. Stop.
-
LIB_DEPENDS= libMagickWand-6.so:graphics/ImageMagick \
libtiff.so:graphics/tiff \
libcdf.so:science/cdf \
@@ -85,6 +83,14 @@ post-patch:
${WRKSRC}/src/uipp/java/server/Makefile.in
@${REINPLACE_CMD} -e 's|$$(ARCH)|@ARCH@|' \
${WRKSRC}/src/misc/Makefile.*
+ @${REINPLACE_CMD} -e 's/void exit (int);/[[noreturn]] void exit (int);/' \
+ ${WRKSRC}/configure
+ for f in `find ${WRKSRC} -name "*.bm"`; do \
+ if [ $${f%/*} != "${WRKSRC}/src/uipp/widgets" ]; then \
+ ${REINPLACE_CMD} -E 's/0x(..)/static_cast<char>(0x\1)/g' $$f; \
+ ${REINPLACE_CMD} -E 's/static unsigned char/static char/g' $$f; \
+ fi; \
+ done
post-install:
@${CP} ${FILESDIR}/pkg-message.in ${PKGMESSAGE}
diff --git a/graphics/opendx/files/patch-src_uipp_dxuilib_EditorWindow.C b/graphics/opendx/files/patch-src_uipp_dxuilib_EditorWindow.C
new file mode 100644
index 000000000000..b09683034a2e
--- /dev/null
+++ b/graphics/opendx/files/patch-src_uipp_dxuilib_EditorWindow.C
@@ -0,0 +1,11 @@
+--- src/uipp/dxuilib/EditorWindow.C.orig 2018-07-02 02:13:46 UTC
++++ src/uipp/dxuilib/EditorWindow.C
+@@ -5997,7 +5997,7 @@ char msg[128];
+ //
+ const char *tmpdir = theDXApplication->getTmpDirectory();
+ int tmpdirlen = STRLEN(tmpdir);
+- if (!tmpdirlen) return FALSE;
++ if (!tmpdirlen) return (char*) FALSE;
+ if (tmpdir[tmpdirlen-1] == '/') {
+ sprintf(netfilename, "%sdx%d.net", tmpdir, getpid());
+ sprintf(cfgfilename, "%sdx%d.cfg", tmpdir, getpid());