aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-23 15:04:41 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-23 15:04:41 +0000
commit08eb9f5168f9df56c85ba35df7f40dbdda179681 (patch)
treedf02ffbd51342caefce272c9ba5ae6dbf23d789d
parentb7390f974b1a2567d6eb4756b064efe32ca57414 (diff)
downloadports-08eb9f5168f9df56c85ba35df7f40dbdda179681.tar.gz
ports-08eb9f5168f9df56c85ba35df7f40dbdda179681.zip
Notes
-rw-r--r--security/xorsearch/Makefile12
-rw-r--r--security/xorsearch/files/patch-XORSearch.c2
2 files changed, 8 insertions, 6 deletions
diff --git a/security/xorsearch/Makefile b/security/xorsearch/Makefile
index 27ac918ff067..68f7c48b3173 100644
--- a/security/xorsearch/Makefile
+++ b/security/xorsearch/Makefile
@@ -2,14 +2,17 @@
# $FreeBSD$
PORTNAME= xorsearch
-PORTVERSION= 1.2.0
+DISTVERSION= 1_2_0
+PORTREVISION= 1
CATEGORIES= security textproc
MASTER_SITES= http://www.didierstevens.com/files/software/
-DISTNAME= XORSearch_V1_2_0
+DISTNAME= XORSearch_V${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Search for a given string in an XOR or ROL encoded binary file
+LICENSE= PD
+
USES= dos2unix zip
DOS2UNIX_GLOB= *.c
NO_WRKSUBDIR= yes
@@ -17,10 +20,9 @@ NO_WRKSUBDIR= yes
PLIST_FILES= bin/xorsearch
do-build:
- ${CC} -o ${WRKSRC}/XORSearch ${WRKSRC}/XORSearch.c
+ ${CC} ${CFLAGS} ${LDFLAGS} -o ${WRKSRC}/XORSearch ${WRKSRC}/XORSearch.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/XORSearch \
- ${STAGEDIR}${PREFIX}/bin/xorsearch
+ ${INSTALL_PROGRAM} ${WRKSRC}/XORSearch ${STAGEDIR}${PREFIX}/bin/xorsearch
.include <bsd.port.mk>
diff --git a/security/xorsearch/files/patch-XORSearch.c b/security/xorsearch/files/patch-XORSearch.c
index 20d6023363da..d109c0d33bac 100644
--- a/security/xorsearch/files/patch-XORSearch.c
+++ b/security/xorsearch/files/patch-XORSearch.c
@@ -1,4 +1,4 @@
---- XORSearch.c.orig 2016-06-20 15:09:40 UTC
+--- XORSearch.c.orig 2016-11-23 12:31:10 UTC
+++ XORSearch.c
@@ -20,7 +20,6 @@
#include <stdio.h>