aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2021-03-04 00:51:25 +0000
committerChris Rees <crees@FreeBSD.org>2021-03-04 00:51:25 +0000
commit0981f5668cf12cb6c1f8cab4438156d1993bf4fc (patch)
tree63fa92e9cd773c028c2479e3fdebaa62cd57867f
parente803ee984c9bf48244370f1eb8af2c332e910ab5 (diff)
downloadports-0981f5668cf12cb6c1f8cab4438156d1993bf4fc.tar.gz
ports-0981f5668cf12cb6c1f8cab4438156d1993bf4fc.zip
MFH: r567284
www/falkon: add flavor without KDE integration This results in a package that doesn't drag in huge numbers of KDE dependencies if you aren't on KDE. This replaces the OPTION KDEINTEGRATION. Approved by: kde (adridg) Differential Revision: https://reviews.freebsd.org/D29010
Notes
Notes: svn path=/branches/2021Q1/; revision=567285
-rw-r--r--www/falkon/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/www/falkon/Makefile b/www/falkon/Makefile
index e4afda042572..c6dd7d575185 100644
--- a/www/falkon/Makefile
+++ b/www/falkon/Makefile
@@ -22,13 +22,21 @@ USE_LDCONFIG= yes
CMAKE_ON= CMAKE_DISABLE_FIND_PACKAGE_PySide2
-OPTIONS_DEFINE= GNOMEKEYRING KDEINTEGRATION
-OPTIONS_DEFAULT= KDEINTEGRATION
+FLAVORS= default qtonly
+FLAVOR?= default
+qtonly_PKGNAMESUFFIX= -qtonly
+
+.if ${FLAVOR} != qtonly
+CMAKE_ON+= ENABLE_KDE_FRAMEWORKS_INTEGRATION_PLUGIN
+USE_KDE+= completion config coreaddons crash jobwidgets kio purpose service wallet widgetsaddons
+PLIST_SUB= KDEINTEGRATION=""
+.else
+PLIST_SUB= KDEINTEGRATION="@comment "
+.endif
+
+OPTIONS_DEFINE= GNOMEKEYRING
OPTIONS_SUB= YES
-KDEINTEGRATION_CMAKE_BOOL= ENABLE_KDE_FRAMEWORKS_INTEGRATION_PLUGIN
-KDEINTEGRATION_USE= KDE=completion,config,coreaddons,crash,jobwidgets,kio,purpose,service,wallet,widgetsaddons
-
GNOMEKEYRING_CMAKE_BOOL= BUILD_KEYRING
GNOMEKEYRING_USE= GNOME=glib20
GNOMEKEYRING_USES= gnome pkgconfig