aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-06-07 22:33:38 +0000
committerJohn Marino <marino@FreeBSD.org>2016-06-07 22:33:38 +0000
commit098c24f14a1a19b4c9c75b6b70e155e55e4fa4b3 (patch)
treeb75864340c2d129e9adc2136dc772dc10c3ff7e3
parentde8f793f7894b4c474f16a52f58156045757c85f (diff)
downloadports-098c24f14a1a19b4c9c75b6b70e155e55e4fa4b3.tar.gz
ports-098c24f14a1a19b4c9c75b6b70e155e55e4fa4b3.zip
Notes
-rw-r--r--lang/gcc5-aux/Makefile.version4
-rw-r--r--lang/gcc5-aux/distinfo5
-rw-r--r--lang/gcc5-aux/files/diff-ada8
-rw-r--r--lang/gcc5-aux/files/diff-core8
-rw-r--r--lang/gcc5-aux/files/patch-armv6-hf-support18
5 files changed, 12 insertions, 31 deletions
diff --git a/lang/gcc5-aux/Makefile.version b/lang/gcc5-aux/Makefile.version
index 6bf127a10389..743bac1f89e6 100644
--- a/lang/gcc5-aux/Makefile.version
+++ b/lang/gcc5-aux/Makefile.version
@@ -1,9 +1,9 @@
# $FreeBSD$
GCC_BRANCH= 5
-GCC_POINT= 3.0
+GCC_POINT= 4.0
GCC_VERSION= ${GCC_BRANCH}.${GCC_POINT}
-SNAPSHOT= 20151204
+SNAPSHOT= 20160603
BUILD_RELEASE= yes
MAIN_PR= 0
UTIL_PR= 0
diff --git a/lang/gcc5-aux/distinfo b/lang/gcc5-aux/distinfo
index 192178636d3f..29eb6044890f 100644
--- a/lang/gcc5-aux/distinfo
+++ b/lang/gcc5-aux/distinfo
@@ -1,5 +1,6 @@
-SHA256 (gcc-5.3.0.tar.bz2) = b84f5592e9218b73dbae612b5253035a7b34a9a1f7688d2e1bfaaf7267d5c4db
-SIZE (gcc-5.3.0.tar.bz2) = 95441837
+TIMESTAMP = 1465327731
+SHA256 (gcc-5.4.0.tar.bz2) = 608df76dec2d34de6558249d8af4cbee21eceddbcb580d666f7a5a583ca3303a
+SIZE (gcc-5.4.0.tar.bz2) = 95661481
SHA256 (ada-bootstrap.i386.freebsd.100B.tar.bz2) = 7231209f2600275f554f788ad1d036cf633c4339ebd25bd479a5bb1ddcddedf3
SIZE (ada-bootstrap.i386.freebsd.100B.tar.bz2) = 41229192
SHA256 (ada-bootstrap.x86_64.dragonfly.41.tar.bz2) = eb7785d8b842aee2bb04b43adfb1346b178ee4e83d8775b4e6705fd23f1586f0
diff --git a/lang/gcc5-aux/files/diff-ada b/lang/gcc5-aux/files/diff-ada
index 7d8923da20d9..356bc3b3c68b 100644
--- a/lang/gcc5-aux/files/diff-ada
+++ b/lang/gcc5-aux/files/diff-ada
@@ -2369,7 +2369,7 @@
THREADSLIB = -lposix4 -lthread
MISCLIB = -lposix4 -lnsl -lsocket
SO_OPTS = -Wl,-h,
-@@ -1420,8 +1424,11 @@
+@@ -1416,8 +1420,11 @@
ifeq ($(strip $(filter-out %86 freebsd%,$(target_cpu) $(target_os))),)
LIBGNAT_TARGET_PAIRS = \
a-intnam.ads<a-intnam-freebsd.ads \
@@ -2381,7 +2381,7 @@
s-osinte.adb<s-osinte-freebsd.adb \
s-osinte.ads<s-osinte-freebsd.ads \
s-osprim.adb<s-osprim-posix.adb \
-@@ -1436,6 +1443,8 @@
+@@ -1432,6 +1439,8 @@
mlib-tgt-specific.adb<mlib-tgt-specific-linux.adb
GNATLIB_SHARED = gnatlib-shared-dual
@@ -2390,7 +2390,7 @@
EXTRA_GNATRTL_NONTASKING_OBJS=g-sse.o g-ssvety.o
EH_MECHANISM=-gcc
-@@ -1449,8 +1458,11 @@
+@@ -1445,8 +1454,11 @@
ifeq ($(strip $(filter-out %86_64 freebsd%,$(target_cpu) $(target_os))),)
LIBGNAT_TARGET_PAIRS = \
a-intnam.ads<a-intnam-freebsd.ads \
@@ -2402,7 +2402,7 @@
s-osinte.adb<s-osinte-freebsd.adb \
s-osinte.ads<s-osinte-freebsd.ads \
s-osprim.adb<s-osprim-posix.adb \
-@@ -1465,6 +1477,110 @@
+@@ -1461,6 +1473,110 @@
mlib-tgt-specific.adb<mlib-tgt-specific-linux.adb
GNATLIB_SHARED = gnatlib-shared-dual
diff --git a/lang/gcc5-aux/files/diff-core b/lang/gcc5-aux/files/diff-core
index 98b2f146c51c..7451751b034b 100644
--- a/lang/gcc5-aux/files/diff-core
+++ b/lang/gcc5-aux/files/diff-core
@@ -11,13 +11,11 @@
#undef LINK_SPEC
--- gcc/config/i386/freebsd.h.orig
+++ gcc/config/i386/freebsd.h
-@@ -77,6 +77,14 @@
+@@ -77,6 +77,12 @@
When the -shared link option is used a final link is not being
done. */
-+#if FBSD_MAJOR < 9
-+#define ELF_HASH_STYLE ""
-+#elif FBSD_MAJOR < 10
++#if FBSD_MAJOR < 10
+#define ELF_HASH_STYLE "--hash-style=both "
+#else
+#define ELF_HASH_STYLE "--hash-style=gnu "
@@ -26,7 +24,7 @@
#undef LINK_SPEC
#define LINK_SPEC "\
%{p:%nconsider using '-pg' instead of '-p' with gprof(1)} \
-@@ -88,6 +96,7 @@
+@@ -88,6 +94,7 @@
%{rdynamic:-export-dynamic} \
-dynamic-linker %(fbsd_dynamic_linker) } \
%{static:-Bstatic}} \
diff --git a/lang/gcc5-aux/files/patch-armv6-hf-support b/lang/gcc5-aux/files/patch-armv6-hf-support
deleted file mode 100644
index 9352e2cdfcc0..000000000000
--- a/lang/gcc5-aux/files/patch-armv6-hf-support
+++ /dev/null
@@ -1,18 +0,0 @@
---- UTC
---- gcc/config.gcc.orig 2016-05-25 22:53:15.930993000 +0200
-+++ gcc/config.gcc 2016-05-25 22:54:06.087115000 +0200
-@@ -1026,11 +1026,9 @@
- case $target in
- armv6*-*-freebsd*)
- tm_defines="${tm_defines} TARGET_FREEBSD_ARMv6=1"
-- ;;
-- esac
-- case $target in
-- arm*hf-*-freebsd*)
-- tm_defines="${tm_defines} TARGET_FREEBSD_ARM_HARD_FLOAT=1"
-+ if test $fbsd_major -ge 11; then
-+ tm_defines="${tm_defines} TARGET_FREEBSD_ARM_HARD_FLOAT=1"
-+ fi
- ;;
- esac
- with_tls=${with_tls:-gnu}