aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-01-05 21:16:53 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-01-05 21:16:53 +0000
commit0a87a5fb5dc2adf597103ef3b971a741bdf5745d (patch)
treef6f7bf3ecb454102c9d2fde5213786edb6ddea6e
parentc73aca2ef0ab80026d0c11da182f2ad6567b19f2 (diff)
downloadports-0a87a5fb5dc2adf597103ef3b971a741bdf5745d.tar.gz
ports-0a87a5fb5dc2adf597103ef3b971a741bdf5745d.zip
Notes
-rw-r--r--astro/pyweather/Makefile28
-rw-r--r--astro/pyweather/distinfo1
-rw-r--r--astro/pyweather/pkg-comment1
-rw-r--r--astro/pyweather/pkg-descr5
-rw-r--r--astro/pyweather/pkg-plist1
5 files changed, 36 insertions, 0 deletions
diff --git a/astro/pyweather/Makefile b/astro/pyweather/Makefile
new file mode 100644
index 000000000000..dd1b2c163825
--- /dev/null
+++ b/astro/pyweather/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: pyWeather
+# Version required: 0.1b
+# Date created: 18 Dec 1999
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= pyWeather
+PKGNAME= pyWeather-0.1b
+CATEGORIES= astro python
+MASTER_SITES= http://members.bellatlantic.net/~rasclkng/
+
+MAINTAINER= andrews@technologist.com
+
+RUN_DEPENDS= ${PYTHON}:${PORTSDIR}/lang/python
+
+NO_BUILD= yes
+PYTHON?= ${LOCALBASE}/bin/python
+
+pre-install:
+ @${PERL} -pi -e "s:/usr/bin/python:${PYTHON}:g" ${WRKSRC}/pyWeather.py
+ @${PERL} -pi -e "s:pyWeather.py:pyWeather:g" ${WRKSRC}/pyWeather.py
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/pyWeather.py ${PREFIX}/bin/pyWeather
+
+.include <bsd.port.mk>
diff --git a/astro/pyweather/distinfo b/astro/pyweather/distinfo
new file mode 100644
index 000000000000..e52bf94f3e20
--- /dev/null
+++ b/astro/pyweather/distinfo
@@ -0,0 +1 @@
+MD5 (pyWeather.tar.gz) = 0c62a75cf3357c5a5f92ca5df004c4d7
diff --git a/astro/pyweather/pkg-comment b/astro/pyweather/pkg-comment
new file mode 100644
index 000000000000..6f44238bc5da
--- /dev/null
+++ b/astro/pyweather/pkg-comment
@@ -0,0 +1 @@
+Python script that downloads weather data and can be cron'd
diff --git a/astro/pyweather/pkg-descr b/astro/pyweather/pkg-descr
new file mode 100644
index 000000000000..e125c439eb7b
--- /dev/null
+++ b/astro/pyweather/pkg-descr
@@ -0,0 +1,5 @@
+Python script that downloads weather data and can be cron'd.
+
+WWW: http://members.bellatlantic.net/~rasclkng/
+
+Author: The Almighty Groundhog <groundhog@linuxfreak.com>
diff --git a/astro/pyweather/pkg-plist b/astro/pyweather/pkg-plist
new file mode 100644
index 000000000000..cd635b12b3b6
--- /dev/null
+++ b/astro/pyweather/pkg-plist
@@ -0,0 +1 @@
+bin/pyWeather