aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-12-20 19:20:20 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-12-20 19:20:20 +0000
commit0a89159f7aec94ccc7a0d529aac87c2ddccfa17c (patch)
tree3f469986f6ee89f25adea6ebc68a82c0974413eb
parentdb39692c8307287b27a1a44d3268526359f9eb5c (diff)
downloadports-0a89159f7aec94ccc7a0d529aac87c2ddccfa17c.tar.gz
ports-0a89159f7aec94ccc7a0d529aac87c2ddccfa17c.zip
Notes
-rw-r--r--security/dsniff/Makefile10
-rw-r--r--security/dsniff/files/patch-pcaputil.c41
2 files changed, 35 insertions, 16 deletions
diff --git a/security/dsniff/Makefile b/security/dsniff/Makefile
index 40b4791d15bf..fabd531b04ae 100644
--- a/security/dsniff/Makefile
+++ b/security/dsniff/Makefile
@@ -14,18 +14,16 @@ COMMENT= Various sniffing utilities for penetration testing
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libnet.so:net/libnet
BUILD_DEPENDS= ${LOCALBASE}/lib/libnids.a:net/libnids
+LIB_DEPENDS= libnet.so:net/libnet
-BROKEN_FreeBSD_12= fails to compile: pcaputil.c: '/usr/include/pcap-int.h' file not found
-BROKEN_FreeBSD_11= fails to compile: pcaputil.c: '/usr/include/pcap-int.h' file not found
+USES= gettext pkgconfig ssl
+USE_GNOME= glib20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libnet=${LOCALBASE}
DESTDIRNAME= install_prefix
-USES= gettext pkgconfig ssl
-USE_GNOME= glib20
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/(.*)..$/\1/}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/..$//}
OPTIONS_DEFINE= X11
OPTIONS_DEFAULT= X11
diff --git a/security/dsniff/files/patch-pcaputil.c b/security/dsniff/files/patch-pcaputil.c
index ecaf1bdc226b..63418e227b72 100644
--- a/security/dsniff/files/patch-pcaputil.c
+++ b/security/dsniff/files/patch-pcaputil.c
@@ -1,15 +1,36 @@
---- ./pcaputil.c.orig 2001-03-15 09:33:04.000000000 +0100
-+++ ./pcaputil.c 2014-07-22 13:20:14.000000000 +0200
-@@ -16,9 +16,10 @@
- #include <stdlib.h>
+--- pcaputil.c.orig 2001-03-15 08:33:04 UTC
++++ pcaputil.c
+@@ -17,20 +17,9 @@
#include <string.h>
#include <err.h>
--#include <pcap.h>
-+#include <net/bpf.h>
-+#include </usr/include/pcap.h>
- #ifdef BSD
+ #include <pcap.h>
+-#ifdef BSD
-#include <pcap-int.h>
-+#include </usr/include/pcap-int.h>
- #endif
+-#endif
#include "pcaputil.h"
+
+-#ifdef BSD
+-static int
+-bpf_immediate(int fd, int on)
+-{
+- return (ioctl(fd, BIOCIMMEDIATE, &on));
+-}
+-#endif
+-
+ int
+ pcap_dloff(pcap_t *pd)
+ {
+@@ -87,12 +76,6 @@ pcap_init(char *intf, char *filter, int
+ pcap_perror(pd, "pcap_compile");
+ return (NULL);
+ }
+-#ifdef BSD
+- if (bpf_immediate(pd->fd, 1) < 0) {
+- perror("ioctl");
+- return (NULL);
+- }
+-#endif
+ return (pd);
+ }
+