aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-06 05:45:44 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-06 05:45:44 +0000
commit0aec81bd953beec581a889cb7cb5a887313727f1 (patch)
tree0570849ae7eba6dc0bbf1b08a6c51cd406c908f9
parent30ea9fa4227900c97e9a5452c6b28ca9ca45e8bd (diff)
Convert to new options framework
Notes
Notes: svn path=/head/; revision=320050
-rw-r--r--misc/amanda-server/Makefile35
-rw-r--r--misc/amanda25-server/Makefile56
-rw-r--r--misc/amanda26-server/Makefile54
-rw-r--r--misc/amanda32-server/Makefile38
4 files changed, 95 insertions, 88 deletions
diff --git a/misc/amanda-server/Makefile b/misc/amanda-server/Makefile
index f4758a4ee31a..36e8708ef571 100644
--- a/misc/amanda-server/Makefile
+++ b/misc/amanda-server/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: amanda
-# Date created: 28th Feb 1995
-# Whom: gpalmer
-#
+# Created by: gpalmer
# $FreeBSD$
-#
PORTNAME= amanda
PORTVERSION= 3.3.2
@@ -42,9 +38,9 @@ PKG_MESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
SUB_LIST= PORTSDIR=${PORTSDIR}
-OPTIONS= GNUTAR "use GNU tar" on
-
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= GNUTAR
+OPTIONS_DEFAULT= GNUTAR
+GNUTAR_DESC= use GNU tar
.if defined(AMANDA_USER)
USERS= ${AMANDA_USER}
@@ -66,7 +62,16 @@ CONFIGURE_ARGS+= --with-index-server=${AMANDA_SERVER}
CONFIGURE_ARGS+= --with-tape-server=${AMANDA_SERVER}
.endif
-.if !defined(WITHOUT_GNUTAR)
+.if !defined(CLIENT_ONLY)
+OPTIONS_DEFINE+= PLOT SAMBA S3
+PLOT_DESC= Enable ploting, requires X11 libraries
+SAMBA_DESC= Enable the use of smbclient
+S3_DESC= Enable Amazon S3 device support
+.endif
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGNUTAR}
CONFIGURE_ARGS+=--with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR} \
--with-gnutar=${LOCALBASE}/bin/gtar
BUILD_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
@@ -119,11 +124,7 @@ MAN8= amaddclient.8 amadmin.8 amaespipe.8 amcheck.8 \
amtape.8 amtoc.8 amtapetype.8 \
amvault.8
-OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
- SAMBA "enable the use of smbclient" off \
- S3 "enable Amazon S3 device support" off
-
-.if defined (WITH_PLOT)
+.if ${PORT_OPTIONS:MPLOT}
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
MAN8+= amplot.8
@@ -134,7 +135,7 @@ PLIST_SUB+= PLOT='@comment '
CONFIGURE_ARGS+= --without-gnuplot
.endif
-.if defined (WITH_SAMBA)
+.if ${PORT_OPTIONS:MSAMBA}
SAMBA_PORT?= samba36
BUILD_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
RUN_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
@@ -142,7 +143,7 @@ CONFIGURE_ARGS+= --with-smbclient=${LOCALBASE}/bin/smbclient
.endif
# If configure founds libcurl, automatically enabled it (with plist change).
-.if defined(WITH_S3)
+.if ${PORT_OPTIONS:MS3}
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --enable-s3-device
PLIST_SUB+= S3DEVICE=''
@@ -216,4 +217,4 @@ post-install:
# Prefix @WANT_CLIENT_TRUE@ for client only files.
# For debugging: dbprintf(_("getcmd: %s\n"), line);
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/amanda25-server/Makefile b/misc/amanda25-server/Makefile
index d785424b37f2..db833ab4d567 100644
--- a/misc/amanda25-server/Makefile
+++ b/misc/amanda25-server/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: amanda
-# Date created: 28th Feb 1995
-# Whom: gpalmer
-#
+# Created by: gpalmer
# $FreeBSD$
-#
PORTNAME= amanda
PORTVERSION= 2.5.1p3
@@ -34,10 +30,10 @@ WANT_PERL= yes
SAMBA_PORT?= net/samba36
-OPTIONS= GNUTAR "use GNU tar" on \
- SSH "enable ssh-auth" off
-
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= GNUTAR SSH
+OPTIONS_DEFAULT= SSH
+GNUTAR_DESC= use GNU tar
+SSH_DESC= Enable ssh-auth
AMANDA_USER?= operator
AMANDA_GROUP?= operator
@@ -58,10 +54,6 @@ CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
CONFIGURE_ARGS+= --with-udpportrange=${AMANDA_UDPPORTRANGE}
.endif
-.if defined (WITH_SSH)
-CONFIGURE_ARGS+= --with-ssh-security
-.endif
-
# AMANDA_PORTRANGE is obsoleted. Use AMANDA_TCPPORTRANGE instead.
.if defined (AMANDA_PORTRANGE)
AMANDA_TCPPORTRANGE= ${AMANDA_PORTRANGE}
@@ -70,7 +62,24 @@ AMANDA_TCPPORTRANGE= ${AMANDA_PORTRANGE}
CONFIGURE_ARGS+= --with-tcpportrange=${AMANDA_TCPPORTRANGE}
.endif
-.if !defined(WITHOUT_GNUTAR)
+.if !defined(CLIENT_ONLY)
+OPTIONS_DEFINE+= PLOT SAMBA MTX AESPIPE
+PLOT_DESC= Eenable ploting, requires X11 libraries
+SAMBA_DESC= Enable the use of smbclient
+MTX_DESC= Enable the use of mtx changer scripts
+AESPIPE_DESC= Enable encryption. Needed by amcrypt
+.else
+OPTIONS_DEFINE+= DUMP_SNAPSHOT
+DUMP_SNAPSHOT_DESC= Use snapshot by using dump -L
+.endif
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSSH}
+CONFIGURE_ARGS+= --with-ssh-security
+.endif
+
+.if ${PORT_OPTIONS:MGNUTAR}
CONFIGURE_ARGS+=--with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR} \
--with-gnutar=${LOCALBASE}/bin/gtar
BUILD_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
@@ -126,12 +135,7 @@ MAN8= amadmin.8 amaespipe.8 amcheck.8 \
amoverview.8 amreport.8 amrmtape.8 amstatus.8 \
amtape.8 amtoc.8 amverify.8 amverifyrun.8 amtapetype.8
-OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
- SAMBA "enable the use of smbclient" off \
- MTX "enable the use of mtx changer scripts" off \
- AESPIPE "enable encryption. Needed by amcrypt" off
-
-.if defined (WITH_PLOT)
+.if ${PORT_OPTIONS:MPLOT}
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
MAN8+= amplot.8
@@ -140,18 +144,18 @@ PLIST_SUB+= PLOT=''
PLIST_SUB+= PLOT='@comment '
.endif
-.if defined (WITH_SAMBA)
+.if ${PORT_OPTIONS:MSAMBA}
BUILD_DEPENDS+= smbclient:${PORTSDIR}/${SAMBA_PORT}
RUN_DEPENDS+= smbclient:${PORTSDIR}/${SAMBA_PORT}
CONFIGURE_ARGS+= --with-smbclient=${LOCALBASE}/bin/smbclient
.endif
-.if defined (WITH_MTX)
+.if ${PORT_OPTIONS:MMTX}
BUILD_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
RUN_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
.endif
-.if defined (WITH_AESPIPE)
+.if ${PORT_OPTIONS:MAESPIPE}
RUN_DEPENDS+= aespipe:${PORTSDIR}/security/aespipe
.endif
@@ -194,8 +198,6 @@ CONFIGURE_ARGS+=--without-server
MAN5= amanda.conf.5 amanda-client.conf.5
MAN8= amanda.8 amrecover.8 amrestore.8
-OPTIONS+= DUMP_SNAPSHOT "use snapshot by using dump -L" off
-
post-install:
${MKDIR} ${PREFIX}/share/examples/amanda
${CP} -R ${WRKSRC}/example/amanda.conf \
@@ -208,7 +210,7 @@ post-install:
${TOUCH} /etc/amandates
${CHOWN} ${AMANDA_USER}:${AMANDA_GROUP} /etc/amandates
-.if defined (WITH_DUMP_SNAPSHOT)
+.if ${PORT_OPTIONS:MDUMP_SNAPSHOT}
EXTRA_PATCHES= ${FILESDIR}/extra-patch-sendbackup-dump.c
.endif
@@ -218,4 +220,4 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-sendbackup-dump.c
# o amanda-server installs lib/libamandad.a which should be handled by
# amanda-client only.
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/amanda26-server/Makefile b/misc/amanda26-server/Makefile
index 0c6139e00380..716b95485212 100644
--- a/misc/amanda26-server/Makefile
+++ b/misc/amanda26-server/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: amanda
-# Date created: 28th Feb 1995
-# Whom: gpalmer
-#
+# Created by: gpalmer
# $FreeBSD$
-#
PORTNAME= amanda
PORTVERSION= 2.6.1p2
@@ -20,8 +16,9 @@ WRKSRC= ${WRKDIR}/amanda-${PORTVERSION}
SLAVEDIRS= misc/amanda26-client
NO_LATEST_LINK= yes
+USES= pkgconfig
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig glib20
+USE_GNOME= glib20
USE_GMAKE= yes
USE_OPENSSL= yes
PATCH_STRIP=
@@ -38,9 +35,8 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
USE_LDCONFIG= yes
USE_PERL5= yes
-OPTIONS= GNUTAR "use GNU tar" on
-
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= GNUTAR
+GNUTAR_DESC= use GNU tar
AMANDA_USER?= operator
AMANDA_GROUP?= operator
@@ -58,7 +54,21 @@ CONFIGURE_ARGS+= --with-tape-server=${AMANDA_SERVER}
CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
.endif
-.if !defined(WITHOUT_GNUTAR)
+.if !defined(CLIENT_ONLY)
+OPTIONS_DEFINE+= PLOT SAMBA MTX AESPIPE S3
+PLOT_DESC= Enable ploting, requires X11 libraries
+SAMBA_DESC= Enable the use of smbclient
+MTX_DESC= Enable the use of mtx changer scripts
+AESPIPE_DESC= Enable encryption. Needed by amcrypt
+S3_DESC= Enable Amazon S3 device support
+.else
+OPTIONS_DEFINE+= ZFSCOMP
+ZFSCOMP_DESC= Accurate estimation of compressed ZFS filesystems
+.endif
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGNUTAR}
CONFIGURE_ARGS+=--with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR} \
--with-gnutar=${LOCALBASE}/bin/gtar
BUILD_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
@@ -107,13 +117,7 @@ MAN8= amaddclient.8 amadmin.8 amaespipe.8 amcheck.8 \
amtape.8 amtoc.8 amtapetype.8 \
amvault.8
-OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
- SAMBA "enable the use of smbclient" off \
- MTX "enable the use of mtx changer scripts" off \
- AESPIPE "enable encryption. Needed by amcrypt" off \
- S3 "enable Amazon S3 device support" off
-
-.if defined (WITH_PLOT)
+.if ${PORT_OPTIONS:MPLOT}
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
MAN8+= amplot.8
@@ -124,25 +128,25 @@ PLIST_SUB+= PLOT='@comment '
CONFIGURE_ARGS+= --without-gnuplot
.endif
-.if defined (WITH_SAMBA)
+.if ${PORT_OPTIONS:MSAMBA}
SAMBA_PORT?= samba36
BUILD_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
RUN_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
CONFIGURE_ARGS+= --with-smbclient=${LOCALBASE}/bin/smbclient
.endif
-.if defined (WITH_MTX)
+.if ${PORT_OPTIONS:MMTX}
BUILD_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
RUN_DEPENDS+= mtx:${PORTSDIR}/misc/mtx
.endif
-.if defined (WITH_AESPIPE)
+.if ${PORT_OPTIONS:MAESPIPE}
RUN_DEPENDS+= aespipe:${PORTSDIR}/security/aespipe
.else
.endif
# If configure founds libcurl, automatically enabled it (with plist change).
-.if defined(WITH_S3)
+.if ${PORT_OPTIONS:MS3}
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --enable-s3-device
PLIST_SUB+= S3DEVICE=''
@@ -176,8 +180,6 @@ pre-fetch:
@${ECHO} " AMANDA_DATES=path to client amandates file"
@${ECHO} ""
-OPTIONS+= ZFSCOMP "accurate estimation of compressed ZFS filesystems" off
-
CONFLICTS= amanda-client-2.5.* amanda-client-3.*
CONFIGURE_ARGS+=--without-server --with-amandates=${AMANDA_DATES}
@@ -198,7 +200,7 @@ MAN8= amanda.8 \
script-email.8
post-install:
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${EXAMPLESDIR}
${CP} -R ${WRKSRC}/example/chg-multi.conf \
${WRKSRC}/example/chg-scsi.conf \
@@ -212,7 +214,7 @@ post-install:
.endif
-.if defined(WITH_ZFSCOMP)
+.if ${PORT_OPTIONS:MZFSCOMP}
EXTRA_PATCHES= ${FILESDIR}/extra-patch-application-src::amzfs-sendrecv.pl
.endif
@@ -225,4 +227,4 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-application-src::amzfs-sendrecv.pl
# which should be handled by amanda-client only.
# o pthread issue: http://wiki.zmanda.com/index.php/Installation/OS_Specific_Notes/Installing_Amanda_on_FreeBSD#Threading_and_-pthread
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index 54c48c6cd6ab..bf12fa9f8831 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: amanda
-# Date created: 28th Feb 1995
-# Whom: gpalmer
-#
+# Created by: gpalmer
# $FreeBSD$
-#
PORTNAME= amanda
PORTVERSION= 3.2.3
@@ -23,7 +19,8 @@ SLAVEDIRS= misc/amanda32-client
NO_LATEST_LINK= yes
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig glib20
+USES= pkgconfig
+USE_GNOME= glib20
USE_GMAKE= yes
USE_OPENSSL= yes
USE_LDCONFIG= yes
@@ -42,9 +39,9 @@ PKG_MESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
SUB_LIST= PORTSDIR=${PORTSDIR}
-OPTIONS= GNUTAR "use GNU tar" on
-
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= GNUTAR
+OPTIONS_DEFAULT= GNUTAR
+GNUTAR_DESC= Use GNU tar
.if defined(AMANDA_USER)
USERS= ${AMANDA_USER}
@@ -66,7 +63,16 @@ CONFIGURE_ARGS+= --with-index-server=${AMANDA_SERVER}
CONFIGURE_ARGS+= --with-tape-server=${AMANDA_SERVER}
.endif
-.if !defined(WITHOUT_GNUTAR)
+.if !defined(CLIENT_ONLY)
+OPTIONS_DEFINE+= PLOT SAMBA S3
+PLOT_DESC= Enable ploting, requires X11 libraries
+SAMBA_DESC= Enable the use of smbclient
+S3_DESC= Enable Amazon S3 device support
+.endif
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGNUTAR}
CONFIGURE_ARGS+=--with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR} \
--with-gnutar=${LOCALBASE}/bin/gtar
BUILD_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
@@ -116,11 +122,7 @@ MAN8= amaddclient.8 amadmin.8 amaespipe.8 amcheck.8 \
amtape.8 amtoc.8 amtapetype.8 \
amvault.8
-OPTIONS+= PLOT "enable ploting, requires X11 libraries" off\
- SAMBA "enable the use of smbclient" off \
- S3 "enable Amazon S3 device support" off
-
-.if defined (WITH_PLOT)
+.if ${PORT_OPTIONS:MPLOT}
BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
MAN8+= amplot.8
@@ -131,7 +133,7 @@ PLIST_SUB+= PLOT='@comment '
CONFIGURE_ARGS+= --without-gnuplot
.endif
-.if defined (WITH_SAMBA)
+.if ${PORT_OPTIONS:MSAMBA}
SAMBA_PORT?= samba36
BUILD_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
RUN_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
@@ -139,7 +141,7 @@ CONFIGURE_ARGS+= --with-smbclient=${LOCALBASE}/bin/smbclient
.endif
# If configure founds libcurl, automatically enabled it (with plist change).
-.if defined(WITH_S3)
+.if ${PORT_OPTIONS:MS3}
LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --enable-s3-device
PLIST_SUB+= S3DEVICE=''
@@ -211,4 +213,4 @@ post-install:
# Prefix @WANT_CLIENT_TRUE@ for client only files.
# For debugging: dbprintf(_("getcmd: %s\n"), line);
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>