aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-08-12 13:21:07 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-08-12 13:21:07 +0000
commit0b39c99dba4c3cd7adfb9c661ff4abd9aaa6f6f0 (patch)
treea2d60c2fbd10797a8234e895a19a3f14a62b06d1
parentee30f238a6dc41e8364e9495e373b217001f3062 (diff)
downloadports-0b39c99dba4c3cd7adfb9c661ff4abd9aaa6f6f0.tar.gz
ports-0b39c99dba4c3cd7adfb9c661ff4abd9aaa6f6f0.zip
Fix the build with GCC 6.
While here, drop USE_GCC=yes, as the port was verified to build with clang on both HEAD-amd64 and 10.3-i386. PR: 219288 Approved by: maintainer timeout (amdmi3, 18 days)
Notes
Notes: svn path=/head/; revision=447829
-rw-r--r--math/drgeo/Makefile3
-rw-r--r--math/drgeo/files/patch-geo_drgeo__figure.cc17
2 files changed, 18 insertions, 2 deletions
diff --git a/math/drgeo/Makefile b/math/drgeo/Makefile
index 46b409abce75..d0381962c340 100644
--- a/math/drgeo/Makefile
+++ b/math/drgeo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= drgeo
PORTVERSION= 1.1.0
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= math
MASTER_SITES= SF/ofset/${PORTNAME}/${PORTVERSION}
@@ -17,7 +17,6 @@ USES= gettext gmake pkgconfig pathfix
USE_GNOME= gnomeprefix intlhack libglade2
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GCC= yes # segfaults when built with clang
PORTDATA= *
diff --git a/math/drgeo/files/patch-geo_drgeo__figure.cc b/math/drgeo/files/patch-geo_drgeo__figure.cc
new file mode 100644
index 000000000000..1f87f43cd587
--- /dev/null
+++ b/math/drgeo/files/patch-geo_drgeo__figure.cc
@@ -0,0 +1,17 @@
+Fix the build with GCC >= 6.
+
+drgeo_figure.cc: At global scope:
+drgeo_figure.cc:56:1: error: '<anonymous struct> drgeoDialogData', declared using anonymous type, is used but never defined [-fpermissive]
+ drgeoDialogData;
+ ^~~~~~~~~~~~~~~
+--- geo/drgeo_figure.cc.orig 2017-07-25 16:56:59 UTC
++++ geo/drgeo_figure.cc
+@@ -48,7 +48,7 @@
+ #include "drgeo_dialog.h"
+ #include "traite.h"
+
+-extern struct
++struct
+ {
+ drgeoPoint mouse;
+ drgeoFigure *figure;