aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-19 16:48:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-19 16:48:26 +0000
commit0bb78febf2425796df25a5cd43322851b3e6681a (patch)
tree781ef9882873423c56fcab6d24355c41d56c420f
parent002cc659f0f56028395a985d602b53f1bdf594e3 (diff)
downloadports-0bb78febf2425796df25a5cd43322851b3e6681a.tar.gz
ports-0bb78febf2425796df25a5cd43322851b3e6681a.zip
Notes
-rw-r--r--net/ntop/Makefile11
-rw-r--r--net/ntop/distinfo6
-rw-r--r--net/ntop/files/patch-Makefile.am8
-rw-r--r--net/ntop/files/patch-autogen.sh4
-rw-r--r--net/ntop/files/patch-configure.in56
-rw-r--r--net/ntop/files/patch-plugins_netflowPlugin.c11
-rw-r--r--net/ntop/pkg-plist21
7 files changed, 65 insertions, 52 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index b0d6e9936b0e..e6ab301fc96c 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -6,17 +6,17 @@
#
PORTNAME= ntop
-PORTVERSION= 3.3.9
-PORTREVISION= 2
+PORTVERSION= 3.3.10
CATEGORIES= net
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= scjamorim@bsd.com.br
COMMENT= Network monitoring tool with command line and web interfaces
BUILD_DEPENDS= rrdtool>=1.2:${PORTSDIR}/databases/rrdtool \
geoiplookup:${PORTSDIR}/net/GeoIP
-LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
+ event-1.4:${PORTSDIR}/devel/libevent
RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz \
${LOCALBASE}/lib/X11/fonts/URW/a010013l.afm:${PORTSDIR}/x11-fonts/urwfonts
@@ -25,6 +25,7 @@ DBDIR?= /var/db
MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS= libtool:22 automake:19 autoconf:262
USE_GNOME= libxml2
+USE_LUA= 5.1
USE_GMAKE= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
diff --git a/net/ntop/distinfo b/net/ntop/distinfo
index 1c0e6c4b5cc2..77e9c712baa1 100644
--- a/net/ntop/distinfo
+++ b/net/ntop/distinfo
@@ -1,3 +1,3 @@
-MD5 (ntop-3.3.9.tar.gz) = 0c22038e0f2aa003110437b5a5d5a6a5
-SHA256 (ntop-3.3.9.tar.gz) = 606c027d02cdaab7de87475bef8be168e9f18329c2215ac21a518766aa8a331f
-SIZE (ntop-3.3.9.tar.gz) = 4955257
+MD5 (ntop-3.3.10.tar.gz) = 6e2ffa90d5f935c8f03d88a5dd19a866
+SHA256 (ntop-3.3.10.tar.gz) = aa18ba3acb564d707521deaa2655f61f5b617d98d4fb5a014553f3fa123f123a
+SIZE (ntop-3.3.10.tar.gz) = 3235500
diff --git a/net/ntop/files/patch-Makefile.am b/net/ntop/files/patch-Makefile.am
index 93942eff21e9..e5ec90c30bcb 100644
--- a/net/ntop/files/patch-Makefile.am
+++ b/net/ntop/files/patch-Makefile.am
@@ -1,5 +1,5 @@
---- Makefile.am.orig 2008-12-03 17:00:22.000000000 -0500
-+++ Makefile.am 2009-06-02 14:27:56.863148713 -0400
+--- Makefile.am.orig 2009-04-17 17:27:57.000000000 -0300
++++ Makefile.am 2009-09-15 13:07:19.000000000 -0300
@@ -76,9 +76,7 @@
NTOPDATA = ntop-cert.pem \
$(ETTER_PASSIVE) \
@@ -20,8 +20,8 @@
@mkdir -p $(DESTDIR)/$(CFG_DBFILE_DIR)
@echo ""
-@@ -336,7 +332,6 @@
-
+@@ -341,7 +337,6 @@
+ chcon -t textrel_shlib_t $(DESTDIR)$(libdir)/*ntop*.so
install-data-local: ntop.txt ntop.html faq.html
- @$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(libdir)/plugins;
diff --git a/net/ntop/files/patch-autogen.sh b/net/ntop/files/patch-autogen.sh
index c7e68b56319e..5fd3a5c43e81 100644
--- a/net/ntop/files/patch-autogen.sh
+++ b/net/ntop/files/patch-autogen.sh
@@ -1,5 +1,5 @@
---- autogen.sh.orig 2009-06-02 10:26:46.731977294 -0400
-+++ autogen.sh 2009-06-02 10:27:02.866983000 -0400
+--- autogen.sh.orig 2009-09-15 11:33:11.000000000 -0300
++++ autogen.sh 2009-09-15 11:34:06.000000000 -0300
@@ -244,16 +244,6 @@
GNU_OR_DIE=0
}
diff --git a/net/ntop/files/patch-configure.in b/net/ntop/files/patch-configure.in
index 1d11d9fea18a..32b7fd41b6d2 100644
--- a/net/ntop/files/patch-configure.in
+++ b/net/ntop/files/patch-configure.in
@@ -1,7 +1,7 @@
---- configure.in.orig 2008-12-03 17:00:22.000000000 -0500
-+++ configure.in 2009-06-02 13:28:01.067367126 -0400
-@@ -573,8 +573,8 @@
- dnl>
+--- configure.in.orig 2009-09-15 11:37:06.000000000 -0300
++++ configure.in 2009-09-15 11:45:13.000000000 -0300
+@@ -621,8 +621,8 @@
+ else
if test ".${PCAP_ROOT}" != .; then
if test -d $PCAP_ROOT &&
- test -r $PCAP_ROOT/libpcap.a &&
@@ -11,7 +11,35 @@
PCAP_ROOT=`cd ${PCAP_ROOT} && pwd`
CORELIBS="${CORELIBS} -L$PCAP_ROOT -lpcap"
INCS="${INCS} -I$PCAP_ROOT"
-@@ -1886,40 +1886,7 @@
+@@ -1650,27 +1650,6 @@
+ fi
+
+ dnl>
+-dnl> Lua - http://www.lua.org
+-dnl>
+-LUA_VERSION=lua-5.1.4
+-if test -f "$LUA_VERSION.tar.gz"; then
+- echo "Lua already present on this machine"
+-else
+- wget http://www.lua.org/ftp/$LUA_VERSION.tar.gz
+-fi
+-
+-tar xvfz $LUA_VERSION.tar.gz
+-cat $LUA_VERSION/src/Makefile | sed -e s,'MYCFLAGS=-DLUA_USE_POSIX',' MYCFLAGS="-fPIC -DLUA_USE_POSIX"',g > /tmp/lua.temp
+-cat /tmp/lua.temp > $LUA_VERSION/src/Makefile
+-#rm -f /tmp/lua.temp
+-cd $LUA_VERSION; make posix; cd ..
+-
+-LUA_LIB_DIR=$PWD/$LUA_VERSION"/src"
+-LIBS="-L${LUA_LIB_DIR} -llua ${LIBS} "
+-INCS="${INCS} -I${LUA_LIB_DIR}"
+-AC_DEFINE_UNQUOTED(HAVE_LUA, 1, [LUA is supported])
+-
+-dnl>
+ dnl> SCTP - RFC 3286
+ dnl>
+ AC_MSG_CHECKING([sctp])
+@@ -1962,40 +1941,7 @@
}'`
fi
@@ -20,14 +48,14 @@
- echo "GeoIP already present on this machine"
-else
- wget http://www.maxmind.com/download/geoip/api/c/GeoIP.tar.gz
-- tar xvfz GeoIP.tar.gz
-- GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
-- cd $GEO_DIR; ./configure; make; cd ..
-- # OSX Fix
-- GEO_DYLIB="$GEO_DIR/libGeoIP/.libs/libGeoIP.dylib"
-- if test -f $GEO_DYLIB; then
-- ln -s $GEO_DYLIB .
-- fi
+-fi
+-tar xvfz GeoIP.tar.gz
+-GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
+-cd $GEO_DIR; ./configure --prefix=${prefix}; make; cd ..
+-# OSX Fix
+-GEO_DYLIB="$GEO_DIR/libGeoIP/.libs/libGeoIP.dylib"
+-if test -f $GEO_DYLIB; then
+- ln -s $GEO_DYLIB .
-fi
-
-if test -f "GeoLiteCity.dat"; then
@@ -48,7 +76,7 @@
-GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
-GEO_IP="$GEO_DIR/libGeoIP/"
-CFLAGS="$CFLAGS -I$GEO_IP"
--LDFLAGS="$LDFLAGS -L$GEO_IP.libs/ -lGeoIP"
+-LDFLAGS="-L$GEO_IP.libs/ -lGeoIP $LDFLAGS"
+LDFLAGS="$LDFLAGS -lGeoIP"
dnl> NTOPCONFIGDEBUG_SETTINGS([precet])
diff --git a/net/ntop/files/patch-plugins_netflowPlugin.c b/net/ntop/files/patch-plugins_netflowPlugin.c
deleted file mode 100644
index be5be50da805..000000000000
--- a/net/ntop/files/patch-plugins_netflowPlugin.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/netflowPlugin.c.orig 2009-06-22 14:00:56.000000000 -0400
-+++ plugins/netflowPlugin.c 2009-06-22 14:01:10.000000000 -0400
-@@ -28,7 +28,7 @@
- static void* netflowUtilsLoop(void* _deviceId);
- #endif
-
--#define DEBUG_FLOWS
-+//#define DEBUG_FLOWS
-
- #define CONST_NETFLOW_STATISTICS_HTML "statistics.html"
-
diff --git a/net/ntop/pkg-plist b/net/ntop/pkg-plist
index 0f05754c1b77..42046d5a21c1 100644
--- a/net/ntop/pkg-plist
+++ b/net/ntop/pkg-plist
@@ -1,5 +1,4 @@
bin/ntop
-etc/ntop/etter.finger.os.gz
etc/ntop/ntop-cert.pem
etc/ntop/oui.txt.gz
etc/ntop/specialMAC.txt.gz
@@ -19,10 +18,6 @@ lib/libntopreport-%%PORTVERSION%%.so
lib/libntopreport.so
lib/libntopreport.a
lib/libntopreport.la
-lib/libpdaPlugin-%%PORTVERSION%%.so
-lib/libpdaPlugin.so
-lib/libremotePlugin-%%PORTVERSION%%.so
-lib/libremotePlugin.so
lib/librrdPlugin-%%PORTVERSION%%.so
lib/librrdPlugin.so
lib/libsflowPlugin-%%PORTVERSION%%.so
@@ -31,8 +26,6 @@ lib/ntop/plugins/cpacketPlugin.so
lib/ntop/plugins/icmpPlugin.so
lib/ntop/plugins/lastSeenPlugin.so
lib/ntop/plugins/netflowPlugin.so
-lib/ntop/plugins/pdaPlugin.so
-lib/ntop/plugins/remotePlugin.so
lib/ntop/plugins/rrdPlugin.so
lib/ntop/plugins/sflowPlugin.so
%%DATADIR%%/perl/report/basic.xml
@@ -67,9 +60,6 @@ lib/ntop/plugins/sflowPlugin.so
%%DATADIR%%/html/Risk_medium.gif
%%DATADIR%%/html/Risk_unknown.gif
%%DATADIR%%/html/antenna.gif
-%%DATADIR%%/html/arrow_down.gif
-%%DATADIR%%/html/arrow_up.gif
-%%DATADIR%%/html/back.gif
%%DATADIR%%/html/bg_line.gif
%%DATADIR%%/html/black.gif
%%DATADIR%%/html/bottom_corner.gif
@@ -94,9 +84,6 @@ lib/ntop/plugins/sflowPlugin.so
%%DATADIR%%/html/expanded.gif
%%DATADIR%%/html/faq.html
%%DATADIR%%/html/favicon.ico
-%%DATADIR%%/html/fback.gif
-%%DATADIR%%/html/fforward.gif
-%%DATADIR%%/html/forward.gif
%%DATADIR%%/html/functions.js
%%DATADIR%%/html/gauge.jpg
%%DATADIR%%/html/gaugeR.jpg
@@ -362,6 +349,14 @@ lib/ntop/plugins/sflowPlugin.so
%%DATADIR%%/html/statsicons/os/os2.gif
%%DATADIR%%/html/statsicons/os/sun.gif
%%DATADIR%%/html/statsicons/os/windows.gif
+%%DATADIR%%/html/arrow_down.png
+%%DATADIR%%/html/arrow_up.png
+%%DATADIR%%/html/back.png
+%%DATADIR%%/html/bit_off.png
+%%DATADIR%%/html/bit_on.png
+%%DATADIR%%/html/fback.png
+%%DATADIR%%/html/fforward.png
+%%DATADIR%%/html/forward.png
%%DATADIR%%/html/style.css
%%DATADIR%%/html/switch.gif
%%DATADIR%%/html/upload.gif