aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-10 07:48:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-10 07:48:40 +0000
commit0c2b2884db00ce0d150cf6c3273068ab7c8b072e (patch)
tree251b0f85edb7f040a0d81da24842e7dee2ec7c61
parentfd586bce8baed11f7e7732673f644258343e9c3a (diff)
downloadports-0c2b2884db00ce0d150cf6c3273068ab7c8b072e.tar.gz
ports-0c2b2884db00ce0d150cf6c3273068ab7c8b072e.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/help_hannahs_horse/Makefile70
-rw-r--r--games/help_hannahs_horse/distinfo4
-rw-r--r--games/help_hannahs_horse/pkg-descr19
-rw-r--r--games/help_hannahs_horse/pkg-plist201
5 files changed, 295 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index e84a61ab3956..5470bee97a77 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -372,6 +372,7 @@
SUBDIR += gweled
SUBDIR += hangman
SUBDIR += hedgewars
+ SUBDIR += help_hannahs_horse
SUBDIR += heretic
SUBDIR += heroes
SUBDIR += hex
diff --git a/games/help_hannahs_horse/Makefile b/games/help_hannahs_horse/Makefile
new file mode 100644
index 000000000000..886916d9f6fe
--- /dev/null
+++ b/games/help_hannahs_horse/Makefile
@@ -0,0 +1,70 @@
+# Created by: nemysis@gmx.ch
+# $FreeBSD$
+
+PORTNAME= help_hannahs_horse
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= SF/hannah/hannah/hannah-${DISTVERSION}/ \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= hhh-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}_icons.tar.gz:icons
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Pacman with a fast food twist
+
+LICENSE= GPLv2 OFL
+LICENSE_COMB= dual
+LICENSE_NAME_OFL=SIL OPEN FONT LICENSE Version 1.1
+LICENSE_FILE_OFL=${WRKSRC}/StansHandOFL.txt
+LICENSE_PERMS_OFL=dist-mirror pkg-mirror auto-accept
+
+WRKSRC= ${WRKDIR}/hhh-2008-03-29
+
+USE_SDL= sdl image mixer ttf
+USE_GMAKE= yes
+ALL_TARGET= # empty
+
+PORTDOCS= CHANGELOG README TODO
+
+INSTALLS_ICONS= yes
+ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
+
+DESKTOP_ENTRIES="Help Hannah's Horse" "${COMMENT}" "${PORTNAME}.png" \
+ "${PORTNAME}" "Game;ArcadeGame;" ${FALSE}
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/games/hhh|${DATADIR}|' \
+ -e 's|/usr/local/bin|${PREFIX}/bin|' \
+ -e 's|CXX = g++|CXX ?= g++|' \
+ -e 's|CXXFLAGS = -O2 -Wall -g|CXXFLAGS +=|' \
+ -e 's|OUT = hhh|OUT = ${PORTNAME}|' \
+ -e 's|-include deps|#-include deps|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.for d in blue carrot default freeze hannah images invert invis maps newanim pink red sounds stop
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR})
+.endfor
+.for d in *.ogg *.ttf *.dat *.png
+ @(cd ${WRKSRC} && ${INSTALL_DATA} ${d} ${DATADIR})
+.endfor
+
+post-install:
+.for s in ${ICON_SIZES}
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
+ ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
+
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/help_hannahs_horse/distinfo b/games/help_hannahs_horse/distinfo
new file mode 100644
index 000000000000..6f0bc4af0da8
--- /dev/null
+++ b/games/help_hannahs_horse/distinfo
@@ -0,0 +1,4 @@
+SHA256 (help_hannahs_horse/hhh-1.0.tar.gz) = 2383306eda55fbea2f7a7c0498e341070e873c1689facee5c59480b2f839f8bc
+SIZE (help_hannahs_horse/hhh-1.0.tar.gz) = 3803855
+SHA256 (help_hannahs_horse/help_hannahs_horse_icons.tar.gz) = 5164b3ffb2770bd67e1ca520e28ed8ed3efd40d4881424000760d2bbfd3bd21c
+SIZE (help_hannahs_horse/help_hannahs_horse_icons.tar.gz) = 56320
diff --git a/games/help_hannahs_horse/pkg-descr b/games/help_hannahs_horse/pkg-descr
new file mode 100644
index 000000000000..03e3ee2d15e1
--- /dev/null
+++ b/games/help_hannahs_horse/pkg-descr
@@ -0,0 +1,19 @@
+An arcade game best described as a cross between pacman and fastfood.
+Collect the pills and carrots while avoiding the ghosts! Cute and colourful!
+
+Basically, it's pacman with a fast food twist. You have to get the pills,
+pacman style, while also collecting the carrots that move around the mazes.
+There are also different styles of gates to make things trickier. These are:
+
+* Red and White - only the ghosts can cross them
+* Blue and White - only hannah can cross them
+* Wooden gates - both hannah and the ghosts can cross, but only passing from
+ below to above
+* Red prison door things - need hannah to get the red key to open
+
+There are some command line switches you can use:
+
+-fullscreen will put the game in fullscreen mode
+-map X will start the game on level X
+
+WWW: http://sourceforge.net/projects/hannah/
diff --git a/games/help_hannahs_horse/pkg-plist b/games/help_hannahs_horse/pkg-plist
new file mode 100644
index 000000000000..78d995a8f1ee
--- /dev/null
+++ b/games/help_hannahs_horse/pkg-plist
@@ -0,0 +1,201 @@
+bin/help_hannahs_horse
+%%DATADIR%%/bgm1.ogg
+%%DATADIR%%/blue/default/blue1.png
+%%DATADIR%%/blue/default/blue2.png
+%%DATADIR%%/blue/default/blue3.png
+%%DATADIR%%/blue/default/blue4.png
+%%DATADIR%%/blue/default/blue5.png
+%%DATADIR%%/blue/default/blue6.png
+%%DATADIR%%/blue/default/blue7.png
+%%DATADIR%%/blue/default/sprite.dat
+%%DATADIR%%/blue/flash/blue1.png
+%%DATADIR%%/blue/flash/flash1.png
+%%DATADIR%%/blue/flash/sprite.dat
+%%DATADIR%%/carrot/default/carrot.png
+%%DATADIR%%/carrot/default/sprite.dat
+%%DATADIR%%/font.ttf
+%%DATADIR%%/freeze/default/clock.png
+%%DATADIR%%/freeze/default/sprite.dat
+%%DATADIR%%/hannah/default/hannah_down1.png
+%%DATADIR%%/hannah/default/hannah_down2.png
+%%DATADIR%%/hannah/default/sprite.dat
+%%DATADIR%%/hannah/die/die1.png
+%%DATADIR%%/hannah/die/die10.png
+%%DATADIR%%/hannah/die/die11.png
+%%DATADIR%%/hannah/die/die2.png
+%%DATADIR%%/hannah/die/die3.png
+%%DATADIR%%/hannah/die/die4.png
+%%DATADIR%%/hannah/die/die5.png
+%%DATADIR%%/hannah/die/die6.png
+%%DATADIR%%/hannah/die/die7.png
+%%DATADIR%%/hannah/die/die8.png
+%%DATADIR%%/hannah/die/die9.png
+%%DATADIR%%/hannah/die/sprite.dat
+%%DATADIR%%/hannah/invis/invis1.png
+%%DATADIR%%/hannah/invis/invis2.png
+%%DATADIR%%/hannah/invis/invis3.png
+%%DATADIR%%/hannah/invis/invis4.png
+%%DATADIR%%/hannah/invis/sprite.dat
+%%DATADIR%%/hiscore.dat
+%%DATADIR%%/images/bg_left.png
+%%DATADIR%%/images/bg_right2_1.png
+%%DATADIR%%/images/border.png
+%%DATADIR%%/images/congrats.png
+%%DATADIR%%/images/cross.png
+%%DATADIR%%/images/end_banner.png
+%%DATADIR%%/images/gate.png
+%%DATADIR%%/images/gradient.png
+%%DATADIR%%/images/grass.png
+%%DATADIR%%/images/grass2.png
+%%DATADIR%%/images/grass3.png
+%%DATADIR%%/images/grass4.png
+%%DATADIR%%/images/hedge.png
+%%DATADIR%%/images/hedge2.png
+%%DATADIR%%/images/hedge3.png
+%%DATADIR%%/images/hedge4.png
+%%DATADIR%%/images/howtoplay.png
+%%DATADIR%%/images/oneway.png
+%%DATADIR%%/images/pill.png
+%%DATADIR%%/images/powerpill.png
+%%DATADIR%%/images/red_door.png
+%%DATADIR%%/images/red_key.png
+%%DATADIR%%/images/story.old.png
+%%DATADIR%%/images/story.png
+%%DATADIR%%/images/story1.png
+%%DATADIR%%/images/story2.png
+%%DATADIR%%/invert/default/sprite.dat
+%%DATADIR%%/invert/default/switch.png
+%%DATADIR%%/invert/default/switch2.png
+%%DATADIR%%/invert/default/switch3.png
+%%DATADIR%%/invert/default/switch4.png
+%%DATADIR%%/invis/default/potion.png
+%%DATADIR%%/invis/default/sprite.dat
+%%DATADIR%%/maps/map1.dat
+%%DATADIR%%/maps/map10.dat
+%%DATADIR%%/maps/map11.dat
+%%DATADIR%%/maps/map12.dat
+%%DATADIR%%/maps/map13.dat
+%%DATADIR%%/maps/map14.dat
+%%DATADIR%%/maps/map15.dat
+%%DATADIR%%/maps/map2.dat
+%%DATADIR%%/maps/map3.dat
+%%DATADIR%%/maps/map4.dat
+%%DATADIR%%/maps/map5.dat
+%%DATADIR%%/maps/map6.dat
+%%DATADIR%%/maps/map7.dat
+%%DATADIR%%/maps/map8.dat
+%%DATADIR%%/maps/map9.dat
+%%DATADIR%%/newanim/blue/default/blue1.png
+%%DATADIR%%/newanim/blue/default/blue2.png
+%%DATADIR%%/newanim/blue/default/blue3.png
+%%DATADIR%%/newanim/blue/default/blue4.png
+%%DATADIR%%/newanim/blue/default/blue5.png
+%%DATADIR%%/newanim/blue/default/blue6.png
+%%DATADIR%%/newanim/blue/default/blue7.png
+%%DATADIR%%/newanim/pink/default/pink1.png
+%%DATADIR%%/newanim/pink/default/pink10.png
+%%DATADIR%%/newanim/pink/default/pink11.png
+%%DATADIR%%/newanim/pink/default/pink12.png
+%%DATADIR%%/newanim/pink/default/pink1a.png
+%%DATADIR%%/newanim/pink/default/pink2.png
+%%DATADIR%%/newanim/pink/default/pink3.png
+%%DATADIR%%/newanim/pink/default/pink4.png
+%%DATADIR%%/newanim/pink/default/pink5.png
+%%DATADIR%%/newanim/pink/default/pink6.png
+%%DATADIR%%/newanim/pink/default/pink7.png
+%%DATADIR%%/newanim/pink/default/pink8.png
+%%DATADIR%%/newanim/pink/default/pink9.png
+%%DATADIR%%/newanim/pink/default/pinksquish.png
+%%DATADIR%%/pink/default/pink1.png
+%%DATADIR%%/pink/default/pink10.png
+%%DATADIR%%/pink/default/pink11.png
+%%DATADIR%%/pink/default/pink12.png
+%%DATADIR%%/pink/default/pink1a.png
+%%DATADIR%%/pink/default/pink2.png
+%%DATADIR%%/pink/default/pink3.png
+%%DATADIR%%/pink/default/pink4.png
+%%DATADIR%%/pink/default/pink5.png
+%%DATADIR%%/pink/default/pink6.png
+%%DATADIR%%/pink/default/pink7.png
+%%DATADIR%%/pink/default/pink8.png
+%%DATADIR%%/pink/default/pink9.png
+%%DATADIR%%/pink/default/pinksquish.png
+%%DATADIR%%/pink/default/sprite.dat
+%%DATADIR%%/pink/flash/flash1.png
+%%DATADIR%%/pink/flash/pink1.png
+%%DATADIR%%/pink/flash/sprite.dat
+%%DATADIR%%/red/default/red1.png
+%%DATADIR%%/red/default/red2.png
+%%DATADIR%%/red/default/red3.png
+%%DATADIR%%/red/default/red4.png
+%%DATADIR%%/red/default/red5.png
+%%DATADIR%%/red/default/red6.png
+%%DATADIR%%/red/default/red7.png
+%%DATADIR%%/red/default/red8.png
+%%DATADIR%%/red/default/sprite.dat
+%%DATADIR%%/red/flash/flash1.png
+%%DATADIR%%/red/flash/red1.png
+%%DATADIR%%/red/flash/sprite.dat
+%%DATADIR%%/sounds/DripC.wav
+%%DATADIR%%/sounds/chomp.wav
+%%DATADIR%%/sounds/crunch.wav
+%%DATADIR%%/sounds/drip.wav
+%%DATADIR%%/sounds/gulp.wav
+%%DATADIR%%/sounds/scream.wav
+%%DATADIR%%/sounds/uh-oh.wav
+%%DATADIR%%/sounds/yeah.wav
+%%DATADIR%%/stop/default/sprite.dat
+%%DATADIR%%/stop/default/stop.png
+%%DATADIR%%/story.png
+%%DATADIR%%/subgamefont.ttf
+share/icons/hicolor/32x32/apps/help_hannahs_horse.png
+share/icons/hicolor/48x48/apps/help_hannahs_horse.png
+share/icons/hicolor/64x64/apps/help_hannahs_horse.png
+share/icons/hicolor/72x72/apps/help_hannahs_horse.png
+share/icons/hicolor/96x96/apps/help_hannahs_horse.png
+share/pixmaps/help_hannahs_horse.png
+@dirrmtry share/icons/hicolor/96x96/apps
+@dirrmtry share/icons/hicolor/96x96
+@dirrmtry share/icons/hicolor/72x72/apps
+@dirrmtry share/icons/hicolor/72x72
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrm %%DATADIR%%/stop/default
+@dirrm %%DATADIR%%/stop
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/red/flash
+@dirrm %%DATADIR%%/red/default
+@dirrm %%DATADIR%%/red
+@dirrm %%DATADIR%%/pink/flash
+@dirrm %%DATADIR%%/pink/default
+@dirrm %%DATADIR%%/pink
+@dirrm %%DATADIR%%/newanim/pink/default
+@dirrm %%DATADIR%%/newanim/pink
+@dirrm %%DATADIR%%/newanim/blue/default
+@dirrm %%DATADIR%%/newanim/blue
+@dirrm %%DATADIR%%/newanim
+@dirrm %%DATADIR%%/maps
+@dirrm %%DATADIR%%/invis/default
+@dirrm %%DATADIR%%/invis
+@dirrm %%DATADIR%%/invert/default
+@dirrm %%DATADIR%%/invert
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%/hannah/invis
+@dirrm %%DATADIR%%/hannah/die
+@dirrm %%DATADIR%%/hannah/default
+@dirrm %%DATADIR%%/hannah
+@dirrm %%DATADIR%%/freeze/default
+@dirrm %%DATADIR%%/freeze
+@dirrm %%DATADIR%%/default
+@dirrm %%DATADIR%%/carrot/default
+@dirrm %%DATADIR%%/carrot
+@dirrm %%DATADIR%%/blue/flash
+@dirrm %%DATADIR%%/blue/default
+@dirrm %%DATADIR%%/blue
+@dirrm %%DATADIR%%