aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-03-25 18:30:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-03-25 18:30:25 +0000
commit0cf23c9e42ff4e1fa43b2a501fc9f5ea3bfdea9c (patch)
tree08cebd342cf36f49f446fb7827a8c58054aa77dc
parent0ae20ec92eea31369620157c6b0d9e9cfa397f4e (diff)
downloadports-0cf23c9e42ff4e1fa43b2a501fc9f5ea3bfdea9c.tar.gz
ports-0cf23c9e42ff4e1fa43b2a501fc9f5ea3bfdea9c.zip
Remove PTHREAD_LIBS, PTHREAD_CFLAGS from my ports
Notes
Notes: svn path=/head/; revision=382258
-rw-r--r--audio/audiere/Makefile4
-rw-r--r--games/flyhard/Makefile2
-rw-r--r--games/minetest/Makefile2
-rw-r--r--games/numptyphysics/Makefile2
-rw-r--r--games/pachi/Makefile2
-rw-r--r--games/passage/Makefile2
-rw-r--r--games/pengupop/Makefile2
-rw-r--r--games/pipewalker/Makefile2
-rw-r--r--games/teeworlds/Makefile2
-rw-r--r--games/zaz/Makefile2
10 files changed, 11 insertions, 11 deletions
diff --git a/audio/audiere/Makefile b/audio/audiere/Makefile
index 129e54cfa07b..84a5e51b980d 100644
--- a/audio/audiere/Makefile
+++ b/audio/audiere/Makefile
@@ -17,7 +17,7 @@ USE_AUTOTOOLS= autoconf
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-CONFIGURE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
+CONFIGURE_ENV= PTHREAD_LIBS="-pthread"
CPPFLAGS+= -I${LOCALBASE}/include/speex -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -71,7 +71,7 @@ CONFIGURE_REPLACES+='/AC_CHECK_HEADER/ s|speex|no_&|'
post-patch:
@${REINPLACE_CMD} ${CONFIGURE_REPLACES:C/.*/-e &/} \
- -e 's|-lpthread|${PTHREAD_LIBS}|' \
+ -e 's|-lpthread|-pthread|' \
${WRKSRC}/configure.in
post-install:
diff --git a/games/flyhard/Makefile b/games/flyhard/Makefile
index e551fb39ba5a..5265bb68f672 100644
--- a/games/flyhard/Makefile
+++ b/games/flyhard/Makefile
@@ -19,7 +19,7 @@ USES= gmake
USE_SDL= sdl mixer
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -pthread
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= *
diff --git a/games/minetest/Makefile b/games/minetest/Makefile
index 12e89a6055e4..0de9253b800c 100644
--- a/games/minetest/Makefile
+++ b/games/minetest/Makefile
@@ -89,7 +89,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-irrlichtdepend
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/cmake/Modules/*.cmake
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
+ @${REINPLACE_CMD} -e 's|-lpthread|-pthread|' \
${WRKSRC}/src/CMakeLists.txt
.if ! ${PORT_OPTIONS:MLUAJIT}
@${REINPLACE_CMD} -e '/find_/ s|LUA_|NO&|g' \
diff --git a/games/numptyphysics/Makefile b/games/numptyphysics/Makefile
index de91d8b8b07d..75bfd2c4a740 100644
--- a/games/numptyphysics/Makefile
+++ b/games/numptyphysics/Makefile
@@ -19,7 +19,7 @@ USE_SDL= sdl image
INSTALLS_ICONS= yes
CONFIGURE_ENV= AUTOMAKE="${TRUE}" ACLOCAL="${TRUE}" MISSING="${TRUE}"
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LDFLAGS+= -L${LOCALBASE}/lib -pthread
CPPFLAGS+= -I${LOCALBASE}/include -DINSTALL_BASE_PATH=\"\\\"${DATADIR}\\\"\"
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/games/pachi/Makefile b/games/pachi/Makefile
index 613e6a2dc6af..28f9199657b5 100644
--- a/games/pachi/Makefile
+++ b/games/pachi/Makefile
@@ -15,7 +15,7 @@ USE_SDL= mixer sdl
USES= gmake tar:tgz
GNU_CONFIGURE= yes
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LDFLAGS+= -L${LOCALBASE}/lib -pthread
CPPFLAGS+= -I${LOCALBASE}/include
WRKSRC= ${WRKDIR}/Pachi
diff --git a/games/passage/Makefile b/games/passage/Makefile
index 8a22db92b3a0..e68eb9751e26 100644
--- a/games/passage/Makefile
+++ b/games/passage/Makefile
@@ -19,7 +19,7 @@ PLIST_FILES= bin/${PORTNAME}
PORTDATA= *
post-patch:
- @${REINPLACE_CMD} -e 's|^\(PLATFORM_LINK_FLAGS =\).*|\1 ${PTHREAD_LIBS}|' \
+ @${REINPLACE_CMD} -e 's|^\(PLATFORM_LINK_FLAGS =\).*|\1 -pthread|' \
${WRKSRC}/Makefile.GnuLinux
@${REINPLACE_CMD} -e 's|"graphics"|"${DATADIR}/graphics"|' \
${WRKSRC}/common.cpp
diff --git a/games/pengupop/Makefile b/games/pengupop/Makefile
index 2194cf9a3527..f76ae274bb77 100644
--- a/games/pengupop/Makefile
+++ b/games/pengupop/Makefile
@@ -15,7 +15,7 @@ GNU_CONFIGURE= yes
USES= gmake
USE_SDL= sdl
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LDFLAGS+= -L${LOCALBASE}/lib -pthread
PLIST_FILES= bin/pengupop
diff --git a/games/pipewalker/Makefile b/games/pipewalker/Makefile
index 0c504d27d791..06fcddb8d110 100644
--- a/games/pipewalker/Makefile
+++ b/games/pipewalker/Makefile
@@ -16,7 +16,7 @@ USE_SDL= sdl
USE_GL= gl glu
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LDFLAGS+= -L${LOCALBASE}/lib -pthread
PLIST_FILES= bin/${PORTNAME} \
share/applications/${PORTNAME}.desktop \
diff --git a/games/teeworlds/Makefile b/games/teeworlds/Makefile
index 08873f27c88a..fe8fba40f1b2 100644
--- a/games/teeworlds/Makefile
+++ b/games/teeworlds/Makefile
@@ -54,7 +54,7 @@ DESKTOP_ENTRIES="Teeworlds" \
post-patch:
@${REINPLACE_CMD} -e 's|"python "|"${PYTHON_CMD} "|' \
${WRKSRC}/bam.lua
- @${REINPLACE_CMD} -e 's|-O.||; s|-lpthread|${PTHREAD_LIBS}|; s|^gcc|${CC} ${CFLAGS}|; s|-ldl||g' \
+ @${REINPLACE_CMD} -e 's|-O.||; s|-lpthread|-pthread|; s|^gcc|${CC} ${CFLAGS}|; s|-ldl||g' \
${BAM_WRKSRC}/make_unix.sh
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/other/sdl/sdl.lua
@${REINPLACE_CMD} -e '/aDirs\[\]/,/}/ s|"/.*"|"${DATADIR}"|' \
diff --git a/games/zaz/Makefile b/games/zaz/Makefile
index acace6d15d7c..0f5eddc56429 100644
--- a/games/zaz/Makefile
+++ b/games/zaz/Makefile
@@ -21,7 +21,7 @@ USE_SDL= sdl image
USE_GL= gl glu
CPPFLAGS+= -I${LOCALBASE}/include/freetype2 -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LDFLAGS+= -L${LOCALBASE}/lib -pthread
CONFIGURE_ARGS= --with-icondir="${PREFIX}/share/pixmaps"
PORTDOCS= *