aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2013-12-30 14:20:08 +0000
committerLars Engels <lme@FreeBSD.org>2013-12-30 14:20:08 +0000
commit0e10847841335c4eeaca6fc53d9b518182c200eb (patch)
tree90ccce361a67b28eed75c71e1e6ad3dd9f9cf208
parent6e8e95f9f06245258f16c4d1c61c7d29a3cb7c58 (diff)
downloadports-0e10847841335c4eeaca6fc53d9b518182c200eb.tar.gz
ports-0e10847841335c4eeaca6fc53d9b518182c200eb.zip
Notes
-rw-r--r--net-mgmt/icinga/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-mgmt/icinga/Makefile b/net-mgmt/icinga/Makefile
index c903f20d5d0d..828c70ddc87b 100644
--- a/net-mgmt/icinga/Makefile
+++ b/net-mgmt/icinga/Makefile
@@ -3,6 +3,7 @@
PORTNAME= icinga
PORTVERSION= 1.10.2
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF
@@ -28,6 +29,8 @@ ICINGADIR?= /var/spool/icinga
ICINGALOGDIR?= /var/log/icinga
ICINGAWWWDIR?= www/icinga
+ICINGAHTMURL?= /icinga
+ICINGACGIURL?= ${ICINGAHTMURL}/cgi-bin
CPPFLAGS+= -I${LOCALBASE}/include -fPIC
CFLAGS+= ${CPPFLAGS}
@@ -36,6 +39,8 @@ CONFIGURE_ARGS= --with-command-user=${ICINGAUSER} \
--with-command-group=${WWWGRP} \
--with-icinga-user=${ICINGAUSER} \
--with-icinga-group=${ICINGAGROUP} \
+ --with-htmurl=${ICINGAHTMURL} \
+ --with-cgiurl=${ICINGACGIURL} \
--sbindir=${PREFIX}/${ICINGAWWWDIR}/cgi-bin \
--datarootdir=${PREFIX}/${ICINGAWWWDIR} \
--datadir=${PREFIX}/${ICINGAWWWDIR} \
@@ -59,6 +64,7 @@ PLIST_SUB= ICINGADIR=${ICINGADIR} \
ICINGAWWWDIR=${ICINGAWWWDIR} \
ICINGAUSER=${ICINGAUSER} \
ICINGAGROUP=${ICINGAGROUP} \
+ ICINGAHTMURL=${ICINGAHTMURL} \
ICINGACGIURL=${ICINGACGIURL} \
WWWGRP=${WWWGRP}