aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-12-31 12:55:17 +0000
committerRene Ladan <rene@FreeBSD.org>2013-12-31 12:55:17 +0000
commit0fd2d67e73f1fae8ea1453fa366ddf5c79598ad4 (patch)
tree7ec6eb7e544a9ea8561abf42166b0262ff0eda74
parent052157ef9c1c8ce2df8c4fda442bd999ce1c482e (diff)
Notes
-rw-r--r--MOVED1
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/parcellite/Makefile35
-rw-r--r--deskutils/parcellite/distinfo2
-rw-r--r--deskutils/parcellite/files/patch-po_Makefile.in.in19
-rw-r--r--deskutils/parcellite/pkg-descr5
-rw-r--r--deskutils/parcellite/pkg-plist25
7 files changed, 87 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index 5303f4e2aa52..306bec3251ac 100644
--- a/MOVED
+++ b/MOVED
@@ -5347,4 +5347,3 @@ security/dazuko||2013-12-31|Has expired: Currently, the project has not an activ
mail/p5-Mail-SPF-Query||2013-12-31|Has expired: Use mail/p5-Mail-SPF instead
x11-fonts/etlfonts||2013-12-31|Has expired: master site gone
net/gateway6||2013-12-31|Has expired: Unsupported upstream, consider using net/gogoc
-deskutils/parcellite||2013-12-31|Removed, use deskutils/clipit instead
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 2f54992eecf9..70b7efc5b777 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -173,6 +173,7 @@
SUBDIR += p5-ZConf-Runner
SUBDIR += p5-ZConf-Runner-GUI-GTK
SUBDIR += pal
+ SUBDIR += parcellite
SUBDIR += phpcollab
SUBDIR += phpicalendar
SUBDIR += phprojekt
diff --git a/deskutils/parcellite/Makefile b/deskutils/parcellite/Makefile
new file mode 100644
index 000000000000..5eb24c8b55e5
--- /dev/null
+++ b/deskutils/parcellite/Makefile
@@ -0,0 +1,35 @@
+# Created by: Joey Mingrone <joey@mingrone.org>
+# $FreeBSD$
+
+PORTNAME= parcellite
+PORTVERSION= 1.0.1
+PORTREVISION= 1
+PORTEPOCH= 1
+CATEGORIES= deskutils
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jrm@ftfl.ca
+COMMENT= A lightweight GTK+ clipboard manager
+
+GNU_CONFIGURE= yes
+USES= gmake pkgconfig
+USE_GNOME= gtk20
+
+NO_STAGE= yes
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+MAN1= parcellite.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g'\
+ ${WRKSRC}/src/keybinder.h
+
+.include <bsd.port.mk>
diff --git a/deskutils/parcellite/distinfo b/deskutils/parcellite/distinfo
new file mode 100644
index 000000000000..2b3237633e3c
--- /dev/null
+++ b/deskutils/parcellite/distinfo
@@ -0,0 +1,2 @@
+SHA256 (parcellite-1.0.1.tar.gz) = a4e7a1bd0616683b7eb4b08350cdaa355b1c9d5c93a4caa0cef4a813cf4cc526
+SIZE (parcellite-1.0.1.tar.gz) = 555184
diff --git a/deskutils/parcellite/files/patch-po_Makefile.in.in b/deskutils/parcellite/files/patch-po_Makefile.in.in
new file mode 100644
index 000000000000..389951be00b2
--- /dev/null
+++ b/deskutils/parcellite/files/patch-po_Makefile.in.in
@@ -0,0 +1,19 @@
+*** po/Makefile.in.in.orig Tue May 5 19:45:52 2009
+--- po/Makefile.in.in Tue May 5 19:46:58 2009
+***************
+*** 34,40 ****
+ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+! itlocaledir = $(prefix)/$(DATADIRNAME)/locale
+ subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
+--- 34,40 ----
+ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+! itlocaledir = $(datarootdir)/locale
+ subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
diff --git a/deskutils/parcellite/pkg-descr b/deskutils/parcellite/pkg-descr
new file mode 100644
index 000000000000..2af4ef1f7578
--- /dev/null
+++ b/deskutils/parcellite/pkg-descr
@@ -0,0 +1,5 @@
+Parcellite is a lightweight GTK+ clipboard manager. This is a stripped down,
+basic-features-only clipboard manager with a small memory footprint for those
+who like simplicity.
+
+WWW: http://parcellite.sourceforge.net
diff --git a/deskutils/parcellite/pkg-plist b/deskutils/parcellite/pkg-plist
new file mode 100644
index 000000000000..705fbb594d2c
--- /dev/null
+++ b/deskutils/parcellite/pkg-plist
@@ -0,0 +1,25 @@
+bin/parcellite
+etc/xdg/autostart/parcellite-startup.desktop
+share/applications/parcellite.desktop
+share/pixmaps/parcellite.png
+share/pixmaps/parcellite.svg
+share/pixmaps/parcellite.xpm
+%%NLS%%share/locale/cs/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/da/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/de/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/es/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/it/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/pl_PL/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/parcellite.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/parcellite.mo
+%%NLS%%@dirrmtry share/locale/pl_PL/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/pl_PL