aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-11-29 18:08:04 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-11-29 18:08:04 +0000
commit0fea06fbb53fa07c16d65a3818d721d03ad3b72d (patch)
treef6af6a46d05714218f5e6ec52166e72d573ea1d1
parent8e918ec1df03bbfd06b49746d440730c2e96bff1 (diff)
downloadports-0fea06fbb53fa07c16d65a3818d721d03ad3b72d.tar.gz
ports-0fea06fbb53fa07c16d65a3818d721d03ad3b72d.zip
Notes
-rw-r--r--devel/qt4-corelib/Makefile1
-rw-r--r--devel/qt4/files/extrapatch-src-corelib-global-qglobal.h10
-rw-r--r--x11/kdelibs4/Makefile2
-rw-r--r--x11/kdelibs4/files/patch-cmake_modules_FindQt4.cmake50
4 files changed, 12 insertions, 51 deletions
diff --git a/devel/qt4-corelib/Makefile b/devel/qt4-corelib/Makefile
index fd1dcade9161..5333f28a753d 100644
--- a/devel/qt4-corelib/Makefile
+++ b/devel/qt4-corelib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= corelib
DISTVERSION= ${QT4_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4/files/extrapatch-src-corelib-global-qglobal.h b/devel/qt4/files/extrapatch-src-corelib-global-qglobal.h
index 492a0993b2fd..715d52ac9b21 100644
--- a/devel/qt4/files/extrapatch-src-corelib-global-qglobal.h
+++ b/devel/qt4/files/extrapatch-src-corelib-global-qglobal.h
@@ -14,7 +14,7 @@ least need to include a non-lightweight header such as cstdio to have access to
__GLIBCXX__) and not worth the effort.
--- src/corelib/global/qglobal.h
+++ src/corelib/global/qglobal.h
-@@ -854,7 +855,16 @@ namespace QT_NAMESPACE {}
+@@ -854,7 +855,18 @@ namespace QT_NAMESPACE {}
# define Q_COMPILER_DEFAULT_DELETE_MEMBERS
# endif
# if __has_feature(cxx_generalized_initializers)
@@ -25,9 +25,11 @@ __GLIBCXX__) and not worth the effort.
+ * lists). Since detecting libstdc++'s version is not trivial, only enable the
+ * macro with libc++.
+ */
-+# include <ciso646>
-+# if defined(_LIBCPP_VER)
-+# define Q_COMPILER_INITIALIZER_LISTS
++# if defined(__cplusplus) /* Only C++ has ciso646. */
++# include <ciso646>
++# if defined(_LIBCPP_VER)
++# define Q_COMPILER_INITIALIZER_LISTS
++# endif
+# endif
# endif
# if __has_feature(cxx_lambdas)
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index c2d4f914f189..0c0f2c0971cc 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
diff --git a/x11/kdelibs4/files/patch-cmake_modules_FindQt4.cmake b/x11/kdelibs4/files/patch-cmake_modules_FindQt4.cmake
index 7213d99f0cf2..57016d605b22 100644
--- a/x11/kdelibs4/files/patch-cmake_modules_FindQt4.cmake
+++ b/x11/kdelibs4/files/patch-cmake_modules_FindQt4.cmake
@@ -1,25 +1,9 @@
-Hunks 1 and 3:
- Backport upstream CMake change de30173d ("Remove C compiler requirement from
- FindQt4.cmake") so that it uses a C++ compiler to look for Q_WS_X11,
- otherwise the build fails because <ciso646> from qglobal.h is not present
- when using a C compiler.
-
-Hunk 2:
- Do the same thing we do in devel/cmake's FindQt4.cmake patch. The idea behind
- the change is that the directories FindQt4.cmake looks for might not be
- present at the time CMake looks for them since the ports that actually create
- them may not be required by the port calling CMake.
+Do the same thing we do in devel/cmake's FindQt4.cmake patch. The idea behind
+the change is that the directories FindQt4.cmake looks for might not be
+present at the time CMake looks for them since the ports that actually create
+them may not be required by the port calling CMake.
--- cmake/modules/FindQt4.cmake.orig 2014-11-06 22:33:50 UTC
+++ cmake/modules/FindQt4.cmake
-@@ -405,7 +405,7 @@ QT_CHECK_FLAG_EXISTS(-DQT_NO_DEBUG CMAKE
- QT_CHECK_FLAG_EXISTS(-DQT_NO_DEBUG CMAKE_CXX_FLAGS_MINSIZEREL "release minsize")
-
- INCLUDE(MacroPushRequiredVars)
--INCLUDE(CheckSymbolExists)
-+INCLUDE(CheckCXXSymbolExists)
- INCLUDE(MacroAddFileDependencies)
-
- SET(QT_USE_FILE ${CMAKE_ROOT}/Modules/UseQt4.cmake)
@@ -638,23 +638,12 @@ IF (QT4_QMAKE_FOUND)
# ask qmake for the imports directory
IF (QT_LIBRARY_DIR AND NOT QT_IMPORTS_DIR OR QT_QMAKE_CHANGED)
@@ -46,29 +30,3 @@ Hunk 2:
#############################################
-@@ -671,19 +660,19 @@ IF (QT4_QMAKE_FOUND)
- SET(CMAKE_REQUIRED_FLAGS "-F${QT_LIBRARY_DIR} ")
- ENDIF( QT_USE_FRAMEWORKS )
- # Check for Window system symbols (note: only one should end up being set)
-- CHECK_SYMBOL_EXISTS(Q_WS_X11 "QtCore/qglobal.h" Q_WS_X11)
-- CHECK_SYMBOL_EXISTS(Q_WS_WIN "QtCore/qglobal.h" Q_WS_WIN)
-- CHECK_SYMBOL_EXISTS(Q_WS_QWS "QtCore/qglobal.h" Q_WS_QWS)
-- CHECK_SYMBOL_EXISTS(Q_WS_MAC "QtCore/qglobal.h" Q_WS_MAC)
-+ CHECK_CXX_SYMBOL_EXISTS(Q_WS_X11 "QtCore/qglobal.h" Q_WS_X11)
-+ CHECK_CXX_SYMBOL_EXISTS(Q_WS_WIN "QtCore/qglobal.h" Q_WS_WIN)
-+ CHECK_CXX_SYMBOL_EXISTS(Q_WS_QWS "QtCore/qglobal.h" Q_WS_QWS)
-+ CHECK_CXX_SYMBOL_EXISTS(Q_WS_MAC "QtCore/qglobal.h" Q_WS_MAC)
- IF(Q_WS_MAC)
- IF(QT_QMAKE_CHANGED)
- UNSET(QT_MAC_USE_COCOA CACHE)
- ENDIF(QT_QMAKE_CHANGED)
-- CHECK_SYMBOL_EXISTS(QT_MAC_USE_COCOA "QtCore/qconfig.h" QT_MAC_USE_COCOA)
-+ CHECK_CXX_SYMBOL_EXISTS(QT_MAC_USE_COCOA "QtCore/qconfig.h" QT_MAC_USE_COCOA)
- ENDIF(Q_WS_MAC)
-
- IF (QT_QTCOPY_REQUIRED)
-- CHECK_SYMBOL_EXISTS(QT_IS_QTCOPY "QtCore/qglobal.h" QT_KDE_QT_COPY)
-+ CHECK_CXX_SYMBOL_EXISTS(QT_IS_QTCOPY "QtCore/qglobal.h" QT_KDE_QT_COPY)
- IF (NOT QT_IS_QTCOPY)
- MESSAGE(FATAL_ERROR "qt-copy is required, but hasn't been found")
- ENDIF (NOT QT_IS_QTCOPY)