aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2007-12-17 01:53:01 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2007-12-17 01:53:01 +0000
commit1004f663efd41022d063273b07fd59fcde452057 (patch)
tree0c083153c03163b87d15472219f5a2a42eda10d2
parentbe68069d3b1b607fd23897998648eff895c559b8 (diff)
downloadports-1004f663efd41022d063273b07fd59fcde452057.tar.gz
ports-1004f663efd41022d063273b07fd59fcde452057.zip
Notes
-rw-r--r--net/sipp/Makefile92
-rw-r--r--net/sipp/distinfo3
-rw-r--r--net/sipp/files/patch-Makefile83
-rw-r--r--net/sipp/files/patch-prepare_pcap.c48
-rw-r--r--net/sipp/files/patch-prepare_pcap.h13
-rw-r--r--net/sipp/files/patch-send_packets.c13
-rw-r--r--net/sipp/files/sipp.1158
-rw-r--r--net/sipp/pkg-descr6
8 files changed, 0 insertions, 416 deletions
diff --git a/net/sipp/Makefile b/net/sipp/Makefile
deleted file mode 100644
index 07bf06fb48cc..000000000000
--- a/net/sipp/Makefile
+++ /dev/null
@@ -1,92 +0,0 @@
-# New ports collection makefile for: sipp
-# Date created: 15 Jun 2004
-# Whom: jesper@jdn.dk
-#
-# $FreeBSD$
-#
-
-PORTNAME= sipp
-PORTVERSION= 2.0.20070906
-CATEGORIES= net
-MASTER_SITES= http://sipp.sourceforge.net/snapshots/
-DISTNAME= ${PORTNAME}.2007-09-06
-
-MAINTAINER= tut@nhamon.com.ua
-COMMENT= SIP testing tool
-
-PLIST_FILES= bin/sipp
-MAN1= sipp.1
-
-MAKE_ENV+= CPP="${CXX}" \
- CPPFLAGS="${CXXFLAGS}" \
- CCLINK="${CXX}"
-
-OPTIONS= OPENSSL "OpenSSL support (for digest auth and SIP over TLS)" on \
- GSL "GSL support (for statistical distributed pauses)" off \
- PCAPPLAY "RTP play support" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_GSL)
-LIB_DEPENDS+= gsl.10:${PORTSDIR}/math/gsl
-
-MAKE_ENV+= EXTRACPPFLAGS=-DHAVE_GSL \
- EXTRACFLAGS=-DHAVE_GSL \
- EXTRALIBS='-lgsl -lgslcblas'
-.endif #defined(WITH_GSL)
-
-.if defined(WITH_PCAPPLAY)
-PCAP_FILES= dtmf_2833_1.pcap dtmf_2833_2.pcap dtmf_2833_3.pcap \
- dtmf_2833_4.pcap dtmf_2833_5.pcap dtmf_2833_6.pcap \
- dtmf_2833_7.pcap dtmf_2833_8.pcap dtmf_2833_9.pcap \
- dtmf_2833_pound.pcap dtmf_2833_star.pcap g711a.pcap
-
-PLIST_DIRS= %%DATADIR%%/pcap \
- %%DATADIR%%
-
-.for f in ${PCAP_FILES}
-PLIST_FILES+= %%DATADIR%%/pcap/${f}
-.endfor
-.endif #defined(WITH_PCAPPLAY)
-
-.if defined(WITHOUT_OPENSSL)
-
-.if defined(WITH_PCAPPLAY)
-ALL_TARGET= pcapplay
-.endif #defined(WITH_PCAPPLAY)
-
-.else #!defined(WITHOUT_OPENSSL)
-
-.if defined(WITH_PCAPPLAY)
-ALL_TARGET= pcapplay_ossl
-.else
-ALL_TARGET= ossl
-.endif #defined(WITH_PCAPPLAY)
-
-.endif #defined(WITHOUT_OPENSSL)
-
-post-patch:
-.if ${ARCH} == "ia64"
- @${REINPLACE_CMD} 's/^\(MFLAGS_ia64=\)\+DD64$$/\1/' ${WRKSRC}/Makefile
-.endif
-
-.if defined(WITH_PCAPPLAY)
- @${REINPLACE_CMD} \
- 's|\(\\"\)\(pcap/[^"]*\.pcap\\"\)|\1${DATADIR}/\2|' \
- ${WRKSRC}/scenario.cpp
-.endif #defined(WITH_PCAPPLAY)
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${FILESDIR}/sipp.1 ${PREFIX}/man/man1
-
-.if defined(WITH_PCAPPLAY)
- ${MKDIR} ${DATADIR}/pcap
-
-.for f in ${PCAP_FILES}
- ${INSTALL_DATA} ${WRKSRC}/pcap/${f} ${DATADIR}/pcap/${f}
-.endfor
-
-.endif #defined(WITH_PCAPPLAY)
-
-.include <bsd.port.post.mk>
diff --git a/net/sipp/distinfo b/net/sipp/distinfo
deleted file mode 100644
index d718b0d00e18..000000000000
--- a/net/sipp/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (sipp.2007-09-06.tar.gz) = b96d01b1435912ea65fd0092c98f130e
-SHA256 (sipp.2007-09-06.tar.gz) = b20de66bdd6b33b8d5441e3655f6e8f247dbcd40b9853e43ab9992f8122ff7eb
-SIZE (sipp.2007-09-06.tar.gz) = 197176
diff --git a/net/sipp/files/patch-Makefile b/net/sipp/files/patch-Makefile
deleted file mode 100644
index 06c2bf30c561..000000000000
--- a/net/sipp/files/patch-Makefile
+++ /dev/null
@@ -1,83 +0,0 @@
---- Makefile.orig 2007-09-06 11:51:24.000000000 +0300
-+++ Makefile 2007-09-08 19:16:08.000000000 +0300
-@@ -18,8 +18,6 @@
- # From Hewlett Packard Company.
- #
-
---include local.mk
--
- # Output binary to be built
- OUTPUT=sipp
-
-@@ -69,7 +67,7 @@
- CC_SunOS=gcc
- CC_Cygwin=cc
- CC_Darwin=cc
--CC=$(CC_$(SYSTEM))
-+CC?=$(CC_$(SYSTEM))
-
- # C++ compiler mapping
- CPP_hpux=aCC
-@@ -79,7 +77,7 @@
- CPP_SunOS=g++
- CPP_Cygwin=g++
- CPP_Darwin=g++
--CPP=$(CPP_$(SYSTEM))
-+CPP?=$(CPP_$(SYSTEM))
-
- #Model specific flags
- MFLAGS_ia64=+DD64
-@@ -102,7 +100,7 @@
- CFLAGS_SunOS=-g -D__SUNOS
- CFLAGS_Cygwin=-D__CYGWIN -Dsocklen_t=int
- CFLAGS_Darwin=-D__DARWIN
--CFLAGS=$(CFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY) $(EXTRACFLAGS)
-+CFLAGS+=$(CFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY) $(EXTRACFLAGS)
-
- #C++ Compiler Flags
- CPPFLAGS_hpux=-AA -mt -D__HPUX +W829
-@@ -112,7 +110,7 @@
- CPPFLAGS_SunOS=-g -D__SUNOS
- CPPFLAGS_Cygwin=-D__CYGWIN -Dsocklen_t=int
- CPPFLAGS_Darwin=-D__DARWIN
--CPPFLAGS=$(CPPFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY) $(EXTRACPPFLAGS)
-+CPPFLAGS+=$(CPPFLAGS_$(SYSTEM)) -D__3PCC__ $(TLS) $(PCAPPLAY) $(EXTRACPPFLAGS)
-
- #Linker mapping
- CCLINK_hpux=aCC
-@@ -122,7 +120,7 @@
- CCLINK_SunOS=gcc
- CCLINK_Cygwin=g++
- CCLINK_Darwin=g++
--CCLINK=$(CCLINK_$(SYSTEM))
-+CCLINK?=$(CCLINK_$(SYSTEM))
-
- #Linker Flags
- LFLAGS_hpux=-AA -mt
-@@ -138,7 +136,7 @@
- LIBS_linux= -ldl -lpthread -lncurses -lstdc++ -lm -L /usr/local/lib -L /usr/lib -L /usr/lib64
- LIBS_hpux= -lcurses -lpthread -L /opt/openssl/lib -L /usr/local/lib
- LIBS_tru64= -lcurses -lpthread
--LIBS_freebsd= -lcurses -pthread
-+LIBS_freebsd= -lcurses -pthread -L /usr/local/lib
- LIBS_SunOS= -lcurses -lpthread -lnsl -lsocket -lstdc++ -lm -ldl -L /usr/local/ssl/lib/
- LIBS_Cygwin= -lcurses -lpthread -lstdc++ -L /usr/lib/WpdPack/Lib
- LIBS_Darwin= -lcurses
-@@ -146,7 +144,7 @@
-
- # Include directories
- INCDIR_linux=-I. -I/usr/include/openssl
--INCDIR_freebsd=-I. -I/opt/openssl/include
-+INCDIR_freebsd=-I. -I/usr/local/include
- INCDIR_hpux=-I. -I/usr/local/include -I/opt/openssl/include
- INCDIR_tru64=-I. -I/opt/openssl/include
- INCDIR_SunOS=-I. -I/usr/local/ssl/include/
-@@ -154,8 +152,6 @@
- INCDIR_Darwin=-I. -I/usr/local/ssl/include
- INCDIR=$(INCDIR_$(SYSTEM))
-
---include local.mk
--
- # Building without TLS and authentication (no openssl pre-requisite)
- all:
- make OSNAME=`uname|sed -e "s/CYGWIN.*/CYGWIN/"` MODELNAME=`uname -m|sed "s/Power Macintosh/ppc/"` $(OUTPUT)
diff --git a/net/sipp/files/patch-prepare_pcap.c b/net/sipp/files/patch-prepare_pcap.c
deleted file mode 100644
index a878d162d7ba..000000000000
--- a/net/sipp/files/patch-prepare_pcap.c
+++ /dev/null
@@ -1,48 +0,0 @@
-$FreeBSD$
-
---- prepare_pcap.c.orig
-+++ prepare_pcap.c
-@@ -19,7 +19,7 @@
- #include <stdlib.h>
- #include <netinet/in.h>
- #include <netinet/udp.h>
--#if defined(__HPUX) || defined(__CYGWIN)
-+#if defined(__HPUX) || defined(__CYGWIN) || defined(__FreeBSD__)
- #include <netinet/in_systm.h>
- #endif
- #include <netinet/ip.h>
-@@ -142,7 +142,7 @@
- fprintf(stderr, "prepare_pcap.c: Ignoring non UDP packet!\n");
- continue;
- }
--#if defined(__DARWIN) || defined(__CYGWIN)
-+#if defined(__DARWIN) || defined(__CYGWIN) || defined(__FreeBSD__)
- udphdr = (struct udphdr *)((char *)iphdr + (iphdr->ihl << 2) + 4);
- pktlen = (u_long)(ntohs(udphdr->uh_ulen));
- #else
-@@ -164,7 +164,7 @@
- ERROR("Can't allocate memory for pcap pkt data");
- memcpy(pkt_index->data, udphdr, pktlen);
-
--#if defined(__HPUX) || defined(__DARWIN) || (defined __CYGWIN)
-+#if defined(__HPUX) || defined(__DARWIN) || (defined __CYGWIN) || defined(__FreeBSD__)
- udphdr->uh_sum = 0 ;
- #else
- udphdr->check = 0;
-@@ -173,14 +173,14 @@
- // compute a partial udp checksum
- // not including port that will be changed
- // when sending RTP
--#if defined(__HPUX) || defined(__DARWIN) || (defined __CYGWIN)
-+#if defined(__HPUX) || defined(__DARWIN) || (defined __CYGWIN) || defined(__FreeBSD__)
- pkt_index->partial_check = check((u_int16_t *) &udphdr->uh_ulen, pktlen - 4) + ntohs(IPPROTO_UDP + pktlen);
- #else
- pkt_index->partial_check = check((u_int16_t *) &udphdr->len, pktlen - 4) + ntohs(IPPROTO_UDP + pktlen);
- #endif
- if (max_length < pktlen)
- max_length = pktlen;
--#if defined(__HPUX) || defined(__DARWIN) || (defined __CYGWIN)
-+#if defined(__HPUX) || defined(__DARWIN) || (defined __CYGWIN) || defined(__FreeBSD__)
- if (base > ntohs(udphdr->uh_dport))
- base = ntohs(udphdr->uh_dport);
- #else
diff --git a/net/sipp/files/patch-prepare_pcap.h b/net/sipp/files/patch-prepare_pcap.h
deleted file mode 100644
index f7c7fec52e60..000000000000
--- a/net/sipp/files/patch-prepare_pcap.h
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- prepare_pcap.h.orig
-+++ prepare_pcap.h
-@@ -22,7 +22,7 @@
- #include <netinet/udp.h>
- #include <time.h>
-
--#if defined(__HPUX) || defined(__DARWIN) || defined(__CYGWIN)
-+#if defined(__HPUX) || defined(__DARWIN) || defined(__CYGWIN) || defined(__FreeBSD__)
- #define u_int8_t uint8_t
- #define u_int16_t uint16_t
- #define u_int32_t uint32_t
diff --git a/net/sipp/files/patch-send_packets.c b/net/sipp/files/patch-send_packets.c
deleted file mode 100644
index e386eee113b6..000000000000
--- a/net/sipp/files/patch-send_packets.c
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- send_packets.c.orig
-+++ send_packets.c
-@@ -45,7 +45,7 @@
- #include <unistd.h>
- #include <stdlib.h>
- #include <netinet/udp.h>
--#if defined(__DARWIN) || defined(__CYGWIN)
-+#if defined(__DARWIN) || defined(__CYGWIN) || defined(__FreeBSD__)
- #include <netinet/in.h>
- #endif
- #ifndef __CYGWIN
diff --git a/net/sipp/files/sipp.1 b/net/sipp/files/sipp.1
deleted file mode 100644
index 52e5cbe2cac6..000000000000
--- a/net/sipp/files/sipp.1
+++ /dev/null
@@ -1,158 +0,0 @@
-.\"
-.\" Standard preamble:
-.\" ========================================================================
-.de Sh \" Subsection heading
-.br
-.if t .Sp
-.ne 5
-.PP
-\fB\\$1\fR
-.PP
-..
-.de Sp \" Vertical space (when we can't use .PP)
-.if t .sp .5v
-.if n .sp
-..
-.de Vb \" Begin verbatim text
-.ft CW
-.nf
-.ne \\$1
-..
-.de Ve \" End verbatim text
-.ft R
-.fi
-..
-.\" Set up some character translations and predefined strings. \*(-- will
-.\" give an unbreakable dash, \*(PI will give pi, \*(L" will give a left
-.\" double quote, and \*(R" will give a right double quote. | will give a
-.\" real vertical bar. \*(C+ will give a nicer C++. Capital omega is used to
-.\" do unbreakable dashes and therefore won't be available. \*(C` and \*(C'
-.\" expand to `' in nroff, nothing in troff, for use with C<>.
-.tr \(*W-|\(bv\*(Tr
-.ds C+ C\v'-.1v'\h'-1p'\s-2+\h'-1p'+\s0\v'.1v'\h'-1p'
-.ie n \{\
-. ds -- \(*W-
-. ds PI pi
-. if (\n(.H=4u)&(1m=24u) .ds -- \(*W\h'-12u'\(*W\h'-12u'-\" diablo 10 pitch
-. if (\n(.H=4u)&(1m=20u) .ds -- \(*W\h'-12u'\(*W\h'-8u'-\" diablo 12 pitch
-. ds L" ""
-. ds R" ""
-. ds C` ""
-. ds C' ""
-'br\}
-.el\{\
-. ds -- \|\(em\|
-. ds PI \(*p
-. ds L" ``
-. ds R" ''
-'br\}
-.\"
-.\" If the F register is turned on, we'll generate index entries on stderr for
-.\" titles (.TH), headers (.SH), subsections (.Sh), items (.Ip), and index
-.\" entries marked with X<> in POD. Of course, you'll have to process the
-.\" output yourself in some meaningful fashion.
-.if \nF \{\
-. de IX
-. tm Index:\\$1\t\\n%\t"\\$2"
-..
-. nr % 0
-. rr F
-.\}
-.\"
-.\" For nroff, turn off justification. Always turn off hyphenation; it makes
-.\" way too many mistakes in technical documents.
-.hy 0
-.if n .na
-.\"
-.\" Accent mark definitions (@(#)ms.acc 1.5 88/02/08 SMI; from UCB 4.2).
-.\" Fear. Run. Save yourself. No user-serviceable parts.
-. \" fudge factors for nroff and troff
-.if n \{\
-. ds #H 0
-. ds #V .8m
-. ds #F .3m
-. ds #[ \f1
-. ds #] \fP
-.\}
-.if t \{\
-. ds #H ((1u-(\\\\n(.fu%2u))*.13m)
-. ds #V .6m
-. ds #F 0
-. ds #[ \&
-. ds #] \&
-.\}
-. \" simple accents for nroff and troff
-.if n \{\
-. ds ' \&
-. ds ` \&
-. ds ^ \&
-. ds , \&
-. ds ~ ~
-. ds /
-.\}
-.if t \{\
-. ds ' \\k:\h'-(\\n(.wu*8/10-\*(#H)'\'\h"|\\n:u"
-. ds ` \\k:\h'-(\\n(.wu*8/10-\*(#H)'\`\h'|\\n:u'
-. ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'^\h'|\\n:u'
-. ds , \\k:\h'-(\\n(.wu*8/10)',\h'|\\n:u'
-. ds ~ \\k:\h'-(\\n(.wu-\*(#H-.1m)'~\h'|\\n:u'
-. ds / \\k:\h'-(\\n(.wu*8/10-\*(#H)'\z\(sl\h'|\\n:u'
-.\}
-. \" troff and (daisy-wheel) nroff accents
-.ds : \\k:\h'-(\\n(.wu*8/10-\*(#H+.1m+\*(#F)'\v'-\*(#V'\z.\h'.2m+\*(#F'.\h'|\\n:u'\v'\*(#V'
-.ds 8 \h'\*(#H'\(*b\h'-\*(#H'
-.ds o \\k:\h'-(\\n(.wu+\w'\(de'u-\*(#H)/2u'\v'-.3n'\*(#[\z\(de\v'.3n'\h'|\\n:u'\*(#]
-.ds d- \h'\*(#H'\(pd\h'-\w'~'u'\v'-.25m'\f2\(hy\fP\v'.25m'\h'-\*(#H'
-.ds D- D\\k:\h'-\w'D'u'\v'-.11m'\z\(hy\v'.11m'\h'|\\n:u'
-.ds th \*(#[\v'.3m'\s+1I\s-1\v'-.3m'\h'-(\w'I'u*2/3)'\s-1o\s+1\*(#]
-.ds Th \*(#[\s+2I\s-2\h'-\w'I'u*3/5'\v'-.3m'o\v'.3m'\*(#]
-.ds ae a\h'-(\w'a'u*4/10)'e
-.ds Ae A\h'-(\w'A'u*4/10)'E
-. \" corrections for vroff
-.if v .ds ~ \\k:\h'-(\\n(.wu*9/10-\*(#H)'\s-2\u~\d\s+2\h'|\\n:u'
-.if v .ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'\v'-.4m'^\v'.4m'\h'|\\n:u'
-. \" for low resolution devices (crt and lpr)
-.if \n(.H>23 .if \n(.V>19 \
-\{\
-. ds : e
-. ds 8 ss
-. ds o a
-. ds d- d\h'-1'\(ga
-. ds D- D\h'-1'\(hy
-. ds th \o'bp'
-. ds Th \o'LP'
-. ds ae ae
-. ds Ae AE
-.\}
-.rm #[ #] #H #V #F C
-.\" ========================================================================
-.\"
-.IX Title "sipp 1"
-.TH sipp 1 "2006-12-17" "sipp" "User Contributed Documentation"
-.SH "NAME"
-sipp \- A benchworking tool for the SIP protocol.
-.SH "DESCRIPTION"
-.IX Header "DESCRIPTION"
-Sipp is a performance test tool / traffic generator for the \s-1SIP\s0
-protocol. It comes with a few basic SipStone user-agents
-scenarios (\s-1UAC\s0 & \s-1UAS\s0), establishing and releasing multiple
-calls with the \s-1INVITE\s0 and \s-1BYE\s0 methods.
-.PP
-It can also read \s-1XML\s0 scenario files describing any performance
-testing configuration for \s-1SIP\s0.
-.SH "SYNTAX"
-.IX Header "SYNTAX"
-.Vb 1
-\&Run 'sipp' command without parameters for configuration details.
-.Ve
-.SH "SEE ALSO"
-.IX Header "SEE ALSO"
-.Vb 1
-\&SIPp documentation - http://sipp.sourceforge.net/doc/
-.Ve
-.SH "AUTHORS"
-.IX Header "AUTHORS"
-.Vb 2
-\&Richard Gayraud <richard_gayraud@users.sourceforge.net>
-\&Olivier Jacques <ojacques@users.sourceforge.net>
-.Ve
diff --git a/net/sipp/pkg-descr b/net/sipp/pkg-descr
deleted file mode 100644
index b7635f87453e..000000000000
--- a/net/sipp/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-Sipp is a performance test tool / traffic generator for the SIP protocol.
-
-It comes with a few basic SipStone user-agents scenarios (UAC & UAS), i
-establishing and releasing multiple calls with the INVITE and BYE methods.
-
-WWW: http://sipp.sourceforge.net/