aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-16 18:07:53 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-16 18:25:09 +0000
commit12092ad379be36655a15e628826cbbd381832b1a (patch)
tree437e1501910b0de1c0ab2e88a59c931d39afc982
parentf7b14f154dbbaf782b74707fd9a2db70339cf919 (diff)
downloadports-12092ad379be36655a15e628826cbbd381832b1a.tar.gz
ports-12092ad379be36655a15e628826cbbd381832b1a.zip
astro/cfitsio: Update to 4.3.0
-rw-r--r--astro/cfitsio/Makefile5
-rw-r--r--astro/cfitsio/distinfo6
-rw-r--r--astro/cfitsio/files/patch-fitsio2.h28
3 files changed, 32 insertions, 7 deletions
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index 6c95a96fd1ca..dbed5e4b5e4f 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -1,5 +1,5 @@
PORTNAME= cfitsio
-PORTVERSION= 4.2.0
+PORTVERSION= 4.3.0
CATEGORIES= astro
MASTER_SITES= https://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/ \
https://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/oldvers/ \
@@ -27,9 +27,6 @@ CPE_VENDOR= nasa
OPTIONS_DEFINE= DOCS
-post-patch:
- @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' ${WRKSRC}/*.[chl]
-
do-install:
cd ${WRKSRC}/ && ${INSTALL_DATA} drvrsmem.h fitsio.h fitsio2.h longnam.h ${STAGEDIR}${PREFIX}/include/
${INSTALL_DATA} ${WRKSRC}/libcfitsio.a ${STAGEDIR}${PREFIX}/lib/
diff --git a/astro/cfitsio/distinfo b/astro/cfitsio/distinfo
index 39a9400708b3..aa3f39a0848e 100644
--- a/astro/cfitsio/distinfo
+++ b/astro/cfitsio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1669057507
-SHA256 (cfitsio-4.2.0.tar.gz) = eba53d1b3f6e345632bb09a7b752ec7ced3d63ec5153a848380f3880c5d61889
-SIZE (cfitsio-4.2.0.tar.gz) = 4356372
+TIMESTAMP = 1691069920
+SHA256 (cfitsio-4.3.0.tar.gz) = fdadc01d09cf9f54253802c5ec87eb10de51ce4130411415ae88c30940621b8b
+SIZE (cfitsio-4.3.0.tar.gz) = 4367500
diff --git a/astro/cfitsio/files/patch-fitsio2.h b/astro/cfitsio/files/patch-fitsio2.h
new file mode 100644
index 000000000000..7d04cb3729a5
--- /dev/null
+++ b/astro/cfitsio/files/patch-fitsio2.h
@@ -0,0 +1,28 @@
+from astro/p5-Astro-FITS-CFITSIO build log:
+
+/usr/local/include/fitsio2.h:271:5: error: invalid token at start of a preprocessor expression
+#if MACHINE == CRAY
+ ^
+/usr/include/machine/param.h:59:18: note: expanded from macro 'MACHINE'
+#define MACHINE "amd64"
+ ^
+
+--- fitsio2.h.orig 2023-07-21 14:37:17 UTC
++++ fitsio2.h
+@@ -268,14 +268,14 @@ extern int Fitsio_Pthread_Status;
+
+ #endif
+
+-#if MACHINE == CRAY
++#if 0
+ /*
+ Cray machines: the large negative integer corresponds
+ to the 3 most sig digits set to 1. If these
+ 3 bits are set in a floating point number (64 bits), then it represents
+ a reserved value (i.e., a NaN)
+ */
+-#define fnan(L) ( (L) >= 0xE000000000000000 ? 1 : 0) )
++#define fnan(L) ( (L) >= 0xE000000000000000 ? 1 : 0)
+
+ #else
+ /* these functions work for both big and little endian machines */