aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2015-03-13 10:24:43 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2015-03-13 10:24:43 +0000
commit1210c3e414f0708c1e092aea80adff8a5a4bee11 (patch)
treea56dcad13fe1f419cddd4a63aaabbd74501f4694
parent5e6902cf1aa15b8a2e1f314b10ca19417a0829db (diff)
downloadports-1210c3e414f0708c1e092aea80adff8a5a4bee11.tar.gz
ports-1210c3e414f0708c1e092aea80adff8a5a4bee11.zip
- Update to 1.5.1 (automatic library updates can be enabled again)
- Fix problems when more than one JVM is installed [1] PR: 198021 [1] Noticed by: jason.unovitch@gmail.com [1]
Notes
Notes: svn path=/head/; revision=381171
-rw-r--r--UPDATING8
-rw-r--r--net/serviio/Makefile2
-rw-r--r--net/serviio/distinfo4
-rw-r--r--net/serviio/files/serviiod.in3
4 files changed, 13 insertions, 4 deletions
diff --git a/UPDATING b/UPDATING
index a18368321b8e..7ed0f72fa872 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,14 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20150313:
+ AFFECTS: users of net/serviio
+ AUTHOR: netchild@FreeBSD.org
+
+ The Java Polling Watch Service used in Serviio 1.5.1 is fixed. If you
+ unchecked "Keep library automatically updated" with 1.5 (as recommended
+ in the 20150206 entry) you can enable it again.
+
20150305:
AFFECTS: users of x11-wm/xfce4 and multimedia/xfce4-parole
AUTHOR: olivierd@FreeBSD.org
diff --git a/net/serviio/Makefile b/net/serviio/Makefile
index 28395afc0453..5ef1daaa8ac4 100644
--- a/net/serviio/Makefile
+++ b/net/serviio/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= serviio
-PORTVERSION= 1.5
+PORTVERSION= 1.5.1
#PORTREVISION= 0
CATEGORIES= net multimedia java www
MASTER_SITES= http://download.serviio.org/releases/
diff --git a/net/serviio/distinfo b/net/serviio/distinfo
index 87e67c5f9762..1b8899e8fbc2 100644
--- a/net/serviio/distinfo
+++ b/net/serviio/distinfo
@@ -1,2 +1,2 @@
-SHA256 (serviio-1.5-linux.tar.gz) = e933de2f5f9da95cc3cdc3afba9d5b623fd5fd4189c5f7f247d4718e14166c3c
-SIZE (serviio-1.5-linux.tar.gz) = 22055839
+SHA256 (serviio-1.5.1-linux.tar.gz) = cc40e2cf777815fa1dda621b7eb66f58289111c01aec828f8dbf019307082bc7
+SIZE (serviio-1.5.1-linux.tar.gz) = 22065747
diff --git a/net/serviio/files/serviiod.in b/net/serviio/files/serviiod.in
index 473b0dff3cc3..19f16560c49e 100644
--- a/net/serviio/files/serviiod.in
+++ b/net/serviio/files/serviiod.in
@@ -19,6 +19,7 @@ SERVIIO_CLASS_PATH="$SERVIIO_CLASS_PATH:%%ETCDIR%%"
# Setup Serviio specific properties
JAVA_OPTS="-Djava.net.preferIPv4Stack=true -Djava.awt.headless=true -Dorg.restlet.engine.loggerFacadeClass=org.restlet.ext.slf4j.Slf4jLoggerFacade -Dderby.system.home=/var/db/serviio -Dserviio.home=$HOME -Dffmpeg.location=%%LOCALBASE%%/bin/ffmpeg -Ddcraw.location=%%LOCALBASE%%/bin/dcraw"
JAVA_OPTS="${JAVA_OPTS} -Djcs.auxiliary.DC.attributes.DiskPath=/var/db/serviio"
+JAVA_VERSION="1.8+"
# A kludge to get the -D... flags to Java, rather than to Serviio itself:
for o in "$@"
@@ -31,5 +32,5 @@ do
done
# Execute the JVM in the foreground
-export HOME PATH
+export HOME PATH JAVA_VERSION
exec java -Xmx512M -Xms20M -XX:+UseG1GC -XX:GCTimeRatio=1 -XX:MinHeapFreeRatio=10 -XX:MaxHeapFreeRatio=20 $JAVA_OPTS -classpath "$SERVIIO_CLASS_PATH" org.serviio.MediaServer "$@" 2>&1 >/dev/null