aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2022-08-31 17:41:03 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-08-31 17:41:03 +0000
commit127558d3ce3058d807feedd20696fe41c7d75bfb (patch)
tree5111cc3f45d43eb54b4b1f557e66683586dc79f2
parent5fd2b15e59599c1b4a37c4b17db6c4d3219eae53 (diff)
downloadports-127558d3ce3058d807feedd20696fe41c7d75bfb.tar.gz
ports-127558d3ce3058d807feedd20696fe41c7d75bfb.zip
-rw-r--r--www/hiawatha/Makefile7
-rw-r--r--www/hiawatha/distinfo6
-rw-r--r--www/hiawatha/files/patch-CMakeLists.txt4
-rw-r--r--www/hiawatha/files/patch-config.h.in4
-rw-r--r--www/hiawatha/files/patch-src_hiawatha.c8
5 files changed, 14 insertions, 15 deletions
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
index 8fa4f92d4868..1df719bdde60 100644
--- a/www/hiawatha/Makefile
+++ b/www/hiawatha/Makefile
@@ -1,6 +1,5 @@
PORTNAME= hiawatha
-PORTVERSION= 10.12
-PORTREVISION= 3
+PORTVERSION= 11.2
CATEGORIES= www
MASTER_SITES= https://www.hiawatha-webserver.org/files/
@@ -58,8 +57,8 @@ post-patch:
${WRKSRC}/man/hiawatha.1.in
post-install:
-.for f in hiawatha.conf mimetype.conf cgi-wrapper.conf toolkit.conf \
- error.xslt index.xslt
+.for f in hiawatha.conf mimetype.conf cgi-wrapper.conf toolkit.conf error.xslt \
+ index.xslt
${INSTALL_DATA} ${WRKSRC}/config/${f} \
${STAGEDIR}${PREFIX}/etc/hiawatha/${f}.sample
.endfor
diff --git a/www/hiawatha/distinfo b/www/hiawatha/distinfo
index 15a940c01607..3352a5fbd423 100644
--- a/www/hiawatha/distinfo
+++ b/www/hiawatha/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1617048335
-SHA256 (hiawatha-10.12.tar.gz) = 61bf41146c51244769984135529fcffd0f6cb92be18dc12d460effc42f19f50d
-SIZE (hiawatha-10.12.tar.gz) = 1454134
+TIMESTAMP = 1661965966
+SHA256 (hiawatha-11.2.tar.gz) = 99c64f76927f93469f062ab76b74eb79a397ea4be12da86bf746b2bb57cf1bc5
+SIZE (hiawatha-11.2.tar.gz) = 1583611
diff --git a/www/hiawatha/files/patch-CMakeLists.txt b/www/hiawatha/files/patch-CMakeLists.txt
index 8dbbd214729d..fc0ccada759f 100644
--- a/www/hiawatha/files/patch-CMakeLists.txt
+++ b/www/hiawatha/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2018-09-11 05:44:11 UTC
+--- CMakeLists.txt.orig 2022-06-01 21:01:35 UTC
+++ CMakeLists.txt
-@@ -39,7 +39,8 @@ include(FindZLIB)
+@@ -36,7 +36,8 @@ include(cmake/CopyIfNotExists.cmake)
include(cmake/CopyIfNotExists.cmake)
# Settings
diff --git a/www/hiawatha/files/patch-config.h.in b/www/hiawatha/files/patch-config.h.in
index 8efdf0534fc8..b71043215465 100644
--- a/www/hiawatha/files/patch-config.h.in
+++ b/www/hiawatha/files/patch-config.h.in
@@ -1,6 +1,6 @@
---- config.h.in.orig 2017-03-13 19:58:34 UTC
+--- config.h.in.orig 2022-01-23 19:44:44 UTC
+++ config.h.in
-@@ -46,6 +46,7 @@
+@@ -43,6 +43,7 @@
/* Functions
*/
#cmakedefine HAVE_CRYPT_R ${HAVE_CRYPT_R}
diff --git a/www/hiawatha/files/patch-src_hiawatha.c b/www/hiawatha/files/patch-src_hiawatha.c
index e345ec2ec194..4aa62c339cf9 100644
--- a/www/hiawatha/files/patch-src_hiawatha.c
+++ b/www/hiawatha/files/patch-src_hiawatha.c
@@ -1,6 +1,6 @@
---- src/hiawatha.c.orig 2018-09-16 08:22:32 UTC
+--- src/hiawatha.c.orig 2021-07-22 15:18:13 UTC
+++ src/hiawatha.c
-@@ -156,8 +156,12 @@ void task_runner(t_config *config) {
+@@ -141,8 +141,12 @@ void task_runner(t_config *config) {
int delay = 0;
time_t now;
#ifdef ENABLE_LOADCHECK
@@ -13,7 +13,7 @@
#ifdef ENABLE_MONITOR
int load_monitor_timer = 0;
#endif
-@@ -228,6 +232,21 @@ void task_runner(t_config *config) {
+@@ -213,6 +217,21 @@ void task_runner(t_config *config) {
#ifdef ENABLE_LOADCHECK
if (config->max_server_load > 0) {
@@ -35,7 +35,7 @@
if ((load_fp = fopen("/proc/loadavg", "r")) != NULL) {
if (fgets(load_str, 49, load_fp) != NULL) {
load_str[49] = '\0';
-@@ -253,6 +272,7 @@ void task_runner(t_config *config) {
+@@ -238,6 +257,7 @@ void task_runner(t_config *config) {
} else {
current_server_load = 0;
}