aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-25 12:21:42 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-25 12:21:42 +0000
commit1346bf9c9bdec492755fbb2420bbf3113b304027 (patch)
tree9e37792cb81cfb32dab8166e1c8dcda3c7837fb6
parent49d9a8f24d6d994167f9a9a0af9eb326706cd453 (diff)
downloadports-1346bf9c9bdec492755fbb2420bbf3113b304027.tar.gz
ports-1346bf9c9bdec492755fbb2420bbf3113b304027.zip
Notes
-rw-r--r--security/scanlogd/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/security/scanlogd/Makefile b/security/scanlogd/Makefile
index 4eb06e0b7197..98ba33058c5a 100644
--- a/security/scanlogd/Makefile
+++ b/security/scanlogd/Makefile
@@ -14,22 +14,18 @@ COMMENT= TCP port scan detection tool
USE_RC_SUBR= ${PORTNAME}
.if defined(WITH_LIBNIDS)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libnids.a:${PORTSDIR}/net/libnids
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libnids.a:${PORTSDIR}/net/libnids
ALL_TARGET= libnids
.else
ALL_TARGET= libpcap
.endif
+
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -c" LD="${CC}"
-MAN8= scanlogd.8
-PLIST_FILES= bin/scanlogd
+PLIST_FILES= bin/scanlogd man/man8/scanlogd.8.gz
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/scanlogd ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/scanlogd.8 ${MANPREFIX}/man/man8
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_PROGRAM} ${WRKSRC}/scanlogd ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/scanlogd.8 ${STAGEDIR}${MANPREFIX}/man/man8
.include <bsd.port.mk>