aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-12-25 14:18:37 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-12-25 14:18:37 +0000
commit144e6f10b641c3b1acab595fd2eb0b2b34b7934a (patch)
tree7e254a47f04d49e0fae4d0b1b536be0ffbdd9aea
parentb4689059076c08ec789d7a4f7211909457285421 (diff)
downloadports-144e6f10b641c3b1acab595fd2eb0b2b34b7934a.tar.gz
ports-144e6f10b641c3b1acab595fd2eb0b2b34b7934a.zip
Notes
-rw-r--r--MOVED1
-rw-r--r--games/Makefile1
-rw-r--r--games/hex/Makefile32
-rw-r--r--games/hex/distinfo2
-rw-r--r--games/hex/files/patch-Makefile26
-rw-r--r--games/hex/files/patch-hex.c12
-rw-r--r--games/hex/files/patch-hex.h12
-rw-r--r--games/hex/pkg-descr5
-rw-r--r--games/hex/pkg-plist14
9 files changed, 1 insertions, 104 deletions
diff --git a/MOVED b/MOVED
index 72e55817e597..d2dcb5d18089 100644
--- a/MOVED
+++ b/MOVED
@@ -7332,3 +7332,4 @@ graphics/pornview||2014-12-24|No more upstream, no more public distfile, no prop
misc/gnomehier||2014-12-25|Not needed anymore
graphics/corona||2014-12-25|Abandonware, no proper support for modern png
graphics/libpano12|graphics/libpano13|2014-12-25|No proper support for modern png, newer version available as libpano13
+games/hex||2014-12-25|Abandonware, no support for moden graphics libraries
diff --git a/games/Makefile b/games/Makefile
index bda222a60b87..b11a788edb1a 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -390,7 +390,6 @@
SUBDIR += help_hannahs_horse
SUBDIR += heretic
SUBDIR += heroes
- SUBDIR += hex
SUBDIR += hex-a-hop
SUBDIR += hexalate
SUBDIR += hexglass
diff --git a/games/hex/Makefile b/games/hex/Makefile
deleted file mode 100644
index ca62ec3b4e81..000000000000
--- a/games/hex/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-# Created by: Will Andrews <andrews@technologist.com>
-# $FreeBSD$
-
-PORTNAME= hex
-PORTVERSION= 0.0.2
-PORTREVISION= 11
-CATEGORIES= games
-MASTER_SITES= http://www.earth.li/projectpurple/files/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Clone of "Puzzle Bobble" for X11 that uses GTK/Imlib
-
-USE_GNOME= imlib
-MAKE_ENV= GRAPHICPATH="${GRAPHICPATH}" LEVELPATH="${LEVELPATH}"
-
-GRAPHICPATH= ${PREFIX}/share/hex/graphics
-LEVELPATH= ${PREFIX}/share/hex/levels
-
-OPTIONS_DEFINE= DOCS
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hex ${STAGEDIR}${PREFIX}/bin
- @${MKDIR} ${STAGEDIR}${GRAPHICPATH}
- ${INSTALL_DATA} ${WRKSRC}/graphics/*.png ${STAGEDIR}${GRAPHICPATH}
- @${MKDIR} ${STAGEDIR}${LEVELPATH}
- ${INSTALL_DATA} ${WRKSRC}/levels/Level1 ${STAGEDIR}${LEVELPATH}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for file in HISTORY README TODO
- ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
-.endfor
-
-.include <bsd.port.mk>
diff --git a/games/hex/distinfo b/games/hex/distinfo
deleted file mode 100644
index 9916bc988c6a..000000000000
--- a/games/hex/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (hex-0.0.2.tar.gz) = f11e88371a211984b756f28859e3b65c50fbc50dfa458644b67e2a0903cdcb4e
-SIZE (hex-0.0.2.tar.gz) = 318981
diff --git a/games/hex/files/patch-Makefile b/games/hex/files/patch-Makefile
deleted file mode 100644
index 7936e63d64a1..000000000000
--- a/games/hex/files/patch-Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
---- Makefile.orig Fri Aug 6 20:56:10 1999
-+++ Makefile Wed Aug 9 03:01:56 2000
-@@ -1,16 +1,19 @@
--CC = gcc -Wall -O6 -g
-+#CC = gcc -Wall -O6 -g
-
- SRCS = main.c levels.c grid.c player.c touching.c gtkstuff.c plot.c graphics.c
- OBJS = $(SRCS:.c=.o)
--LIBS = -lm -lgdk_imlib
-+CFLAGS += -DGRAPHICPATH=\"${GRAPHICPATH}\" -DLEVELPATH=\"${LEVELPATH}\"
-+#LIBS = -lm -lgdk_imlib
-+GDK_IMLIB_CFLAGS = `imlib-config --cflags-gdk`
-+GDK_IMLIB_LIBS = `imlib-config --libs-gdk`
-
- all: hex
-
- .c.o:
-- $(CC) `gtk-config --cflags` -c $*.c -o $*.o
-+ $(CC) $(CFLAGS) $(GDK_IMLIB_CFLAGS) -c $*.c -o $*.o
-
- hex: $(OBJS)
-- $(CC) $(LIBS) `gtk-config --libs` $(OBJS) -o $@
-+ $(CC) $(LIBS) $(GDK_IMLIB_LIBS) $(OBJS) -o $@
-
- clean:
- rm -f *~ *.o hex
diff --git a/games/hex/files/patch-hex.c b/games/hex/files/patch-hex.c
deleted file mode 100644
index c00792cac4bb..000000000000
--- a/games/hex/files/patch-hex.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- hex.c.orig Thu Aug 5 08:36:00 1999
-+++ hex.c Wed Aug 9 02:55:38 2000
-@@ -17,7 +17,9 @@
- #include <string.h>
- #include <ctype.h>
-
-+#ifndef LEVELPATH
- #define LEVELPATH "./levels/"
-+#endif
-
- #define XSIZE 8
- #define YSIZE 12
diff --git a/games/hex/files/patch-hex.h b/games/hex/files/patch-hex.h
deleted file mode 100644
index 023e818c6d78..000000000000
--- a/games/hex/files/patch-hex.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- hex.h.orig Sat Aug 7 06:27:05 1999
-+++ hex.h Wed Aug 9 02:54:56 2000
-@@ -1,5 +1,9 @@
-+#ifndef GRAPHICPATH
- #define GRAPHICPATH "./graphics/"
-+#endif
-+#ifndef LEVELPATH
- #define LEVELPATH "./levels/"
-+#endif
-
- #define XSIZE 8
- #define YSIZE 12 // add 1 for the ceiling line
diff --git a/games/hex/pkg-descr b/games/hex/pkg-descr
deleted file mode 100644
index c0ae3242e92b..000000000000
--- a/games/hex/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-Hex is a clone of "Puzzle Bobble". It is currently in a rather
-developmental stage, and needs some bugtesting, so unless you
-are a Puzzle Bobble diehard, this game probably isn't for you.
-
-WWW: http://www.earth.li/projectpurple/progs/hex.html
diff --git a/games/hex/pkg-plist b/games/hex/pkg-plist
deleted file mode 100644
index 71aadbd8156c..000000000000
--- a/games/hex/pkg-plist
+++ /dev/null
@@ -1,14 +0,0 @@
-bin/hex
-%%PORTDOCS%%%%DOCSDIR%%/HISTORY
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%DATADIR%%/graphics/ball0.png
-%%DATADIR%%/graphics/ball1.png
-%%DATADIR%%/graphics/ball2.png
-%%DATADIR%%/graphics/ball3.png
-%%DATADIR%%/graphics/ball4.png
-%%DATADIR%%/graphics/ball5.png
-%%DATADIR%%/graphics/ball6.png
-%%DATADIR%%/graphics/ball7.png
-%%DATADIR%%/graphics/ball8.png
-%%DATADIR%%/levels/Level1