aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-11-01 23:06:23 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-11-01 23:06:23 +0000
commit1464c30e05f5f2f152abeae6f437801bbdd69878 (patch)
tree04184a2b306364a02b4016e93f142d6577a817ff
parent6c16736a3162515d8ae342150a43dc5270a40559 (diff)
downloadports-1464c30e05f5f2f152abeae6f437801bbdd69878.tar.gz
ports-1464c30e05f5f2f152abeae6f437801bbdd69878.zip
Notes
-rw-r--r--multimedia/gstreamer/files/patch-Makefile.in12
-rw-r--r--multimedia/gstreamer/files/patch-gst_gstdatetime.c6
-rw-r--r--multimedia/gstreamer/files/patch-gst_parse_grammar.y18
-rw-r--r--multimedia/gstreamer/pkg-plist11
4 files changed, 27 insertions, 20 deletions
diff --git a/multimedia/gstreamer/files/patch-Makefile.in b/multimedia/gstreamer/files/patch-Makefile.in
index fe7d89f4cacf..bcb6f993f200 100644
--- a/multimedia/gstreamer/files/patch-Makefile.in
+++ b/multimedia/gstreamer/files/patch-Makefile.in
@@ -1,18 +1,18 @@
---- Makefile.in.orig 2009-10-19 00:06:14.000000000 +0200
-+++ Makefile.in 2009-10-19 00:07:47.000000000 +0200
-@@ -397,7 +397,6 @@ aclocaldir = $(datadir)/aclocal
+--- Makefile.in.orig 2012-02-20 22:48:34 UTC
++++ Makefile.in
+@@ -469,7 +469,6 @@ aclocaldir = $(datadir)/aclocal
aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
SUBDIRS = pkgconfig \
gst libs plugins tools tests \
- docs \
po \
+ m4 \
common
-
-@@ -405,7 +404,6 @@ SUBDIRS = pkgconfig \
+@@ -478,7 +477,6 @@ SUBDIRS = pkgconfig \
# These are all the possible subdirs
DIST_SUBDIRS = pkgconfig \
gst libs plugins tools tests \
- docs \
po \
+ m4 \
common
-
diff --git a/multimedia/gstreamer/files/patch-gst_gstdatetime.c b/multimedia/gstreamer/files/patch-gst_gstdatetime.c
index 8eac4d8c76d4..8695107ba03c 100644
--- a/multimedia/gstreamer/files/patch-gst_gstdatetime.c
+++ b/multimedia/gstreamer/files/patch-gst_gstdatetime.c
@@ -1,5 +1,5 @@
---- gst/gstdatetime.c.orig 2013-10-20 16:05:12.000000000 +0200
-+++ gst/gstdatetime.c 2013-10-20 16:05:24.000000000 +0200
+--- gst/gstdatetime.c.orig 2011-12-11 18:45:55 UTC
++++ gst/gstdatetime.c
@@ -21,8 +21,8 @@
#include "config.h"
#endif
@@ -8,5 +8,5 @@
#include "gst_private.h"
+#include "glib-compat-private.h"
#include "gstdatetime.h"
- #include "gstvalue.h"
#include <glib.h>
+ #include <math.h>
diff --git a/multimedia/gstreamer/files/patch-gst_parse_grammar.y b/multimedia/gstreamer/files/patch-gst_parse_grammar.y
new file mode 100644
index 000000000000..ddb13f70230f
--- /dev/null
+++ b/multimedia/gstreamer/files/patch-gst_parse_grammar.y
@@ -0,0 +1,18 @@
+--- gst/parse/grammar.y.orig 2011-12-30 01:14:35 UTC
++++ gst/parse/grammar.y
+@@ -26,7 +26,6 @@
+ */
+
+ #define YYERROR_VERBOSE 1
+-#define YYLEX_PARAM scanner
+
+ #define YYENABLE_NLS 0
+
+@@ -648,6 +647,7 @@ static int yyerror (void *scanner, graph
+ %right '.'
+ %left '!' '='
+
++%lex-param { void *scanner }
+ %parse-param { void *scanner }
+ %parse-param { graph_t *graph }
+ %pure-parser
diff --git a/multimedia/gstreamer/pkg-plist b/multimedia/gstreamer/pkg-plist
index 4c4e4061e586..a195d6e9a269 100644
--- a/multimedia/gstreamer/pkg-plist
+++ b/multimedia/gstreamer/pkg-plist
@@ -191,14 +191,3 @@ share/gir-1.0/GstNet-%%VERSION%%.gir
%%NLS%%share/locale/vi/LC_MESSAGES/gstreamer-%%VERSION%%.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/gstreamer-%%VERSION%%.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/gstreamer-%%VERSION%%.mo
-%%NLS%%@dirrmtry share/locale/rw/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/rw
-@dirrm libexec/gstreamer-%%VERSION%%
-@dirrm lib/gstreamer-%%VERSION%%
-@dirrm include/gstreamer-%%VERSION%%/gst/net
-@dirrm include/gstreamer-%%VERSION%%/gst/dataprotocol
-@dirrm include/gstreamer-%%VERSION%%/gst/controller
-%%CHECK%%@dirrm include/gstreamer-%%VERSION%%/gst/check
-@dirrm include/gstreamer-%%VERSION%%/gst/base
-@dirrm include/gstreamer-%%VERSION%%/gst
-@dirrm include/gstreamer-%%VERSION%%