aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-06-16 23:53:16 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-06-16 23:53:16 +0000
commit14d9f00be082b4a55e6ae0b306ee45fbdeb8635e (patch)
treecd297caddffb2f4d61ba0d2be0b4a7a5d5f0d38c
parent61eba97f8dc63baef1cef202f0cd16eb05f554ff (diff)
downloadports-14d9f00be082b4a55e6ae0b306ee45fbdeb8635e.tar.gz
ports-14d9f00be082b4a55e6ae0b306ee45fbdeb8635e.zip
Notes
-rw-r--r--net/dpdk/Makefile8
-rw-r--r--net/dpdk/distinfo6
-rw-r--r--net/dpdk/pkg-plist12
3 files changed, 16 insertions, 10 deletions
diff --git a/net/dpdk/Makefile b/net/dpdk/Makefile
index dcda6ec63207..15a70ef099af 100644
--- a/net/dpdk/Makefile
+++ b/net/dpdk/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= dpdk
-DISTVERSION= 19.11
-PORTREVISION= 2
+DISTVERSION= 19.11.2
CATEGORIES= net
MASTER_SITES= http://fast.dpdk.org/rel/
@@ -15,8 +14,10 @@ ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= Only works on 64-bit x86 hardware
LIB_DEPENDS= libjansson.so:devel/jansson
+BUILD_DEPENDS= objdump:devel/binutils
-USES= meson kmod shebangfix tar:xz
+USES= meson kmod pkgconfig shebangfix tar:xz python:3.5+
+WRKSRC= ${WRKDIR}/${PORTNAME}-stable-${PORTVERSION}
MESON_ARGS= -Dmachine=default -Ddefault_library=shared
USE_LDCONFIG= yes
SHEBANG_FILES= usertools/dpdk-pmdinfo.py \
@@ -42,6 +43,5 @@ DEBUG_MESON_ON= --buildtype=debug
DEBUG_MESON_OFF= --buildtype=release
TESTS_MESON_TRUE= tests
TOOLS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyelftools>=0:devel/py-pyelftools@${PY_FLAVOR}
-TOOLS_USES= python:3.5+
.include <bsd.port.mk>
diff --git a/net/dpdk/distinfo b/net/dpdk/distinfo
index 3f3efdd8fa10..1e970a2e395f 100644
--- a/net/dpdk/distinfo
+++ b/net/dpdk/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1575029584
-SHA256 (dpdk-19.11.tar.xz) = 467133968843677bb1c276bb74a3458aa7c002cc21e295c51e3bd65497b112ab
-SIZE (dpdk-19.11.tar.xz) = 12380984
+TIMESTAMP = 1589809964
+SHA256 (dpdk-19.11.2.tar.xz) = 6978c493eb3cc14aaa943b659e74531d7e66e213f36b82b66ccb1c9de4e444bb
+SIZE (dpdk-19.11.2.tar.xz) = 12398636
diff --git a/net/dpdk/pkg-plist b/net/dpdk/pkg-plist
index 0c3711a822f0..da401a644e78 100644
--- a/net/dpdk/pkg-plist
+++ b/net/dpdk/pkg-plist
@@ -14,6 +14,7 @@ bin/dpdk-test-eventdev
bin/dpdk-test-pipeline
bin/dpdk-test-sad
bin/dpdk-testpmd
+include/bpf_def.h
include/cmdline.h
include/cmdline_cirbuf.h
include/cmdline_parse.h
@@ -53,6 +54,8 @@ include/rte_bbdev_op.h
include/rte_bbdev_pmd.h
include/rte_bitmap.h
include/rte_bitrate.h
+include/rte_bpf.h
+include/rte_bpf_ethdev.h
include/rte_branch_prediction.h
include/rte_build_config.h
include/rte_bus.h
@@ -65,8 +68,6 @@ include/rte_byteorder_32.h
include/rte_byteorder_64.h
include/rte_cfgfile.h
include/rte_class.h
-include/rte_cmp_arm64.h
-include/rte_cmp_x86.h
include/rte_common.h
include/rte_comp.h
include/rte_compat.h
@@ -81,7 +82,6 @@ include/rte_crypto_asym.h
include/rte_crypto_sym.h
include/rte_cryptodev.h
include/rte_cryptodev_pmd.h
-include/rte_cuckoo_hash.h
include/rte_cycles.h
include/rte_debug.h
include/rte_dev.h
@@ -247,6 +247,9 @@ include/rte_table_lpm_ipv6.h
include/rte_table_stub.h
include/rte_tailq.h
include/rte_tcp.h
+include/rte_telemetry.h
+include/rte_telemetry_internal.h
+include/rte_telemetry_parser.h
include/rte_thash.h
include/rte_time.h
include/rte_timer.h
@@ -1003,6 +1006,9 @@ lib/librte_security.so.20.0
lib/librte_stack.a
lib/librte_stack.so
lib/librte_stack.so.0.200
+lib/librte_telemetry.a
+lib/librte_telemetry.so
+lib/librte_telemetry.so.0.200
lib/librte_table.a
lib/librte_table.so
lib/librte_table.so.20.0