aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-12-13 12:08:11 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-12-13 12:08:11 +0000
commit150fd09e009d4554b5d826ae722269c7edbe8f0a (patch)
tree86e6ce2f8ab0b208e99472a3a62dc11dc6af82cb
parentf975b7f849e72fee846f334f07675fc10e9a19fe (diff)
Notes
-rw-r--r--net-mgmt/flowviewer/Makefile44
-rw-r--r--net-mgmt/flowviewer/distinfo4
-rw-r--r--net-mgmt/flowviewer/files/patch-FlowViewer__Configuration.pm43
-rw-r--r--net-mgmt/flowviewer/pkg-plist66
4 files changed, 79 insertions, 78 deletions
diff --git a/net-mgmt/flowviewer/Makefile b/net-mgmt/flowviewer/Makefile
index 316536a97789..15f4ab315546 100644
--- a/net-mgmt/flowviewer/Makefile
+++ b/net-mgmt/flowviewer/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= flowviewer
-PORTVERSION= 4.3
+PORTVERSION= 4.5
CATEGORIES= net-mgmt
MASTER_SITES= SF/${PORTNAME}
DISTNAME= FlowViewer_${DISTVERSION}
@@ -27,23 +27,23 @@ FLOWVIEWERDIR?= ${PREFIX}/www/flowviewer
PLIST_SCRIPT= FV.cgi FV_Relay.cgi FlowGrapher.cgi FlowGrapher_Main.cgi \
FlowGrapher_Replay.cgi FlowGrapher_Sort.cgi \
- FlowTracker.cgi FlowTracker_Dashboard.cgi FlowTracker_Display.cgi \
- FlowTracker_DisplayPublic.cgi FlowTracker_Dumper.cgi \
- FlowTracker_Group.cgi FlowTracker_Main.cgi FlowTracker_Management.cgi \
- FlowTracker_Replay.cgi FlowViewer.cgi dscan.suppress.dst dscan.suppress.src \
+ FlowMonitor.cgi FlowMonitor_Dashboard.cgi FlowMonitor_Display.cgi \
+ FlowMonitor_DisplayPublic.cgi FlowMonitor_Dumper.cgi \
+ FlowMonitor_Group.cgi FlowMonitor_Main.cgi FlowMonitor_Management.cgi \
+ FlowMonitor_Replay.cgi FlowViewer.cgi dscan.suppress.dst dscan.suppress.src \
FlowViewer_Main.cgi FlowViewer_Replay.cgi \
FlowViewer_Save.cgi FlowViewer_SaveManage.cgi FlowViewer_Sort.cgi \
FlowViewer_UI.pm FlowViewer_Utilities.pm FlowGrapher_Colors \
- FlowTracker_AltDashboard FlowTracker_Collector FlowTracker_Grapher \
- FlowTracker_Recreate FlowTracker_Thumbnail FlowViewer_CleanASCache \
+ FlowMonitor_Collector FlowMonitor_Grapher \
+ FlowMonitor_Recreate FlowMonitor_Thumbnail FlowViewer_CleanASCache \
FlowViewer_CleanFiles FlowViewer_CleanHostCache FlowViewer_CleanSiLK \
NamedInterfaces_Devices NamedInterfaces_Exporters
-PLIST_DATA= FG_button.png FT_button.png FV_button.png FlowViewer.css
-PLIST_TOOLS= flowcapture_restart resize_rrdtools flowtracker_grapher_nonlazy \
- date_to_epoch_gm performance_check flowtracker_restart \
- convert_pre40_filters analyze_flowtracker_debug flowtracker_grapher_recent \
- flow-capture-table.conf rsync_trackings epoch_to_date_local rwflowpack_start \
- epoch_to_date_gm rsync_htmls flowtracker_archive_restore \
+PLIST_DATA= FG_button.png FM_button.png FV_button.png FlowViewer.css
+PLIST_TOOLS= flowcapture_restart resize_rrdtools flowmonitor_grapher_nonlazy \
+ date_to_epoch_gm performance_check flowmonitor_restart \
+ convert_pre40_filters analyze_flowmonitor_debug flowmonitor_grapher_recent \
+ flow-capture-table.conf rsync_monitors epoch_to_date_local rwflowpack_start \
+ epoch_to_date_gm rsync_htmls flowmonitor_archive_restore \
date_to_epoch_local analyze_netflow_packets rsync_flows
PLIST_SUB+= FLOWVIEWERDIR="${FLOWVIEWERDIR}" \
@@ -58,7 +58,6 @@ NO_BUILD= yes
PORTDOCS= README
-.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -E \
-e "s|%%PREFIX%%|${PREFIX}|" \
@@ -71,23 +70,20 @@ do-install:
${MKDIR} ${STAGEDIR}${FLOWVIEWERDIR}
${MKDIR} ${STAGEDIR}${FLOWVIEWERDIR}/tools
${INSTALL_DATA} ${WRKSRC}/FlowViewer_Configuration.pm ${STAGEDIR}${FLOWVIEWERDIR}/FlowViewer_Configuration.pm.dist
- ${MKDIR} ${STAGEDIR}${FLOWVIEWERDIR}/tmp ${STAGEDIR}${FLOWVIEWERDIR}/reports \
- ${STAGEDIR}${FLOWVIEWERDIR}/graphs ${STAGEDIR}${FLOWVIEWERDIR}/tracker ${STAGEDIR}${FLOWVIEWERDIR}/working \
- ${STAGEDIR}${FLOWVIEWERDIR}/saves ${STAGEDIR}${FLOWVIEWERDIR}/names ${STAGEDIR}${FLOWVIEWERDIR}/filters \
+ ${MKDIR} ${STAGEDIR}${FLOWVIEWERDIR}/tmp ${STAGEDIR}${FLOWVIEWERDIR}/reports ${STAGEDIR}${FLOWVIEWERDIR}/graphs \
+ ${STAGEDIR}${FLOWVIEWERDIR}/monitor ${STAGEDIR}${FLOWVIEWERDIR}/working ${STAGEDIR}${FLOWVIEWERDIR}/saves \
+ ${STAGEDIR}${FLOWVIEWERDIR}/names ${STAGEDIR}${FLOWVIEWERDIR}/ipsets ${STAGEDIR}${FLOWVIEWERDIR}/filters \
${STAGEDIR}${FLOWVIEWERDIR}/rrdtools ${STAGEDIR}${FLOWVIEWERDIR}/FlowViewer_Dashboard
.for i in ${PLIST_SCRIPT}
- @${INSTALL_SCRIPT} ${WRKSRC}/${i} ${STAGEDIR}${FLOWVIEWERDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${i} ${STAGEDIR}${FLOWVIEWERDIR}
.endfor
.for i in ${PLIST_TOOLS}
- @${INSTALL_SCRIPT} ${WRKSRC}/tools/${i} ${STAGEDIR}${FLOWVIEWERDIR}/tools
+ ${INSTALL_SCRIPT} ${WRKSRC}/tools/${i} ${STAGEDIR}${FLOWVIEWERDIR}/tools
.endfor
.for i in ${PLIST_DATA}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${FLOWVIEWERDIR}/reports
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${FLOWVIEWERDIR}/reports
.endfor
-
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/net-mgmt/flowviewer/distinfo b/net-mgmt/flowviewer/distinfo
index 16406d0ae6a6..c831626bffa9 100644
--- a/net-mgmt/flowviewer/distinfo
+++ b/net-mgmt/flowviewer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (FlowViewer_4.3.tar) = 740086dbf4b70aed625c650caddd4c010ea49d035253165b6087f2c12dc9188a
-SIZE (FlowViewer_4.3.tar) = 1024000
+SHA256 (FlowViewer_4.5.tar) = c06b778bcfea55f8fff0c2d78fa0ed41137e41d37f00254674018f54b00e76ce
+SIZE (FlowViewer_4.5.tar) = 1443840
diff --git a/net-mgmt/flowviewer/files/patch-FlowViewer__Configuration.pm b/net-mgmt/flowviewer/files/patch-FlowViewer__Configuration.pm
index 434fef37c67e..a458c048bb3c 100644
--- a/net-mgmt/flowviewer/files/patch-FlowViewer__Configuration.pm
+++ b/net-mgmt/flowviewer/files/patch-FlowViewer__Configuration.pm
@@ -1,6 +1,6 @@
---- FlowViewer_Configuration.pm.orig 2014-02-24 17:44:27.000000000 +0400
-+++ FlowViewer_Configuration.pm 2014-02-24 17:54:45.000000000 +0400
-@@ -56,31 +56,31 @@
+--- FlowViewer_Configuration.pm.orig 2014-11-10 11:04:45.000000000 +0300
++++ FlowViewer_Configuration.pm 2014-11-10 11:25:39.000000000 +0300
+@@ -64,36 +64,36 @@
# Service
@@ -13,33 +13,40 @@
-$reports_short = "/FlowViewer";
-$graphs_directory = "/var/www/html/FlowGrapher";
-$graphs_short = "/FlowGrapher";
--$tracker_directory = "/var/www/html/FlowTracker";
--$tracker_short = "/FlowTracker";
--$cgi_bin_directory = "/var/www/cgi-bin/FlowViewer_4.3";
--$cgi_bin_short = "/cgi-bin/FlowViewer_4.3";
--$work_directory = "/var/www/cgi-bin/FlowViewer_4.3/Flow_Working";
+-$monitor_directory = "/var/www/html/FlowMonitor";
+-$monitor_short = "/FlowMonitor";
+-$cgi_bin_directory = "/var/www/cgi-bin/FlowViewer_4.5";
+-$cgi_bin_short = "/cgi-bin/FlowViewer_4.5";
+-$work_directory = "/var/www/cgi-bin/FlowViewer_4.5/Flow_Working";
-$save_directory = "/var/www/html/FlowViewer_Saves";
-$save_short = "/FlowViewer_Saves";
--$names_directory = "/var/www/cgi-bin/FlowViewer_4.3";
--$filter_directory = "/var/www/cgi-bin/FlowTracker_Files/FlowTracker_Filters";
--$rrdtool_directory = "/var/www/cgi-bin/FlowTracker_Files/FlowTracker_RRDtool";
+-$names_directory = "/var/www/cgi-bin/FlowViewer_4.5";
+-$ipset_directory = "/var/www/cgi-bin/FlowViewer_4.5"; # Where FlowViewer can find IPset files
+-$filter_directory = "/var/www/cgi-bin/FlowMonitor_Files/FlowMonitor_Filters";
+-$rrdtool_directory = "/var/www/cgi-bin/FlowMonitor_Files/FlowMonitor_RRDtool";
-$dashboard_directory = "/var/www/html/FlowViewer_Dashboard";
+$reports_directory = "%%FLOWVIEWERDIR%%/reports";
+$reports_short = "/FlowViewer/reports";
+$graphs_directory = "%%FLOWVIEWERDIR%%/graphs";
+$graphs_short = "/FlowViewer/graphs";
-+$tracker_directory = "%%FLOWVIEWERDIR%%/tracker";
-+$tracker_short = "/FlowViewer/tracker";
++$monitor_directory = "%%FLOWVIEWERDIR%%/monitor";
++$monitor_short = "/FlowMonitor/monitor";
+$cgi_bin_directory = "%%FLOWVIEWERDIR%%";
+$cgi_bin_short = "/FlowViewer";
+$work_directory = "%%FLOWVIEWERDIR%%/working";
+$save_directory = "%%FLOWVIEWERDIR%%/saves";
+$save_short = "/FlowViewer/saves";
+$names_directory = "%%FLOWVIEWERDIR%%/names";
++$ipset_directory = "%%FLOWVIEWERDIR%%/ipsets"; # Where FlowViewer can find IPset files
+$filter_directory = "%%FLOWVIEWERDIR%%/filters";
+$rrdtool_directory = "%%FLOWVIEWERDIR%%/rrdtools";
+$dashboard_directory = "%%FLOWVIEWERDIR%%/FlowViewer_Dashboard";
$dashboard_short = "/FlowViewer_Dashboard";
+ #@other_dashboards = (); # Set to empty if you have just the one nominal Dashboard
+-@other_dashboards = ("/var/www/html/SOC","/var/www/html/NetOps");
++@other_dashboards = ("%%FLOWVIEWERDIR%%/SOC","%%FLOWVIEWERDIR%%/NetOps");
+ #@dashboard_titles = (); # Set to empty if you have just the one nominal Dashboard
+ @dashboard_titles = ("Performance","SOC","NetOps"); # titles must be in the same order as the directories
-$flow_data_directory = "/data/flows";
-$exporter_directory = "/data/flows/all_routers";
@@ -50,13 +57,13 @@
+$flow_bin_directory = "%%PREFIX%%/bin";
+$rrdtool_bin_directory = "%%PREFIX%%/bin";
- $silk_data_directory = "/data/flows";
- $silk_bin_directory = "/usr/local/bin";
-@@ -167,7 +167,7 @@
- # Tracking parameters
+ # SiLK parameters
+
+@@ -207,7 +207,7 @@
+ # Monitor parameters
$actives_webpage = "index.html";
--$log_directory = "/var/www/cgi-bin/FlowViewer_4.3/logs";
+-$log_directory = "/var/www/cgi-bin/FlowViewer_4.5/logs";
+$log_directory = "%%FLOWVIEWERDIR%%/logs";
$log_collector_short= "Y";
$log_collector_med = "N";
diff --git a/net-mgmt/flowviewer/pkg-plist b/net-mgmt/flowviewer/pkg-plist
index 53df695e4caa..1825a9d96bfb 100644
--- a/net-mgmt/flowviewer/pkg-plist
+++ b/net-mgmt/flowviewer/pkg-plist
@@ -5,20 +5,19 @@
%%FLOWVIEWERDIR%%/FlowGrapher_Main.cgi
%%FLOWVIEWERDIR%%/FlowGrapher_Replay.cgi
%%FLOWVIEWERDIR%%/FlowGrapher_Sort.cgi
-%%FLOWVIEWERDIR%%/FlowTracker.cgi
-%%FLOWVIEWERDIR%%/FlowTracker_AltDashboard
-%%FLOWVIEWERDIR%%/FlowTracker_Collector
-%%FLOWVIEWERDIR%%/FlowTracker_Dashboard.cgi
-%%FLOWVIEWERDIR%%/FlowTracker_Display.cgi
-%%FLOWVIEWERDIR%%/FlowTracker_DisplayPublic.cgi
-%%FLOWVIEWERDIR%%/FlowTracker_Dumper.cgi
-%%FLOWVIEWERDIR%%/FlowTracker_Grapher
-%%FLOWVIEWERDIR%%/FlowTracker_Group.cgi
-%%FLOWVIEWERDIR%%/FlowTracker_Main.cgi
-%%FLOWVIEWERDIR%%/FlowTracker_Management.cgi
-%%FLOWVIEWERDIR%%/FlowTracker_Recreate
-%%FLOWVIEWERDIR%%/FlowTracker_Replay.cgi
-%%FLOWVIEWERDIR%%/FlowTracker_Thumbnail
+%%FLOWVIEWERDIR%%/FlowMonitor.cgi
+%%FLOWVIEWERDIR%%/FlowMonitor_Collector
+%%FLOWVIEWERDIR%%/FlowMonitor_Dashboard.cgi
+%%FLOWVIEWERDIR%%/FlowMonitor_Display.cgi
+%%FLOWVIEWERDIR%%/FlowMonitor_DisplayPublic.cgi
+%%FLOWVIEWERDIR%%/FlowMonitor_Dumper.cgi
+%%FLOWVIEWERDIR%%/FlowMonitor_Grapher
+%%FLOWVIEWERDIR%%/FlowMonitor_Group.cgi
+%%FLOWVIEWERDIR%%/FlowMonitor_Main.cgi
+%%FLOWVIEWERDIR%%/FlowMonitor_Management.cgi
+%%FLOWVIEWERDIR%%/FlowMonitor_Recreate
+%%FLOWVIEWERDIR%%/FlowMonitor_Replay.cgi
+%%FLOWVIEWERDIR%%/FlowMonitor_Thumbnail
%%FLOWVIEWERDIR%%/FlowViewer.cgi
%%FLOWVIEWERDIR%%/FlowViewer_CleanASCache
%%FLOWVIEWERDIR%%/FlowViewer_CleanFiles
@@ -36,7 +35,7 @@
%%FLOWVIEWERDIR%%/NamedInterfaces_Exporters
%%FLOWVIEWERDIR%%/dscan.suppress.dst
%%FLOWVIEWERDIR%%/dscan.suppress.src
-%%FLOWVIEWERDIR%%/tools/analyze_flowtracker_debug
+%%FLOWVIEWERDIR%%/tools/analyze_flowmonitor_debug
%%FLOWVIEWERDIR%%/tools/analyze_netflow_packets
%%FLOWVIEWERDIR%%/tools/convert_pre40_filters
%%FLOWVIEWERDIR%%/tools/date_to_epoch_gm
@@ -45,30 +44,29 @@
%%FLOWVIEWERDIR%%/tools/epoch_to_date_local
%%FLOWVIEWERDIR%%/tools/flow-capture-table.conf
%%FLOWVIEWERDIR%%/tools/flowcapture_restart
-%%FLOWVIEWERDIR%%/tools/flowtracker_archive_restore
-%%FLOWVIEWERDIR%%/tools/flowtracker_grapher_nonlazy
-%%FLOWVIEWERDIR%%/tools/flowtracker_grapher_recent
-%%FLOWVIEWERDIR%%/tools/flowtracker_restart
+%%FLOWVIEWERDIR%%/tools/flowmonitor_archive_restore
+%%FLOWVIEWERDIR%%/tools/flowmonitor_grapher_nonlazy
+%%FLOWVIEWERDIR%%/tools/flowmonitor_grapher_recent
+%%FLOWVIEWERDIR%%/tools/flowmonitor_restart
%%FLOWVIEWERDIR%%/tools/performance_check
%%FLOWVIEWERDIR%%/tools/resize_rrdtools
%%FLOWVIEWERDIR%%/tools/rsync_flows
%%FLOWVIEWERDIR%%/tools/rsync_htmls
-%%FLOWVIEWERDIR%%/tools/rsync_trackings
+%%FLOWVIEWERDIR%%/tools/rsync_monitors
%%FLOWVIEWERDIR%%/tools/rwflowpack_start
%%FLOWVIEWERDIR%%/reports/FG_button.png
-%%FLOWVIEWERDIR%%/reports/FT_button.png
+%%FLOWVIEWERDIR%%/reports/FM_button.png
%%FLOWVIEWERDIR%%/reports/FV_button.png
%%FLOWVIEWERDIR%%/reports/FlowViewer.css
-@exec /usr/sbin/chown %%WWWOWN%%:%%WWWGRP%% %%FLOWVIEWERDIR%%/tmp %%FLOWVIEWERDIR%%/reports %%FLOWVIEWERDIR%%/graphs %%FLOWVIEWERDIR%%/tracker %%FLOWVIEWERDIR%%/working %%FLOWVIEWERDIR%%/saves %%FLOWVIEWERDIR%%/names %%FLOWVIEWERDIR%%/filters %%FLOWVIEWERDIR%%/rrdtools %%FLOWVIEWERDIR%%/FlowViewer_Dashboard %%FLOWVIEWERDIR%%/tools
-@dirrmtry %%FLOWVIEWERDIR%%/working
-@dirrmtry %%FLOWVIEWERDIR%%/tracker
-@dirrmtry %%FLOWVIEWERDIR%%/tools
-@dirrmtry %%FLOWVIEWERDIR%%/tmp
-@dirrmtry %%FLOWVIEWERDIR%%/saves
-@dirrmtry %%FLOWVIEWERDIR%%/rrdtools
-@dirrmtry %%FLOWVIEWERDIR%%/reports
-@dirrmtry %%FLOWVIEWERDIR%%/names
-@dirrmtry %%FLOWVIEWERDIR%%/graphs
-@dirrmtry %%FLOWVIEWERDIR%%/filters
-@dirrmtry %%FLOWVIEWERDIR%%/FlowViewer_Dashboard
-@dirrmtry %%FLOWVIEWERDIR%%
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%FLOWVIEWERDIR%%/FlowViewer_Dashboard
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%FLOWVIEWERDIR%%/filters
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%FLOWVIEWERDIR%%/graphs
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%FLOWVIEWERDIR%%/ipsets
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%FLOWVIEWERDIR%%/monitor
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%FLOWVIEWERDIR%%/names
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%FLOWVIEWERDIR%%/reports
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%FLOWVIEWERDIR%%/rrdtools
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%FLOWVIEWERDIR%%/saves
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%FLOWVIEWERDIR%%/tmp
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%FLOWVIEWERDIR%%/tools
+@dir(%%WWWOWN%%,%%WWWGRP%%,) %%FLOWVIEWERDIR%%/working