aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-06-23 09:57:27 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-06-23 09:57:27 +0000
commit15128d1d3830e89012358f0a9561882354a8ee1c (patch)
treea901f9eed61205f88ec46494aa0491ba2b552eca
parent052583226dc66540bc7f349f292b84a3484ff274 (diff)
downloadports-15128d1d3830e89012358f0a9561882354a8ee1c.tar.gz
ports-15128d1d3830e89012358f0a9561882354a8ee1c.zip
Remove the IGNOREFILES feature: it was an unsafe feature allowing to use files
fetched from untrusted sources directly into the ports tree CR: D269 Reviewed by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=358915
-rw-r--r--CHANGES7
-rw-r--r--Mk/bsd.port.mk64
2 files changed, 7 insertions, 64 deletions
diff --git a/CHANGES b/CHANGES
index 0079721b0b4a..a4dbf6cb46d6 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,13 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20140623:
+AUTHOR: bapt@FreeBSD.org
+
+ IGNOREFILES is not supported anymore, it was an unsafe feature allowing to
+ use unchecked files downloaded from untrusted places to be used in the ports
+ tree.
+
20140607:
AUTHOR: mva@FreeBSD.org
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 7c35083336b1..5fe97ab7560d 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -122,7 +122,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# ${DISTDIR} (see below). Also they will be fetched in this
# subdirectory from FreeBSD mirror sites.
# ALLFILES - All of ${DISTFILES} and ${PATCHFILES}.
-# IGNOREFILES - If set, don't perform checksum checks on these files.
# NOFETCHFILES - If set, don't download these files from the ${MASTER_SITES}
# or ${MASTER_SITE_BACKUP} (but do from
# ${MASTER_SITE_OVERRIDE})
@@ -2683,30 +2682,15 @@ patch-sites-default: patch-sites-DEFAULT
master-sites: master-sites-DEFAULT
patch-sites: patch-sites-DEFAULT
-.if defined(IGNOREFILES)
-.if !defined(CKSUMFILES)
-. for _f in ${ALLFILES}
-. if ! ${IGNOREFILES:M${_f}}
-CKSUMFILES+= ${_f}
-. endif
-. endfor
-. undef _f
-.endif
-.else
CKSUMFILES= ${ALLFILES}
-.endif
# List of all files, with ${DIST_SUBDIR} in front. Used for checksum.
.if defined(DIST_SUBDIR)
.if defined(CKSUMFILES) && ${CKSUMFILES}!=""
_CKSUMFILES?= ${CKSUMFILES:S/^/${DIST_SUBDIR}\//}
.endif
-.if defined(IGNOREFILES) && ${IGNOREFILES}!=""
-_IGNOREFILES?= ${IGNOREFILES:S/^/${DIST_SUBDIR}\//}
-.endif
.else
_CKSUMFILES?= ${CKSUMFILES}
-_IGNOREFILES?= ${IGNOREFILES}
.endif
# This is what is actually going to be extracted, and is overridable
@@ -4678,11 +4662,6 @@ makesum: check-checksum-algorithms
${ECHO_CMD} "SIZE ($$file) = `${STAT} -f \"%z\" $$file`" >> ${DISTINFO_FILE}; \
done \
)
- @for file in ${_IGNOREFILES}; do \
- for alg in ${CHECKSUM_ALGORITHMS:tu}; do \
- ${ECHO_CMD} "$$alg ($$file) = IGNORE" >> ${DISTINFO_FILE}; \
- done; \
- done
.endif
.if !target(checksum)
@@ -4710,13 +4689,6 @@ checksum: fetch check-checksum-algorithms
ignore="true"; \
fi; \
\
- if [ "$$CKSUM" = "IGNORE" ]; then \
- ${ECHO_MSG} "=> $$alg Checksum for $$file is set to IGNORE in distinfo file even though"; \
- ${ECHO_MSG} " the file is not in the "'$$'"{IGNOREFILES} list."; \
- ignore="true"; \
- OK=${FALSE}; \
- fi; \
- \
if [ $$ignore = "false" ]; then \
match="false"; \
for chksum in $$CKSUM; do \
@@ -4745,42 +4717,6 @@ checksum: fetch check-checksum-algorithms
\
done; \
\
- for file in ${_IGNOREFILES}; do \
- _file=$${file#${DIST_SUBDIR}/*}; \
- ignored="true"; \
- alreadymatched="false"; \
- for alg in ${CHECKSUM_ALGORITHMS:tu}; do \
- ignore="false"; \
- eval alg_executable=\$$$$alg; \
- \
- if [ $$alg_executable != "NO" ]; then \
- CKSUM=`file=$$_file; ${DISTINFO_DATA}`; \
- else \
- ignore="true"; \
- fi; \
- \
- if [ $$ignore = "false" ]; then \
- if [ -z "$$CKSUM" ]; then \
- ${ECHO_MSG} "=> No $$alg checksum for $$file recorded (expected IGNORE)"; \
- OK="$$alreadymatched"; \
- elif [ $$CKSUM != "IGNORE" ]; then \
- ${ECHO_MSG} "=> $$alg Checksum for $$file is not set to IGNORE in distinfo file even though"; \
- ${ECHO_MSG} " the file is in the "'$$'"{IGNOREFILES} list."; \
- OK="false"; \
- else \
- ignored="false"; \
- alreadymatched="true"; \
- fi; \
- fi; \
- done; \
- \
- if ( [ $$ignored = "true" ]) ; then \
- ${ECHO_MSG} "=> No suitable checksum found for $$file."; \
- OK="false"; \
- fi; \
- \
- done; \
- \
if [ "$${OK:=true}" = "retry" ] && [ ${FETCH_REGET} -gt 0 ]; then \
${ECHO_MSG} "===> Refetch for ${FETCH_REGET} more times files: $$refetchlist"; \
if ( cd ${.CURDIR} && \