aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-11 09:54:08 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-11 09:54:08 +0000
commit1539e0886b8834f28f81afd6d906ca66f87d6449 (patch)
tree3137ade6fc7774f2edb5f66cdd2d06373d9fe493
parentb38bbaec1f3a42489de4507d108ceb14d8164ea4 (diff)
downloadports-1539e0886b8834f28f81afd6d906ca66f87d6449.tar.gz
ports-1539e0886b8834f28f81afd6d906ca66f87d6449.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
Notes
Notes: svn path=/head/; revision=326958
-rw-r--r--audio/crip/Makefile8
-rw-r--r--audio/mp3burn/Makefile2
-rw-r--r--audio/ogg2mp3/Makefile7
-rw-r--r--audio/p5-Audio-Ecasound/Makefile8
-rw-r--r--audio/p5-Audio-MPD-Common/Makefile3
-rw-r--r--audio/p5-MP3-Find/Makefile9
-rw-r--r--audio/p5-MP3-Info/Makefile9
-rw-r--r--audio/p5-MP3-Tag/Makefile9
-rw-r--r--audio/p5-Music-Audioscrobbler-MPD/Makefile9
-rw-r--r--audio/p5-Music-Audioscrobbler-Submit/Makefile9
-rw-r--r--audio/p5-Ogg-Vorbis-Header-PurePerl/Makefile9
-rw-r--r--graphics/fotofix/Makefile9
-rw-r--r--graphics/p5-Convert-Color/Makefile3
-rw-r--r--graphics/p5-Geo-EOP/Makefile9
-rw-r--r--graphics/p5-Geo-GML/Makefile9
-rw-r--r--graphics/p5-Geo-Gpx/Makefile9
-rw-r--r--graphics/p5-Image-Grab/Makefile9
-rw-r--r--graphics/p5-Image-Size/Makefile3
-rw-r--r--x11-fm/p5-PerlFM/Makefile9
19 files changed, 49 insertions, 93 deletions
diff --git a/audio/crip/Makefile b/audio/crip/Makefile
index 13528a131280..3e5e0134a526 100644
--- a/audio/crip/Makefile
+++ b/audio/crip/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: crip
-# Date created: 30 June 2003
-# Whom: Philip Paeps <philip@paeps.cx>
-#
+# Created by: Philip Paeps <philip@paeps.cx>
# $FreeBSD$
-#
PORTNAME= crip
PORTVERSION= 3.9
@@ -28,7 +24,7 @@ PORTDOCS= Changelog README criprc_example
.endif
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
pre-fetch:
.if !defined (WITH_SOX)
diff --git a/audio/mp3burn/Makefile b/audio/mp3burn/Makefile
index 587a56903c0f..3dc6dd14da35 100644
--- a/audio/mp3burn/Makefile
+++ b/audio/mp3burn/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123 \
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BZIP2= yes
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
PLIST_FILES= bin/mp3burn
diff --git a/audio/ogg2mp3/Makefile b/audio/ogg2mp3/Makefile
index a5c6b05844f3..3699bcf54886 100644
--- a/audio/ogg2mp3/Makefile
+++ b/audio/ogg2mp3/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: ogg2mp3
-# Date created: 26 Jun 2005
-# Whom: Aleksander Fafula <alex@bsdguru.org>
-#
+# Created by: Aleksander Fafula <alex@bsdguru.org>
# $FreeBSD$
PORTNAME= ogg2mp3
@@ -19,7 +16,7 @@ RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
NO_BUILD= yes
USE_BZIP2= yes
-USE_PERL5= yes
+USES= perl5
PLIST_FILES= bin/ogg2mp3
diff --git a/audio/p5-Audio-Ecasound/Makefile b/audio/p5-Audio-Ecasound/Makefile
index 5d4ab4fc0312..e866d9089bc8 100644
--- a/audio/p5-Audio-Ecasound/Makefile
+++ b/audio/p5-Audio-Ecasound/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Audio::Ecasound
-# Date created: 20 Nov 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Audio-Ecasound
PORTVERSION= 1.01
@@ -16,7 +11,8 @@ COMMENT= Perl extension for ecasound sampler, recorder, fx-processor
BUILD_DEPENDS= libecasoundc-config:${PORTSDIR}/audio/ecasound
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Audio::Ecasound.3
diff --git a/audio/p5-Audio-MPD-Common/Makefile b/audio/p5-Audio-MPD-Common/Makefile
index 90a3eb73ca2d..d0fe50c4188b 100644
--- a/audio/p5-Audio-MPD-Common/Makefile
+++ b/audio/p5-Audio-MPD-Common/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Moose>=0.92:${PORTSDIR}/devel/p5-Moose \
p5-String-Formatter>=0:${PORTSDIR}/devel/p5-String-Formatter
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Audio::MPD::Common.3 \
Audio::MPD::Common::Item.3 \
diff --git a/audio/p5-MP3-Find/Makefile b/audio/p5-MP3-Find/Makefile
index c75ea71a7f32..82b381fd875f 100644
--- a/audio/p5-MP3-Find/Makefile
+++ b/audio/p5-MP3-Find/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-MP3-Find
-# Date created: 2006-07-12
-# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
-#
+# Created by: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
# $FreeBSD$
-#
PORTNAME= MP3-Find
PORTVERSION= 0.07
@@ -17,7 +13,8 @@ COMMENT= Search and sort MP3 files based on their ID3 tags
BUILD_DEPENDS= p5-MP3-Info>=0:${PORTSDIR}/audio/p5-MP3-Info
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= mp3db.1 mp3find.1
MAN3= MP3::Find.3 \
diff --git a/audio/p5-MP3-Info/Makefile b/audio/p5-MP3-Info/Makefile
index 34c55eacc250..e6addeedfff5 100644
--- a/audio/p5-MP3-Info/Makefile
+++ b/audio/p5-MP3-Info/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-MP3-Info
-# Date created: 14-Aug-2000
-# Whom: Leo Kim <leo@florida.sarang.net>
-#
+# Created by: Leo Kim <leo@florida.sarang.net>
# $FreeBSD$
-#
PORTNAME= MP3-Info
PORTVERSION= 1.24
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Manipulate / fetch info from MP3 audio files
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MP3::Info.3
diff --git a/audio/p5-MP3-Tag/Makefile b/audio/p5-MP3-Tag/Makefile
index 364feecb653a..c5ba656a1987 100644
--- a/audio/p5-MP3-Tag/Makefile
+++ b/audio/p5-MP3-Tag/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-MP3-Tag
-# Date created: 7 Feb 2005
-# Whom: Roman Bogorodskiy
-#
+# Created by: Roman Bogorodskiy
# $FreeBSD$
-#
PORTNAME= MP3-Tag
PORTVERSION= 1.13
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= novel@FreeBSD.org
COMMENT= Module for reading tags of MP3 audio files
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= audio_rename.1 typeset_audio_dir.1 mp3info2.1
MAN3= MP3::Tag.3 MP3::Tag::ID3v1.3 MP3::Tag::File.3 \
diff --git a/audio/p5-Music-Audioscrobbler-MPD/Makefile b/audio/p5-Music-Audioscrobbler-MPD/Makefile
index c639b171e28c..5efac4c8c4b3 100644
--- a/audio/p5-Music-Audioscrobbler-MPD/Makefile
+++ b/audio/p5-Music-Audioscrobbler-MPD/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Music-Audioscrobbler-MPD
-# Date created: 2008-09-15
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Music-Audioscrobbler-MPD
PORTVERSION= 0.13
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-Proc-Daemon>=0:${PORTSDIR}/devel/p5-Proc-Daemon \
RUN_DEPENDS:= p5-Proc-Daemon>=0:${PORTSDIR}/devel/p5-Proc-Daemon \
p5-Music-Audioscrobbler-Submit>=0.05:${PORTSDIR}/audio/p5-Music-Audioscrobbler-Submit
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= musicmpdscrobble.1
MAN3= Music::Audioscrobbler::MPD.3
diff --git a/audio/p5-Music-Audioscrobbler-Submit/Makefile b/audio/p5-Music-Audioscrobbler-Submit/Makefile
index 7c1fd906018f..24f8108abf27 100644
--- a/audio/p5-Music-Audioscrobbler-Submit/Makefile
+++ b/audio/p5-Music-Audioscrobbler-Submit/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Music-Audioscrobbler-Submit
-# Date created: 2008-09-15
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Music-Audioscrobbler-Submit
PORTVERSION= 0.05
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
RUN_DEPENDS:= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Config-Options>=0.8:${PORTSDIR}/devel/p5-Config-Options
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Music::Audioscrobbler::Submit.3
diff --git a/audio/p5-Ogg-Vorbis-Header-PurePerl/Makefile b/audio/p5-Ogg-Vorbis-Header-PurePerl/Makefile
index 9cde01c66898..8dada4db9d4c 100644
--- a/audio/p5-Ogg-Vorbis-Header-PurePerl/Makefile
+++ b/audio/p5-Ogg-Vorbis-Header-PurePerl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Ogg-Vorbis-Header-PurePerl
-# Date created: 2007-09-10
-# Whom: Dominique Goncalves <dominique.goncalves@gmail.com>
-#
+# Created by: Dominique Goncalves <dominique.goncalves@gmail.com>
# $FreeBSD$
-#
PORTNAME= Ogg-Vorbis-Header-PurePerl
PORTVERSION= 1.0
@@ -19,7 +15,8 @@ COMMENT= Manipulate / fetch info from Ogg-Vorbis audio files
LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg \
vorbis:${PORTSDIR}/audio/libvorbis
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Ogg::Vorbis::Header::PurePerl.3
diff --git a/graphics/fotofix/Makefile b/graphics/fotofix/Makefile
index dff584ce1eb9..ec6aa972997e 100644
--- a/graphics/fotofix/Makefile
+++ b/graphics/fotofix/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fotofix
-# Date created: 7 August 2007
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= fotofix
PORTVERSION= 0.01.1.79
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-Prima>=1.21:${PORTSDIR}/x11-toolkits/p5-Prima \
IPA>=1.03:${PORTSDIR}/graphics/IPA
USE_BZIP2= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
PLIST_FILES= bin/${PORTNAME}
diff --git a/graphics/p5-Convert-Color/Makefile b/graphics/p5-Convert-Color/Makefile
index 5b1aadd177c6..a47b0011bef0 100644
--- a/graphics/p5-Convert-Color/Makefile
+++ b/graphics/p5-Convert-Color/Makefile
@@ -13,7 +13,8 @@ RUN_DEPENDS= \
p5-List-UtilsBy>0:${PORTSDIR}/devel/p5-List-UtilsBy
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Convert::Color.3 \
Convert::Color::CMY.3 \
diff --git a/graphics/p5-Geo-EOP/Makefile b/graphics/p5-Geo-EOP/Makefile
index 38ea3bc841d7..cd1ef22662e1 100644
--- a/graphics/p5-Geo-EOP/Makefile
+++ b/graphics/p5-Geo-EOP/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Geo-EOP
-# Date created: 23 January 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Geo-EOP
PORTVERSION= 0.13
@@ -22,6 +18,7 @@ RUN_DEPENDS= p5-Geo-GML>=0.12:${PORTSDIR}/graphics/p5-Geo-GML \
MAN3= Geo::EOP::Util.3 Geo::EOP.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/graphics/p5-Geo-GML/Makefile b/graphics/p5-Geo-GML/Makefile
index dfff3c94c971..25462c926568 100644
--- a/graphics/p5-Geo-GML/Makefile
+++ b/graphics/p5-Geo-GML/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Geo-GML
-# Date created: 11 January 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Geo-GML
PORTVERSION= 0.15
@@ -22,6 +18,7 @@ RUN_DEPENDS= p5-Log-Report>=0.18:${PORTSDIR}/devel/p5-Log-Report \
MAN3= Geo::GML.3 Geo::GML::Util.3 Geo::GML::GeoPoint.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/graphics/p5-Geo-Gpx/Makefile b/graphics/p5-Geo-Gpx/Makefile
index 24142acf5caf..cbff713d5c8b 100644
--- a/graphics/p5-Geo-Gpx/Makefile
+++ b/graphics/p5-Geo-Gpx/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Geo-Gpx
-# Date created: 10 March 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Geo-Gpx
PORTVERSION= 0.26
@@ -26,6 +22,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Geo::Gpx.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/graphics/p5-Image-Grab/Makefile b/graphics/p5-Image-Grab/Makefile
index 88514a8461aa..c7de8befc34f 100644
--- a/graphics/p5-Image-Grab/Makefile
+++ b/graphics/p5-Image-Grab/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Image-Grab
-# Date created: 8 April 2001
-# Whom: Anatoliy Dmytriyev <tolid@plab.ku.dk>
-#
+# Created by: Anatoliy Dmytriyev <tolid@plab.ku.dk>
# $FreeBSD$
-#
PORTNAME= Image-Grab
PORTVERSION= 1.4.2
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ENV= ${ECHO_CMD} "N" |
MAN3= Image::Grab.3
diff --git a/graphics/p5-Image-Size/Makefile b/graphics/p5-Image-Size/Makefile
index 199dd5af8e6b..60f3192802b2 100644
--- a/graphics/p5-Image-Size/Makefile
+++ b/graphics/p5-Image-Size/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tolid@tolid.eu.org
COMMENT= Perl5 module to determine the size of images in several common formats
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= imgsize.1
MAN3= Image::Size.3
diff --git a/x11-fm/p5-PerlFM/Makefile b/x11-fm/p5-PerlFM/Makefile
index efc0be8a7867..53d96bd94171 100644
--- a/x11-fm/p5-PerlFM/Makefile
+++ b/x11-fm/p5-PerlFM/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: x11-fm/p5-PerlFM
-# Date created: 2009-10-19
-# Whom: Zane C, Bowers <vvelox@vvelox.net>
-#
+# Created by: Zane C, Bowers <vvelox@vvelox.net>
# $FreeBSD$
-#
PORTNAME= PerlFM
PORTVERSION= 0.2.0
@@ -26,7 +22,8 @@ BUILD_DEPENDS= p5-Gtk2>=1.060:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
p5-Dir-Watch>=0.0.0:${PORTSDIR}/devel/p5-Dir-Watch
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= PerlFM.3