aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-28 02:52:18 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-28 02:52:18 +0000
commit15cf9c98131ae36cf473855c49e4fe6503ad5abb (patch)
tree049996b2d63dd73c181296c804c668563606a76b
parent450f61db857719e555613e03a4684d54c1f3ca4f (diff)
downloadports-15cf9c98131ae36cf473855c49e4fe6503ad5abb.tar.gz
ports-15cf9c98131ae36cf473855c49e4fe6503ad5abb.zip
Notes
-rw-r--r--security/p5-IO-Socket-SSL/Makefile33
-rw-r--r--security/p5-IO-Socket-SSL/distinfo4
2 files changed, 18 insertions, 19 deletions
diff --git a/security/p5-IO-Socket-SSL/Makefile b/security/p5-IO-Socket-SSL/Makefile
index c6feedf73b9f..4f8bce04e021 100644
--- a/security/p5-IO-Socket-SSL/Makefile
+++ b/security/p5-IO-Socket-SSL/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= IO-Socket-SSL
-PORTVERSION= 1.74
+PORTVERSION= 1.76
CATEGORIES= security perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:SULLR
@@ -15,36 +15,35 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jadawin@FreeBSD.org
COMMENT= Perl5 interface to SSL sockets
-RUN_DEPENDS= p5-Net-SSLeay>=1.21:${PORTSDIR}/security/p5-Net-SSLeay
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= p5-Net-SSLeay>=1.21:${PORTSDIR}/security/p5-Net-SSLeay
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+OPTIONS_DEFINE= EXAMPLES IDN IPV6
PERL_CONFIGURE= yes
INSTALL_TARGET= pure_install
MAN3= IO::Socket::SSL.3
-
-OPTIONS_DEFINE= IDN IPV6
-IDN_DESC= International Domain Names (IDN) support
-IPV6_DESC= IPv6 support
-
-.if !defined(NOPORTEXAMPLES)
PORTEXAMPLES= *
-post-install:
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/example/* ${EXAMPLESDIR}
-.endif
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIDN}
-RUN_DEPENDS+= p5-Net-LibIDN>=0:${PORTSDIR}/dns/p5-Net-LibIDN
+RUN_DEPENDS+= p5-URI>=1.50:${PORTSDIR}/net/p5-URI
.endif
.if ${PORT_OPTIONS:MIPV6}
-RUN_DEPENDS+= p5-IO-Socket-INET6>=0:${PORTSDIR}/net/p5-IO-Socket-INET6
+RUN_DEPENDS+= p5-IO-Socket-IP>=0.11:${PORTSDIR}/net/p5-IO-Socket-IP \
+ p5-Socket>=1.95:${PORTSDIR}/net/p5-Socket
+.endif
+
+post-install:
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${EXAMPLESDIR}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/example/* ${EXAMPLESDIR}/
.endif
-regression-test:
- @(cd ${WRKSRC} && ${PERL} ${CONFIGURE_SCRIPT} && ${MAKE} test)
+regression-test: build
+ cd ${WRKSRC}/ && ${MAKE} test
.include <bsd.port.mk>
diff --git a/security/p5-IO-Socket-SSL/distinfo b/security/p5-IO-Socket-SSL/distinfo
index 3ea1660b3b10..7c112988dd44 100644
--- a/security/p5-IO-Socket-SSL/distinfo
+++ b/security/p5-IO-Socket-SSL/distinfo
@@ -1,2 +1,2 @@
-SHA256 (IO-Socket-SSL-1.74.tar.gz) = e080fae93663322a49c2cdf3eeeb5cad7bd9bf7ad9dd9f0147ddb57573fc2800
-SIZE (IO-Socket-SSL-1.74.tar.gz) = 75282
+SHA256 (IO-Socket-SSL-1.76.tar.gz) = a14d07edf8a1839481564ba9f9e9a07ecc95f51914e62a9264b4e858268d1870
+SIZE (IO-Socket-SSL-1.76.tar.gz) = 75442