aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2005-01-21 07:52:33 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2005-01-21 07:52:33 +0000
commit16155fe3c9828ae5118b4726208e01b0daaaaad1 (patch)
tree0c2160d7008995694b3ab2a8b60a29f8941cab5b
parent6f5d92ea8c67eb5ae5285698ceb6b9979f9a6588 (diff)
downloadports-16155fe3c9828ae5118b4726208e01b0daaaaad1.tar.gz
ports-16155fe3c9828ae5118b4726208e01b0daaaaad1.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Kwiki-PagePrivacy/Makefile34
-rw-r--r--www/p5-Kwiki-PagePrivacy/distinfo2
-rw-r--r--www/p5-Kwiki-PagePrivacy/pkg-descr8
-rw-r--r--www/p5-Kwiki-PagePrivacy/pkg-message15
-rw-r--r--www/p5-Kwiki-PagePrivacy/pkg-plist4
6 files changed, 64 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b2ddf5b617e5..291596d8c7d5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -502,6 +502,7 @@
SUBDIR += p5-Kwiki-Atom
SUBDIR += p5-Kwiki-GDGraphGenerator
SUBDIR += p5-Kwiki-NewPage
+ SUBDIR += p5-Kwiki-PagePrivacy
SUBDIR += p5-Kwiki-RecentChanges
SUBDIR += p5-Kwiki-RecentChangesRSS
SUBDIR += p5-Kwiki-Revisions
diff --git a/www/p5-Kwiki-PagePrivacy/Makefile b/www/p5-Kwiki-PagePrivacy/Makefile
new file mode 100644
index 000000000000..988cc82804c6
--- /dev/null
+++ b/www/p5-Kwiki-PagePrivacy/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Kwiki-PagePrivacy
+# Date created: Jan 21 2005
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Kwiki-PagePrivacy
+PORTVERSION= 0.10
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Kwiki
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Kwiki PagePrivacy Plugin
+
+BUILD_DEPENDS= ${SITE_PERL}/Kwiki.pm:${PORTSDIR}/www/p5-Kwiki
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Kwiki::PagePrivacy.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Kwiki-PagePrivacy/distinfo b/www/p5-Kwiki-PagePrivacy/distinfo
new file mode 100644
index 000000000000..e53ed17a6b08
--- /dev/null
+++ b/www/p5-Kwiki-PagePrivacy/distinfo
@@ -0,0 +1,2 @@
+MD5 (Kwiki-PagePrivacy-0.10.tar.gz) = 76f9031ad1be6f2c2fa7d6443acd1b67
+SIZE (Kwiki-PagePrivacy-0.10.tar.gz) = 8437
diff --git a/www/p5-Kwiki-PagePrivacy/pkg-descr b/www/p5-Kwiki-PagePrivacy/pkg-descr
new file mode 100644
index 000000000000..68e07e0c67d1
--- /dev/null
+++ b/www/p5-Kwiki-PagePrivacy/pkg-descr
@@ -0,0 +1,8 @@
+Kwiki::PagePrivacy is a plugin that lets you mark individual pages as:
+
+ * Public - normal readable/writable
+ * Protected - readonly to everyone except the control group.
+ * Private - invisible to everyone but the control group.
+
+WWW: http://search.cpan.org/dist/Kwiki-PagePrivacy/
+Author: Brian Ingerson <INGY at cpan.org>
diff --git a/www/p5-Kwiki-PagePrivacy/pkg-message b/www/p5-Kwiki-PagePrivacy/pkg-message
new file mode 100644
index 000000000000..0b369436e5b2
--- /dev/null
+++ b/www/p5-Kwiki-PagePrivacy/pkg-message
@@ -0,0 +1,15 @@
+/* ================================================================= */
+Note:
+ Kwiki-PagePrivacy plugin installed! Now you should add
+ to your kwiki in kwiki installation directory:
+
+$ cd cgi-bin/my-kwiki
+$ kwiki -add Kwiki::PagePrivacy
+
+ To active PagePrivacy, please check official site:
+
+URL: http://www.kwiki.org/?KwikiPagePrivacy
+
+ Remeber to properly setup your .htaccess file
+
+/* ================================================================= */
diff --git a/www/p5-Kwiki-PagePrivacy/pkg-plist b/www/p5-Kwiki-PagePrivacy/pkg-plist
new file mode 100644
index 000000000000..fede0efecff8
--- /dev/null
+++ b/www/p5-Kwiki-PagePrivacy/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Kwiki/PagePrivacy.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Kwiki/PagePrivacy/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Kwiki/PagePrivacy
+@unexec rmdir %D/%%SITE_PERL%%/Kwiki 2>/dev/null || true