aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2024-11-12 12:06:22 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2024-11-12 12:06:22 +0000
commit167ecf6119de60880655a6de415463352da31ad8 (patch)
treed9f6c5416d4b8b17f87a97c6ab91896efd6805f2
parent3f94bf7607e938be424791e657c394ff9f1fa403 (diff)
-rw-r--r--graphics/libheif/Makefile3
-rw-r--r--graphics/libheif/distinfo6
-rw-r--r--graphics/libheif/files/patch-libheif_api_libheif_heif.h11
-rw-r--r--graphics/libheif/files/patch-libheif_context.cc11
4 files changed, 4 insertions, 27 deletions
diff --git a/graphics/libheif/Makefile b/graphics/libheif/Makefile
index d1044a15d943..29f4312203de 100644
--- a/graphics/libheif/Makefile
+++ b/graphics/libheif/Makefile
@@ -1,6 +1,5 @@
PORTNAME= libheif
-DISTVERSION= 1.19.1
-PORTREVISION= 1
+DISTVERSION= 1.19.3
CATEGORIES= graphics
MASTER_SITES= https://github.com/strukturag/${PORTNAME}/releases/download/v${DISTVERSION}/
diff --git a/graphics/libheif/distinfo b/graphics/libheif/distinfo
index dcfeae3ad8fc..cd5f0d5b34c9 100644
--- a/graphics/libheif/distinfo
+++ b/graphics/libheif/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1730562330
-SHA256 (libheif-1.19.1.tar.gz) = 994913eb2a29c00c146d6f3d61e07d9ff0d8e9eccb0624d87e4be8b108c74e4b
-SIZE (libheif-1.19.1.tar.gz) = 1649119
+TIMESTAMP = 1731406330
+SHA256 (libheif-1.19.3.tar.gz) = 1e6d3bb5216888a78fbbf5fd958cd3cf3b941aceb002d2a8d635f85cc59a8599
+SIZE (libheif-1.19.3.tar.gz) = 1714718
diff --git a/graphics/libheif/files/patch-libheif_api_libheif_heif.h b/graphics/libheif/files/patch-libheif_api_libheif_heif.h
deleted file mode 100644
index 64164273fb82..000000000000
--- a/graphics/libheif/files/patch-libheif_api_libheif_heif.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- libheif/api/libheif/heif.h.orig 2024-11-01 10:56:56 UTC
-+++ libheif/api/libheif/heif.h
-@@ -2363,7 +2363,7 @@ struct heif_encoding_options
-
- // Set this to the NCLX parameters to be used in the output image or set to NULL
- // when the same parameters as in the input image should be used.
-- const struct heif_color_profile_nclx* output_nclx_profile;
-+ struct heif_color_profile_nclx* output_nclx_profile;
-
- uint8_t macOS_compatibility_workaround_no_nclx_profile;
-
diff --git a/graphics/libheif/files/patch-libheif_context.cc b/graphics/libheif/files/patch-libheif_context.cc
deleted file mode 100644
index a82b5b02d4f8..000000000000
--- a/graphics/libheif/files/patch-libheif_context.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- libheif/context.cc.orig 2024-11-01 10:56:56 UTC
-+++ libheif/context.cc
-@@ -1154,7 +1154,7 @@ Result<std::shared_ptr<ImageItem>> HeifContext::encode
- heif_encoding_options options = in_options;
-
- if (const auto* nclx = output_image_item->get_forced_output_nclx()) {
-- options.output_nclx_profile = nclx;
-+ options.output_nclx_profile = const_cast<heif_color_profile_nclx*>(nclx);
- }
-
- Result<std::shared_ptr<HeifPixelImage>> srcImageResult = output_image_item->convert_colorspace_for_encoding(pixel_image,