aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-05 19:59:10 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-05 19:59:10 +0000
commit16b3d843d90f88030390de0a8d41ca724f7e9d76 (patch)
tree039aed9eb8fb4231eaab45a48d4fc46f3cff121c
parente24e2836902b1fcbb49f8024871986ce4f87e538 (diff)
downloadports-16b3d843d90f88030390de0a8d41ca724f7e9d76.tar.gz
ports-16b3d843d90f88030390de0a8d41ca724f7e9d76.zip
Notes
-rw-r--r--net/rsync/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 2b4a260cb759..f0ec030e4df9 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -29,6 +29,7 @@ USE_RC_SUBR= rsyncd
SUB_LIST= NAME=rsyncd
INSTALL_TARGET= install-strip
+TEST_TARGET= check
CONFIGURE_ARGS= --disable-debug --enable-ipv6 \
--with-rsyncd-conf=${ETCDIR}/rsyncd.conf
@@ -79,9 +80,14 @@ POPT_PORT_CONFIGURE_OFF= --with-included-popt
SSH_CONFIGURE_ON= --with-rsh=ssh
SSH_CONFIGURE_OFF= --with-rsh=rsh
-.include <bsd.port.options.mk>
+ACL_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+ATIMES_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+FLAGS_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+ICONV_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+RENAMED_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+TIMELIMIT_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
-.if ${PORT_OPTIONS:MICONV} || ${PORT_OPTIONS:MFLAGS} || ${PORT_OPTIONS:MACL} || make(makesum) || ${PORT_OPTIONS:MTIMELIMIT} || ${PORT_OPTIONS:MATIMES} || ${PORT_OPTIONS:MRENAMED}
+.if make(makesum)
DISTFILES+= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
.endif
@@ -102,7 +108,4 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-test: build
- @(cd ${WRKSRC} && ${MAKE_CMD} check)
-
.include <bsd.port.post.mk>