aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2013-09-24 16:47:23 +0000
committerRenato Botelho <garga@FreeBSD.org>2013-09-24 16:47:23 +0000
commit172810a1035de217cebd549deeff5d9d1d5486e2 (patch)
tree3debfa29653b0d982265f0c4e1b5f126cf718c92
parent968182c75316b62832509d86765d8299cdd1338e (diff)
downloadports-172810a1035de217cebd549deeff5d9d1d5486e2.tar.gz
ports-172810a1035de217cebd549deeff5d9d1d5486e2.zip
Notes
-rw-r--r--audio/wmauda/Makefile2
-rw-r--r--devel/libslang2/Makefile6
-rw-r--r--devel/pecl-newt/Makefile2
-rw-r--r--editors/jed/Makefile2
-rw-r--r--math/slgrace/Makefile2
-rw-r--r--net-im/pidgin-hotkeys/Makefile2
-rw-r--r--www/dansguardian-devel/Makefile2
-rw-r--r--www/dansguardian/Makefile2
-rw-r--r--www/sarg/Makefile4
-rw-r--r--x11-wm/awesome/Makefile22
-rw-r--r--x11/gmrun/Makefile2
-rw-r--r--x11/xcb-util-image/Makefile6
-rw-r--r--x11/xcb-util-keysyms/Makefile6
-rw-r--r--x11/xcb-util-renderutil/Makefile6
-rw-r--r--x11/xcb-util-wm/Makefile6
15 files changed, 28 insertions, 44 deletions
diff --git a/audio/wmauda/Makefile b/audio/wmauda/Makefile
index 3f2be9a4bb35..d6159f89ce48 100644
--- a/audio/wmauda/Makefile
+++ b/audio/wmauda/Makefile
@@ -13,7 +13,7 @@ COMMENT= A port of wmxmms to GTK 2.x and Audacious
BUILD_DEPENDS= audacious:${PORTSDIR}/multimedia/audacious
RUN_DEPENDS= audacious:${PORTSDIR}/multimedia/audacious
-LIB_DEPENDS= mowgli:${PORTSDIR}/devel/libmowgli
+LIB_DEPENDS= libmowgli.so:${PORTSDIR}/devel/libmowgli
USES= gmake pkgconfig
NO_STAGE= yes
diff --git a/devel/libslang2/Makefile b/devel/libslang2/Makefile
index 475dc46470ec..56f67099c3ba 100644
--- a/devel/libslang2/Makefile
+++ b/devel/libslang2/Makefile
@@ -40,7 +40,7 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPCRE}
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
PLIST_SUB+= PCRE=""
.else
CONFIGURE_ARGS+= --without-pcre
@@ -48,7 +48,7 @@ PLIST_SUB+= PCRE="@comment "
.endif
.if ${PORT_OPTIONS:MPNG}
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
PLIST_SUB+= PNG=""
.else
CONFIGURE_ARGS+= --without-png
@@ -64,7 +64,7 @@ PLIST_SUB+= ICONV="@comment "
.endif
.if ${PORT_OPTIONS:MONIG}
-LIB_DEPENDS+= onig:${PORTSDIR}/devel/oniguruma4
+LIB_DEPENDS+= libonig.so:${PORTSDIR}/devel/oniguruma4
PLIST_SUB+= ONIG=""
.else
CONFIGURE_ARGS+= --without-onig
diff --git a/devel/pecl-newt/Makefile b/devel/pecl-newt/Makefile
index ee96116775f0..c2a44f97c9b6 100644
--- a/devel/pecl-newt/Makefile
+++ b/devel/pecl-newt/Makefile
@@ -12,7 +12,7 @@ COMMENT= PHP language extension for RedHat Newt library
LICENSE= PHP301
-LIB_DEPENDS= newt:${PORTSDIR}/devel/newt
+LIB_DEPENDS= libnewt.so:${PORTSDIR}/devel/newt
USE_PHP= yes
USE_PHPIZE= yes
diff --git a/editors/jed/Makefile b/editors/jed/Makefile
index adef06032c38..96ece9837f8c 100644
--- a/editors/jed/Makefile
+++ b/editors/jed/Makefile
@@ -13,7 +13,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
MAINTAINER= garga@FreeBSD.org
COMMENT= A SLang-based text editor
-LIB_DEPENDS= slang:${PORTSDIR}/devel/libslang2
+LIB_DEPENDS= libslang.so:${PORTSDIR}/devel/libslang2
CONFLICTS= jed-devel-[0-9]*
diff --git a/math/slgrace/Makefile b/math/slgrace/Makefile
index b212afed245a..c368b1308923 100644
--- a/math/slgrace/Makefile
+++ b/math/slgrace/Makefile
@@ -12,7 +12,7 @@ MASTER_SITE_SUBDIR= garga/slgrace/
MAINTAINER= garga@FreeBSD.org
COMMENT= A SLang module to plot graphs with grace
-LIB_DEPENDS= slang:${PORTSDIR}/devel/libslang2
+LIB_DEPENDS= libslang.so:${PORTSDIR}/devel/libslang2
RUN_DEPENDS= grace:${PORTSDIR}/math/grace
OPTIONS_DEFINE= DOCS
diff --git a/net-im/pidgin-hotkeys/Makefile b/net-im/pidgin-hotkeys/Makefile
index 3bcfbbbd378a..24a7d1bd84ac 100644
--- a/net-im/pidgin-hotkeys/Makefile
+++ b/net-im/pidgin-hotkeys/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= SF
MAINTAINER= garga@FreeBSD.org
COMMENT= A pidgin plugin that allows user to assign global hotkeys
-LIB_DEPENDS= purple:${PORTSDIR}/net-im/libpurple
+LIB_DEPENDS= libpurple.so:${PORTSDIR}/net-im/libpurple
BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
diff --git a/www/dansguardian-devel/Makefile b/www/dansguardian-devel/Makefile
index 108554ec0206..ab2a211665f9 100644
--- a/www/dansguardian-devel/Makefile
+++ b/www/dansguardian-devel/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= garga@FreeBSD.org
COMMENT= A fast, feature-rich web content filter for Squid proxy servers
RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
USE_RC_SUBR= dansguardian
USES= pkgconfig
diff --git a/www/dansguardian/Makefile b/www/dansguardian/Makefile
index ce55c2926f13..241c3d1e18b3 100644
--- a/www/dansguardian/Makefile
+++ b/www/dansguardian/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= garga@FreeBSD.org
COMMENT= A fast, feature-rich web content filter for Squid proxy servers
RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
USE_RC_SUBR= dansguardian
USES= pkgconfig
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index 88baad873266..a2cd405dc511 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -43,7 +43,7 @@ CONFIGURE_ARGS+=--disable-nls
.if ${PORT_OPTIONS:MGD}
CONFIGURE_ARGS+=--with-gd
-LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
+LIB_DEPENDS+= libgd.so:${PORTSDIR}/graphics/gd
.else
CONFIGURE_ARGS+=--without-gd
.endif
@@ -58,7 +58,7 @@ PLIST_SUB+= PHP="@comment "
.if ${PORT_OPTIONS:MPCRE}
CONFIGURE_ARGS+=--with-pcre
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
.else
CONFIGURE_ARGS+=--without-pcre
.endif
diff --git a/x11-wm/awesome/Makefile b/x11-wm/awesome/Makefile
index 4db66c2b9fac..2d13c6a34878 100644
--- a/x11-wm/awesome/Makefile
+++ b/x11-wm/awesome/Makefile
@@ -22,16 +22,16 @@ BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc \
${LUA_MODLIBDIR}/lgi/corelgilua51.so:${PORTSDIR}/devel/lua-lgi \
${LOCALBASE}/share/xml/docbook/4.5/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml-450
RUN_DEPENDS= ${LUA_MODLIBDIR}/lgi/corelgilua51.so:${PORTSDIR}/devel/lua-lgi
-LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo \
- ev:${PORTSDIR}/devel/libev \
- freetype:${PORTSDIR}/print/freetype2 \
- startup-notification-1:${PORTSDIR}/x11/startup-notification \
- xdg-basedir:${PORTSDIR}/x11/libxdg-basedir \
- xcb-util:${PORTSDIR}/x11/xcb-util \
- xcb-image:${PORTSDIR}/x11/xcb-util-image \
- xcb-keysyms:${PORTSDIR}/x11/xcb-util-keysyms \
- xcb-icccm:${PORTSDIR}/x11/xcb-util-wm \
- execinfo:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
+ libev.so:${PORTSDIR}/devel/libev \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification \
+ libxdg-basedir.so:${PORTSDIR}/x11/libxdg-basedir \
+ libxcb-util.so:${PORTSDIR}/x11/xcb-util \
+ libxcb-image.so:${PORTSDIR}/x11/xcb-util-image \
+ libxcb-keysyms.so:${PORTSDIR}/x11/xcb-util-keysyms \
+ libxcb-icccm.so:${PORTSDIR}/x11/xcb-util-wm \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo
USE_XZ= yes
USES= cmake iconv pkgconfig
@@ -61,7 +61,7 @@ IGNORE= cannot find dependency: The cairo exists but not with XCB support. Pleas
.endif
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS += dbus-1.3:${PORTSDIR}/devel/dbus
+LIB_DEPENDS += libdbus-1.so:${PORTSDIR}/devel/dbus
CMAKE_ARGS += -DWITH_DBUS=YES
.else
CMAKE_ARGS += -DWITH_DBUS=NO
diff --git a/x11/gmrun/Makefile b/x11/gmrun/Makefile
index a8187b770e41..ce7bc1d63941 100644
--- a/x11/gmrun/Makefile
+++ b/x11/gmrun/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF
MAINTAINER= garga@FreeBSD.org
COMMENT= A customizable program to run programs, with tab-completion
-LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
+LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt
OPTIONS_DEFINE= DOCS
diff --git a/x11/xcb-util-image/Makefile b/x11/xcb-util-image/Makefile
index d56c42ad6b42..25b4954aa49c 100644
--- a/x11/xcb-util-image/Makefile
+++ b/x11/xcb-util-image/Makefile
@@ -8,18 +8,14 @@ MASTER_SITES= http://xcb.freedesktop.org/dist/
MAINTAINER= garga@FreeBSD.org
COMMENT= A port of Xlib's XImage and XShmImage functions
-LIB_DEPENDS= xcb-util:${PORTSDIR}/x11/xcb-util
-#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
+LIB_DEPENDS= libxcb-util.so:${PORTSDIR}/x11/xcb-util
USE_BZIP2= yes
USES= gmake pkgconfig
USE_LDCONFIG= yes
USE_XORG= xcb xorg-macros
-#USE_XORG= xau xdmcp
-#USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-#CONFIGURE_ENV= GPERF="${LOCALBASE}/bin/gperf"
NO_STAGE= yes
post-patch:
diff --git a/x11/xcb-util-keysyms/Makefile b/x11/xcb-util-keysyms/Makefile
index aebfa8050913..e363d701aacf 100644
--- a/x11/xcb-util-keysyms/Makefile
+++ b/x11/xcb-util-keysyms/Makefile
@@ -8,18 +8,14 @@ MASTER_SITES= http://xcb.freedesktop.org/dist/
MAINTAINER= garga@FreeBSD.org
COMMENT= Standard X key constants and conversion to/from keycodes
-LIB_DEPENDS= xcb-util:${PORTSDIR}/x11/xcb-util
-#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
+LIB_DEPENDS= libxcb-util.so:${PORTSDIR}/x11/xcb-util
USES= gmake pkgconfig
USE_BZIP2= yes
USE_LDCONFIG= yes
USE_XORG= xcb xorg-macros
-#USE_XORG= xau xdmcp
-#USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-#CONFIGURE_ENV= GPERF="${LOCALBASE}/bin/gperf"
NO_STAGE= yes
post-patch:
diff --git a/x11/xcb-util-renderutil/Makefile b/x11/xcb-util-renderutil/Makefile
index 36d1e949133b..f6ad1ad64c0f 100644
--- a/x11/xcb-util-renderutil/Makefile
+++ b/x11/xcb-util-renderutil/Makefile
@@ -8,18 +8,14 @@ MASTER_SITES= http://xcb.freedesktop.org/dist/
MAINTAINER= garga@FreeBSD.org
COMMENT= Convenience functions for the Render extension
-LIB_DEPENDS= xcb-util:${PORTSDIR}/x11/xcb-util
-#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
+LIB_DEPENDS= libxcb-util.so:${PORTSDIR}/x11/xcb-util
USE_BZIP2= yes
USES= gmake pkgconfig
USE_XORG= xcb xorg-macros
USE_LDCONFIG= yes
-#USE_XORG= xau xdmcp
-#USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-#CONFIGURE_ENV= GPERF="${LOCALBASE}/bin/gperf"
NO_STAGE= yes
post-patch:
diff --git a/x11/xcb-util-wm/Makefile b/x11/xcb-util-wm/Makefile
index 696b9bf2803b..71cc0ca342af 100644
--- a/x11/xcb-util-wm/Makefile
+++ b/x11/xcb-util-wm/Makefile
@@ -8,18 +8,14 @@ MASTER_SITES= http://xcb.freedesktop.org/dist/
MAINTAINER= garga@FreeBSD.org
COMMENT= Framework for window manager implementation
-LIB_DEPENDS= xcb-util:${PORTSDIR}/x11/xcb-util
-#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
+LIB_DEPENDS= libxcb-util.so:${PORTSDIR}/x11/xcb-util
USE_BZIP2= yes
USES= gmake pkgconfig
USE_LDCONFIG= yes
USE_XORG= xcb xorg-macros
-#USE_XORG= xau xdmcp
-#USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-#CONFIGURE_ENV= GPERF="${LOCALBASE}/bin/gperf"
NO_STAGE= yes
post-patch: