aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Leres <leres@FreeBSD.org>2020-04-11 19:51:24 +0000
committerCraig Leres <leres@FreeBSD.org>2020-04-11 19:51:24 +0000
commit1877a6bad2792a8a17b9c321e8bd996e087f8ed6 (patch)
treed990eedaa240d95d5f9e959c0547765c2e38e58c
parent0f7db214939779434657c0f168b75777679208b9 (diff)
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-flynt/Makefile22
-rw-r--r--devel/py-flynt/distinfo3
-rw-r--r--devel/py-flynt/pkg-descr5
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3ef26e63569c..f8b8f2c140fb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4383,6 +4383,7 @@
SUBDIR += py-fluent-logger
SUBDIR += py-flufl.i18n
SUBDIR += py-flufl.lock
+ SUBDIR += py-flynt
SUBDIR += py-foolscap
SUBDIR += py-freebsd
SUBDIR += py-freebsd-sysctl
diff --git a/devel/py-flynt/Makefile b/devel/py-flynt/Makefile
new file mode 100644
index 000000000000..138edbe4b794
--- /dev/null
+++ b/devel/py-flynt/Makefile
@@ -0,0 +1,22 @@
+# Created by: Craig Leres <leres@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= flynt
+PORTVERSION= 0.46
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= leres@FreeBSD.org
+COMMENT= Convert Python scripts from string formatting to f-strings
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astor>0:devel/py-astor@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+GH_ACCOUNT= ikamensh
+
+.include <bsd.port.mk>
diff --git a/devel/py-flynt/distinfo b/devel/py-flynt/distinfo
new file mode 100644
index 000000000000..980686a7847e
--- /dev/null
+++ b/devel/py-flynt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1586627490
+SHA256 (ikamensh-flynt-0.46_GH0.tar.gz) = 3df7a37c44e582a84cc9a335c306207d2aace2db79a5fee919abce1c211dd95f
+SIZE (ikamensh-flynt-0.46_GH0.tar.gz) = 38930
diff --git a/devel/py-flynt/pkg-descr b/devel/py-flynt/pkg-descr
new file mode 100644
index 000000000000..9b41dd226d9b
--- /dev/null
+++ b/devel/py-flynt/pkg-descr
@@ -0,0 +1,5 @@
+flynt is a command line tool to automatically convert a project's
+Python code from old "%-formatted" and .format(...) strings into
+Python 3.6+'s "f-strings".
+
+WWW: https://github.com/ikamensh/